Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2265




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Packard Bell - GPS 400/Compasseo
 Customising the Packard Bell GPS400
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author  Topic Next Topic
Page: of 9

Gavoidix

Ireland
8 Posts

Posted - 04 mai 2006 :  17:46:08  Show Profile  Reply with Quote
That was problem. The Hardware buttons failed to zoom after CE wake up. However just loaded up Oziexplorer and buttons are active again. Strange.

Will reset and start all over just to check.

Just have to wait for TomTom.... Thanks again.
Go to Top of Page

PsiDOC

United Kingdom
139 Posts

Posted - 04 mai 2006 :  23:13:11  Show Profile  Reply with Quote
Gavoidix,
Destinator ND needs to be launced via the G400 icon for the hardware buttons to become active if you have upgraded the software. This is because the Dshell.exe needs to load the Hardbuttons software patch.
If you load the Destinator from the desktop the buttons are not loaded and hence your problem.

Regards,

Si

Packard Bell GPS 400 running on TomTom 5 / OziExplorer and Destinator ND (Not used!)
Currently working on yet another hack for the PB 400.
Go to Top of Page

Gavoidix

Ireland
8 Posts

Posted - 05 mai 2006 :  01:05:42  Show Profile  Reply with Quote
Cool. Thanks will try that right now. My heart was sad but now I'm happy!

Been playing with OziExplorer. Haven't taken it out yet but just whilst I'm here Does it work well whilst driving or is it just for walking/off roading?

Thanks.
Go to Top of Page

PsiDOC

United Kingdom
139 Posts

Posted - 05 mai 2006 :  20:57:33  Show Profile  Reply with Quote
Here's a shot of me offroading with OziExplorer running in my 4x4.



It tracked my progress regardless of how much tree cover there was, no false positions at all. I chose that route because of it's dense tree cover.
Walking, riding or driving OziExplorer is a brilliant tool. Unless I need TomTom's knowledge on how to get to an unknown destination I usually run OziExplorer in the truck whilst driving just to track my day on my home made OS map. Also added to the Packard Bell with the SirfStar 3 GPS chipset makes it just about the best you can get in my opinion.

Regards,

Si

Packard Bell GPS 400 running on TomTom 5 / OziExplorer and Destinator ND (Not used!)
Currently working on yet another hack for the PB 400.

Edited by - PsiDOC on 05 mai 2006 21:01:20
Go to Top of Page

Gavoidix

Ireland
8 Posts

Posted - 10 mai 2006 :  16:12:22  Show Profile  Reply with Quote
I must re read all through this as I might have missed something.
Destinator ND is working ( all the external buttons ) as you said PsiDoc but ... when in the menu and accessing the "middle" screen, like the MAP option it jumps to the main screen and then all the options freeze. I have to use Banana PC to escape and then reboot to get Destinator functional again.

I have Oziexplorer CE working well now. Very impressive and solves my off the beaten track problems with the Irish mapping ( until Q1 2006 Navteq maps arrive for ND !!) however I'm having problems connecting to Oziexplorer 3.5.4 trial version. The PB GPS400 shows the Connection but then.....nothing.
I presume that the PB is compatable with the PC version of Oziexplorer.

Not having the agyshell.dll shouldn't be an issue to above problems? I haven't found away to get it loaded up yet as I get a violation warning ( can't quite remember exact wording).

Your thoughts have been seriously helpful.

Thanks
Go to Top of Page

Commsman

United Kingdom
22 Posts

Posted - 10 mai 2006 :  20:43:04  Show Profile  Reply with Quote
1. agyshell.dll caused a problem for me the first time I unlocked my GPS440, but subsequently no problems. I think you need to do another soft reboot at some point in the process.
2. Secondly, unlike instructions I have read elsewhere on this forum, I do *not* need to unzip the cust400.cab file and copy the resulting cust400 *directory* on to my GPS400 - just the compressed cust400.cab is enough, along with the customised PhotoViewer app.
3. The process for unlocking is therefore:
- copy the two files to the PhotoViewer directory
- soft reboot
- run the PhotoViewer app and agree to over-write all and agree to the default locations for various things etc.
- soft reboot
- more activity
- another soft reboot - and this time everything is working.
So that is three soft re-boots in total.
Hope that is of some help.
Now I need to work out what it takes to customise the standard Start screen - as I keep losing the Banana PC buttons and WinCE toolbar and the only way to get them back at the moment is to hard reset everything! Doh


------------------
Life - still learning the ropes...
Go to Top of Page

Commsman

United Kingdom
22 Posts

Posted - 11 mai 2006 :  12:08:25  Show Profile  Reply with Quote
Still no joy trying to work out how to re-boot Banana (it is on my machine but has either stopped or is in the background) I know I could hard reset, but that gets tedious - what with adding the unlock hacks and re-installing all the faves etc - even if I do now have the folders mirrored on my PC).
I have had a look at the shema.ini in \DestinatorApps\DShell\Schema and this does seem to control the front panel interface and buttons, but adding an entry to this for another button to run Banana does not seem to work.
Anyone know if I am on the right track or am I barking up the wrong gum tree?

Here is the enrty in schema.ini I tried:

[WinCEBtn]
Rectangle=117,2,125,21 ;puts it at the top of the screen
Unselected=d_press.bmp ; a button that seemed handy
Selected=d_press.bmp
Pressed=d_press.bmp
Disabled=d_press.bmp
CaptionRectangle=116,3,120,15 ; der - dunno what this is
Caption=TxtDestinator ; probably redundant
Font=FontDestinator ; probably redundant
Color=0,0,0 ; probably redundant
Action=\Program Files\BananaPC\BananaPC.exe ; run that app!


------------------
Life - still learning the ropes...
Go to Top of Page

Commsman

United Kingdom
22 Posts

Posted - 11 mai 2006 :  12:18:52  Show Profile  Reply with Quote
UPDATED:
I now have a nicely modified interface for my GPS400 so TCMP and Banana can be run straight off the front screen.



The trick is to edit the schema.ini (located in the \DestinatorApps\DShell\Schema folder and to provide new icons for any new buttons in the same folder.

I made new icons for BananaPC and TCMP - see below.

Here is a link to my new schema.ini file with the two new buttons
http://www.jtcomms.co.uk/images/schema.ini.txt (save the file as schema.ini - I have added the txt extension for convenient viewing)

and here are the new icon files I created:




These images are shown in order:
v_sel.bmp v_pres.bmp v_unsel.bmp v_dis.bmp
b_sel.bmp b_pres.bmp b_unsel.bmp b_dis.bmp

Feel free to grab these images (right click and choose to save - or if you have Firefox or other better browser - just drag them off the page onto your desktop)

Of course you need to have unlocked the GPS400 to use this hack - and this is only a start. I have already made further improvements not shown here to run other useful tools - explorer, gsexplorer and showtaskbar being the main ones.

Cheers!

Edited by - Commsman on 11 mai 2006 18:37:26
Go to Top of Page

Compufix

United Kingdom
750 Posts

Posted - 11 mai 2006 :  19:24:54  Show Profile  Reply with Quote
The Caption, Font and Colour references in that .ini file are partially redundant, for the moment! In future versions ( i.e. 5.5) they are fully used. Please dont delete them, even though the .exe file is told to "do nothing" by them, if they are not present, it will cause problems.
With regard to the "caption rectangle" reference, play with the numbers, reboot, and see what happens :)

Moderator - "All in One" Navigation Systems

Edited by - Compufix on 11 mai 2006 19:45:59
Go to Top of Page

Commsman

United Kingdom
22 Posts

Posted - 11 mai 2006 :  19:40:30  Show Profile  Reply with Quote
Thanks Compufix - as you could probably tell, I was blundering around trying different things to see what worked.
As you point out, I have left a load of entries in the ini file that are clearly redundant at the moment but thought it would be wise to leave them alone until I knew more.
Your point about version 5.5, are you referring to the firmware version? I appear to have OSPB1.05 - nowhere near 5.5. If you are referring to Destinator - I already have 5.5.0.85 - I am confused!
Cheers

------------------
Life - still learning the ropes...
Go to Top of Page

Compufix

United Kingdom
750 Posts

Posted - 11 mai 2006 :  19:48:34  Show Profile  Reply with Quote
You are lucky! Most are loaded with the 1.02 OS. The 5.5 version of Destinator ND does indeed use these references. If you wish to play with them ,please do so, but ( teach a duck to suck eggs) do a full backup first!
I am, at present, getting the John Cleese Tomtom voice to work on this unit. When finished, ill post the "how to" with regard to altering the voice.

Moderator - "All in One" Navigation Systems

Edited by - Compufix on 11 mai 2006 19:50:10
Go to Top of Page

Commsman

United Kingdom
22 Posts

Posted - 11 mai 2006 :  23:41:02  Show Profile  Reply with Quote
quote:
Originally posted by Paul80

Using this method Would it be possible to have a button to launch TomTom.

I am pretty sure this would be possible. In principle you can use this technique to launch any exe file on the device. You simply put the correct path and application name in the an appropriate place in the schema.ini file. One thing I cannot check as I don't have TomTom is whether the hardware buttons would work (do you need these in TomTom??)

With TomTom, I do not know where the application executable file resides, but it should be a relatively simple matter to work this out.

Why don't you have a browse through the directories and check, then use this technique to temporarily re-program (say) the mp3 player button? Once you can show you can get one button working, try adding new ones as per my example schema.ini file.

Remember to soft reset each time you upload a new schema.ini file. The suck it and see.

Good luck!

Finally - I must say how dead chuffed I am to have acquired such an excellent and versatile bit of kit for such a ludicrously low price. I snapped it up after checking out the bargain basement and seeing the reports of unlocking the unit to WinCE and running TomTom. I really am amazed to see some people grumbling about it in other threads (although to be fair, 99.9% of the grumbles were about PB being complete dead heads as far as after sales support is concerned - how to win friends and influence people eh?). On top of it being a fast and accurate nav unit, I now have a pretty good multimedia device (the speed, stability, capability and quality of TCMP is realy impressive). My hat is off to the people behind all these variuous goodies which enable the greater flexibility of my GPS400.

p.s. - Compufix - do you work with PB or Navteq?? You sure seem to have a handle on the hardware/software involved in these devices. Regarding your comments about my Destinator version - I will check out the extra lines in the ini file to see if I can make any sense.

------------------
Life - still learning the ropes...
Go to Top of Page

Commsman

United Kingdom
22 Posts

Posted - 12 mai 2006 :  00:04:12  Show Profile  Reply with Quote
Ok now we have the front panel sorted out, I need a bit of advice:

1. What applications can be made to run on this device (are there any dll files I need to add to the OS to allow some to work - I assume a lot have been stripped out of WinCE Net Core - otherwise it wouldn;t be called "Core" ;-)

2. I assume I need to tweak some of the installation cab files using WinCE CAB Manager as described by PsiDoc in his thread on installing TomTom? I assume if I obtain installation cabs designed for "StrongARM / Xscale" and then switch them to looking like "All / CEF" they should work ok. I did this (rather hopefully in retrospect!) for Adobe Reader for PocketPC and guess what - it did not work! Maybe if I toned down my ambitions I could get some less demanding apps to run - but I have no feel at this moment of the criteria for knowing whether a particular app will run or not. Anyone have some ideas?

As was mentioned by someone earlier in this thread, what we need is a list of apps which are known to work on this platform. At least it should be our joint aim to build up such a list!

Cheers!

------------------
Life - still learning the ropes...
Go to Top of Page

Compufix

United Kingdom
750 Posts

Posted - 12 mai 2006 :  04:34:12  Show Profile  Reply with Quote
Commsman: No, i dont, im actually Licenced Aircraft Engineer :)

Moderator - "All in One" Navigation Systems
Go to Top of Page

Commsman

United Kingdom
22 Posts

Posted - 12 mai 2006 :  09:01:29  Show Profile  Reply with Quote
Paul80 - for the button graphics I use Fireworks - it is really a cinch to use layers and output buttons that have a variety of states (but like any sophisticated graphics editor, it has a learning curve). I could have used Photoshop or The Gimp or Serif PhotoPlus - all are capable of managing layers with aplomb.

Regarding BananaPC - It seems to be useful for window management - sometimes it is tricky to bring up the WinCE interface depending on the taskbar settings in use at the time (I am stil trying to get to grips with this actually). It could well be that BananaPC is redundant - Now I have had time to play for longer with the interface, running Explorer looks like the best way of bringing the task bar to the fron, from which I can show the desktop if I want to. This is work in progress for me.

Regarding 5.5 - I bought my GPS400 from eBay actualy from the eBay shop at http://stores.ebay.co.uk/PABS-Direct (I have no connection with these people).
It might be worth asking where he obtained his factory refurb units and working back to the place the firmware comes from. Tell you what - I will do this right now.

Cheers

------------------
Life - still learning the ropes...
Go to Top of Page
Page: of 9  Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,27 seconds. Powered By: Snitz Forums 2000 Version 3.4.05