Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2173




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 MioPocket 4.0 (Unlock for GPS devices)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 190

Janne

Sweden
92 Posts

Posted - 14 sept. 2010 :  10:03:11  Show Profile  Reply with Quote
Osprey
I think you missed a few points.
1. when removing MP using controlpanel and then reinstalling in a clean envronment, everything works!
2. Setting Autostandby=0 in MioPocket.ini has no effect as I still get the countdown and poweroff when disconnecting external power. (Having had a autostandby the system no longer works with power off/on)

Questions:
1. where is autostandby=0 used? Can I get an exe or a mscr from a earlier relese to fix/test it? If so which one(s)?
2. as the system seemingly gets screwed up after autostandby, are there any reqistry changes done when doing a autostandby?
Rgds

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

Greg Ziegler

6 Posts

Posted - 14 sept. 2010 :  14:42:40  Show Profile  Reply with Quote
I have a bricked Magellan 1470. Will I be able to load MioPocket to it OR must I first have a working unit?

If I try to run MioAutoRun.exe or any of the exe files from my desktop I get an error message that it's not a valid Win32 application.
I assume that means I have a corrupted files and need to download the zip again - Correct?

Thanks - Ziggy
Go to Top of Page

Gremlin

Germany
70 Posts

Posted - 14 sept. 2010 :  15:24:52  Show Profile  Reply with Quote
Thank you very much for MioPocket, Osprey.
Version 3 worked pretty well on my PNA and though i expected problems, when switching to the brand new V.4, i was still surprised by where the problems are.
I expected trouble with the new shell, but that seems to be about the only program that works actually flawless.

My device uses WinCE Core 4.2 and i used R63 with the updated scripts posted by you in this thread.

Found Bugs:
- The very first dialog that appears, requires split second timing to click on OK, before the default shell covers it up. I still have no idea, what i can choose there. ;)
- When clicking on explorer, i don't get a file manager, i get a new taskbar. I can have as many as i want or until the screen is full of them.
- I can't use any other file manager, because i only see the upper half of each line.
- In WMP only the buttons on the grayish bar and the time slider work. The rest is dead.
- In TCPMP, i can't use any dialogs, because they're mostly invisible. Clicking just blindly and then ok, gives an endless spinning hourglass.
- Clicking on a lot of icons in the shell, results in the icons just going into the background and then reemerging shortly after without the program ever starting.
- Trying to use any Windows dialogs to configure anything is impossible, since they all open up in the size of a icon + a title bar. Clicking on X or ok does nothing eighter.
- Double clicking on Control panel gives an empty window.
- Choosing to close MIO Pocket, freezes the whole PNA.

Non of the above was present in R59.


Last but not least a little request. The screen rotation tool(i guess RotateCE4.exe), turns the screen counter clockwise and back.
This way my stylus is pointing downward and is in danger of getting lost. Could you ask the author for a version, which turns the screen clockwise and back?
Thank you.

Regards Gremlin

Edited by - Gremlin on 14 sept. 2010 15:34:22
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 14 sept. 2010 :  18:04:41  Show Profile  Reply with Quote
Gremlin
If you go back somewhat through the pages you will find that the aygshell.dll is a problem. Look at page 55 in Osprey's response to me. Osprey's advice to me was also to use Miopockets explorer rather than your device's. That can be done in MioPocket settings. If you start with this we'll see what other problems there might be. Would be good if you also wrote what device you have.

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

Gremlin

Germany
70 Posts

Posted - 14 sept. 2010 :  21:17:31  Show Profile  Reply with Quote
I followed your advice Janne and it fixed the problem with the Windows dialogs as well as the file manager issue, the explorer taskbar craziness and the problem where i couldn't select anything in TCPMP.

However i have now another bug to report, possibly related to the flash problem i've read about. Trying to play a .flv file will now hang the whole device to the point, that the standby button is dead.

btw. I have a Medion MD95900 also known as MDPNA200s

Regards Gremlin
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 14 sept. 2010 :  21:41:31  Show Profile  Reply with Quote
Gremlin
Good to hear that it worked for you.
For the .flv files I don't know myself, but if you do a search
in Gpspassion (on top of this page) and search for "play .flv"
you'll find a lot of hits, some of which may apply to your
specific environment. If not, I'm sure that Osprey has better ideas.
Good luck

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

Gremlin

Germany
70 Posts

Posted - 14 sept. 2010 :  22:19:41  Show Profile  Reply with Quote
I'm sure he has, this is after all just a beta.
It was a bit unfortunate, that he choose to change so many things at once.
That complicates the bug squashing. ;-)

Regards Gremlin
Go to Top of Page

Tony Cat

Australia
1 Posts

Posted - 14 sept. 2010 :  23:01:08  Show Profile  Reply with Quote
Osprey & knight44
Firstly thanks for the program & follow up on bug fixes. Also running the same MY55T and have been trying to get the original software to work. It ios now doing so with the R52 version of Initialize.mscr as that was the version I had only just installed previously without giving it a full shakedown. I was unaware of the close button not showing up when running Ozi or the Navman software but I see I also have that problem. I have followed your threads and made changes to no avail except for the press and hold alteration to the task manager icon. I way wondering if this little problem got resolved?
Many thanks, Tony

Navman MY55T, Windows CE5.0, MioPocket V4, R64 on 8gb Scandisk micro SDHC
Go to Top of Page

knight44

Australia
17 Posts

Posted - 15 sept. 2010 :  00:21:10  Show Profile  Reply with Quote
Tony,

quote:
Originally posted by Tony Cat

Osprey & knight44
Firstly thanks for the program & follow up on bug fixes. Also running the same MY55T and have been trying to get the original software to work. It ios now doing so with the R52 version of Initialize.mscr as that was the version I had only just installed previously without giving it a full shakedown. I was unaware of the close button not showing up when running Ozi or the Navman software but I see I also have that problem. I have followed your threads and made changes to no avail except for the press and hold alteration to the task manager icon. I way wondering if this little problem got resolved?
Many thanks, Tony



Just to be clear, I'm running the Navman program via an icon (the MioMap icon) that I modified the path to read \FlashDisk\Program Files\Navman\SmartST_CE\SmartST_CE.exe. And I'm running R63 with the R61 Initialize.mscr - I don't have R62.

I haven't done anything about the Task Manager - I just use the other one (iTask).

The close button ("X") is present when running Navman and works, but the blue triangle isn't present. The blue triangle is present when running Ozi but doesn't work. The close button is not present. I use Ozi's own close button.

Cheers

Navman MY55T, Windows CE5.0, MioPocket V4, R63 on SDHC card
Go to Top of Page

sixtiesrule

5 Posts

Posted - 15 sept. 2010 :  02:36:43  Show Profile  Reply with Quote
quote:
Originally posted by sixtiesrule

quote:
Originally posted by Osprey

sixtiesrule,
It sounds like the navigation icon is set to run \Storage Card\MobileNavigator\MobileNavigator.exe, is that right? If so, doesn't that mean that there's something wrong with that file? Maybe it's missing, maybe it's the 8KB MioAutoRun.exe that comes with MioPocket and either MobileNavigator.mscr (MioAutoRun.mscr renamed) or MortScript.exe is missing (either of which would cause nothing to happen, as you reported). Aside from installing unlocks, you should also be able to copy any .exe to that folder and rename it to MobileNavigator.exe, such as FileManCE.exe (in MioAutoRun\Programs\FileManCE2) and Regedit.exe (in MioAutoRun\Programs), allowing you to do just about whatever you need on the device to get it back up and running. Instead of doing either just yet, though, I would get the MioPocket files in that folder sorted out, since MioPocket's startup menu gives you access to file managers, regedit and the keyboard (important for renaming files).







Hi Osprey, & thanks again for your help.
I have tried all your suggestions so far, but sadly none worked.
But I'm determined not to give up, lol.

I have noticed that when my original splash screen loads up, it is only the "Navigator" icon that doesn't work.
The others, such as "multimedia" & "ebook" do work.

So I was wondering if there is a way I could re-program those icons to point towards Miopocket, or even the FilemanCE2 file?
Go to Top of Page

Eggh

United Kingdom
4 Posts

Posted - 15 sept. 2010 :  03:05:53  Show Profile  Reply with Quote
>>Eggh,
If you use a file manager and run MioAutoRun\Programs\TaskMgr.exe directly, does it work? If not, then that rules out MortScript. As for checking DLL dependencies, EXE Check on the Tools page is what you want.
>>

Well, that's the point -- it doesn't work from the filemanager, as well many other programs (like devmanager etc). And I cannot check dll dependencies on my device as that software actually crashes :)) I.e. it loads the program, then I get explorer crash so I cannot yet get any dependencies atm.
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 15 sept. 2010 :  04:59:21  Show Profile  Visit Osprey's Homepage  Reply with Quote
knight44,
1. Good work. Ok, since I made only one significant change in Initialize.mscr between R61 and R63 and I've since undone it, I think that the problem may already be solved. If you'd like to test, I uploaded the newest Initialize.mscr a few pages back. If I had any inkling that it might fix your problem, I would've suggested it to you earlier. Oh well.
2. The close button is present and the blue triangle not present in Navman because it sounds like you edited the path of the MioMap icon, rather than the MioMap path in MioPocket Settings. If you'd like the close button gone and the blue triangle present, go into MioPocket Settings and edit the MioMap path to be SmartST_CE.exe. That way, MioPocket will know what to do when you run SmartST_CE.exe via the icon. If, for some reason, it doesn't work like you'd like, edit the icon's path (via the tap-and-hold method) to MioAutoRun\Scripts\MioMapLauncher.mscr.

bsweeny,
If you're determined to not give up, that's fine, but I've given you every suggestion and answer that I can think of and have spent more time over the last month helping you than anyone else. We haven't gotten anywhere and I'm only having to repeat the answers that I've already given you. I need to spend my time in more productive ways, like helping people with more-solvable (and more-serious) problems. If you, too, have any (unrelated to Flash), I'll be more than happy to answer.

realdreams,
It looks like v2.0 has dropped support for older devices. If you've downloaded it and it works, let me know, but my guess is that it won't. EDIT: I tested it, anyways, and nope, it doesn't work.

Brian Serda,
Please download the SubRoutines.mscr that I uploaded a couple of pages back and copy to MioAutoRun\Scripts.

matip,
Thanks for the report.

Janne,
In StartupPrograms.mscr, if AutoStandby is enabled, TroNik's PowerNotify.exe is run. That registers power notifications with WinCE that determine what to do when external power is connected and disconnected. You can read MioAutoRun\Programs\TroNik\PowerNotify.ini to see the scripts that it sets. As for why disabling AutoStandby made no change, you probably need to hard reset to wipe the existing power notifications.

Greg Ziegler,
Yes, you need a working device to use MioPocket. MioPocket is not an anti-bricking software, like you've assumed. It's software that runs on your device, not on desktop computer (which is why you get that error).

Gremlin,
1. Use the "Hide/Show Windows" and/or "Switch Windows" buttons on the MiniBar's MiniMenu to unhide the dialog.
2. Open MioAutoRun\Scripts\OrientationToggle.mscr in a text editor, find the line that runs RotateCE4.exe and simply duplicate the line two more times (so that it runs three times). To answer your question, I don't know who wrote the app.
3. Did .flv files work for you in R59? If you copy the MioAutoRun\Programs\Media Player folder from R59, it'll likely fix it. You'll lose the new features of the new version (the big thing being the skin), though.
4. I hear you about changing too many things at once. I definitely did that with R60 and have been kicking myself for that. Still, we're talking about R63 here, not R60, so all of the changes since R59 have occurred over four releases, not one. It just feels like one to you because you didn't try any of the releases in-between. I can't be blamed for that :)

Tony Cat,
Ozi Explorer is treated by MioPocket as a navigation app, like iGO and the like. That's why MioPocket's close button is killed when it's run. If you want it to display, open MioPocket.ini, find the Ozi Explorer= line and change the filename to something different than the actual filename, like oziexplorerce_REMOVE.exe. Then, tap and hold on the Ozi Explorer icon in the shell, choose Edit Icon and change the Execute path to the real filename (right now, it's set to MioPocket's script). Doing that will prevent MioPocket from doing anything special (such as killing the close button) when Ozi runs.

sixtiesrule,
Sure, by replacing their files the same way that you replaced MobileNavigator.exe, but if you could do that, you could just as easily change MobileNavigator.exe back. That's what we've been unable to do, since you have no USB connectivity or any other way to access the file system. This is unlikely to work, but you could try putting FileManCE.exe on the SD card and renaming it to the same as the "multimedia" or "ebook" executables (if you happen to know what they are) in the hopes that maybe, just maybe, they're setup to check for a new version of themselves on the SD card the same way as Mobile Navigator. I really doubt it, but you can try. Try it in various places on the card, including the root, the MobileNavigator folder and folders named the same as on the flash drive (i.e. since since <flashdrive>\MobileNavigator\MobileNavigator.exe runs <sdcard>\MobileNavigator\MobileNavigator.exe, if one of the other executables in <flashdrive>\Multimedia\multimedia.exe, you'd want to duplicate that on folder\filename on the SD card).

Eggh,
If you have a Windows PC, you can run Extras\Win32\Dependency Walker to get the same list of dependent DLLs. Also (or, if that path leads you nowhere), you can simply use one of the other task managers in MioPocket (iTaskMgr and Processes on the Tools page).

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 15 sept. 2010 13:37:38
Go to Top of Page

brokngel

6 Posts

Posted - 15 sept. 2010 :  08:24:57  Show Profile  Reply with Quote
Osprey,
By disabling GPS Time Sync in MioPocket Settings does it mean "disable the auto time sync"? had try it but wont help. i guess some other software using the same port ( com1: 38400 ) i using a China non-branded atlas4 2GB GPS. no prob when using Mio 3.0. i had try install using Mio 3.0, but change the TF Card which content Mio 4.0, and it can run. but i scare they will be some software corruption as i install using Mio 3.0, but running 4.0 software. Kindly assit. Thanks!
Go to Top of Page

DragonCZ

Czech Republic
3 Posts

Posted - 15 sept. 2010 :  09:04:58  Show Profile  Reply with Quote
Hi, i get often problem with freezing programs runing from SD card when i switch device to stand by mode and then switch on. Pleas is it possible to used PowerOff.mscr script with LockScreen to get more time to refresh communication between device and SD card thought i haven't istalled MioPocket? I've tryied to copy PowerOff.mscr, Variables.mscr, SubRoutines.mscr and app LockScreen onto Flash Disk and launch PowerOff but nothing happened. I've MortScript allready instaled and my device is MIO C720. What i do bad and what should i change? Thank you. DragonCZ
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 15 sept. 2010 :  11:17:16  Show Profile  Visit Osprey's Homepage  Reply with Quote
brokngel,
Hmm. I'm not sure. Try R64 and let me know if you still have the problem.

DragonCZ,
I have a C320, which is pretty much the same hardware as the C720. Simply wait 8 or so seconds after exiting standby mode before you touch the screen.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe
Go to Top of Page
Page: of 190 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,11 seconds. Powered By: Snitz Forums 2000 Version 3.4.05