Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2243




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 MioPocket 4.0 (Unlock for GPS devices)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 190

Harpo

Sweden
184 Posts

Posted - 02 sept. 2010 :  19:16:45  Show Profile  Reply with Quote
@Osprey

I think you missed this one, or dont you have any ideas??



quote:
Originally posted by Harpo

quote:
Originally posted by Osprey


Harpo and luissss81,
Please try copying this icons.xml and this settings.xml to MioAutoRun\Skin\iPhoneToday\icons. If that doesn't make any difference, try replacing MioAutoRun\Skin\iPhoneToday\iPhoneToday.exe, MioAutoRun\Skin\LockScreen\LockScreen.exe and MioAutoRun\Skin\SkinChanger\SkinChanger.exe with those from R61. If one of those fixes it, please tell me which. Thanks.






Nope!!

None of the suggested fixes solved anything, same problem.







C220 Miomap 3.3 Olivercp/split skin and Miopocket 4.0 v63 SD-based - IGO8.3/diMKa 1.5.9 /Navigon Mn6/Mn7.5 reality view light, IGO Primo 1.1
SE X1 IGO8-IGO Primo
Go to Top of Page

Dany123

9 Posts

Posted - 02 sept. 2010 :  19:18:25  Show Profile  Reply with Quote
when miopockent not instaled everytime i power up/power down it says the same thing"installation files not found on sd/mmc card".
If i instal any software mio/miopocket/igo it works fine until i plug off power.When i do that the device go to 0("again says the part with installation files not found on sd/mmc card") but only internal memory not the memory card(everything on mmc card is there nothing dissapears").That memory where is WiCce or whatever.
So basicaly as long as i keep it powered up everything goes fine.When i power down the device everything is "puff" and i need to "hack" again.Seems hes not saving any settings i do during any instal seesion.
To be clear the mmc remains intact everything thats on it is there the only memory that resets its the internal.Everything that i put there dissapear like he has some restore point or wathever.
to be sure those partition i have when i open my pna with windows mobile :
\(this is the main partition with windows)-this one gets everytime wiped
My flash disk-
Storage Card-this is where i have my files with igo kit.

Edited by - Dany123 on 02 sept. 2010 20:43:30
Go to Top of Page

Anakin

Brazil
33 Posts

Posted - 02 sept. 2010 :  20:04:45  Show Profile  Visit Anakin's Homepage  Reply with Quote
Osprey,
This new interface is awsome. The edit icons facility is very nice. Thanks for the effort put in place for this release. One question, when arranging icons, for example, copying icons from GPS to Favorites, the icons goes always on the first space avaiable after the last icon on the screen as expected. Now if I want to move the last icon between other 2 icons, is a bit difficult as one has to move all the other icons to the last place until you can have the icon on the order you want. Is it possible to have an icon dragged to the exact place you want it to be? Not sure if I did myself clear. Thanks again for the nice job!

Anakin
Mio C320, MioPocket 4.0 Release 68
http://clovis3d.blogspot.com/
http://clovis3dme.blogspot.com.br/
Go to Top of Page

desimtor

92 Posts

Posted - 02 sept. 2010 :  20:55:12  Show Profile  Reply with Quote
Copy the the icon and then go to the desired page and click and hold on the icon in front of which you want to insert the copied icon, the pop-up menu has a copy here option.

V7 NAV740; Asus R300; Asus R600; Sanyo 4370 (All running on CE5.0)
Go to Top of Page

aiiro

4 Posts

Posted - 02 sept. 2010 :  21:10:17  Show Profile  Reply with Quote
This is my first post here in the forum and I really appreciate that Osprey has created such nice thing. But since I own a Chinese X10 unit (from Pandawill) which, like it seems, cannot be hard reset back to factory settings, I must be really careful with implementing anything on the device, because I have read some occasions when people have bricked their devices with Miopocket or it's settings or some settings for some other soft. (Otherwise it's a pretty decent unit for that money). So my questions, with all due respect, are following (if I may):

1. How much does the installation of MioPocket affect the system? I mean, I know it uses different software for accomplishing different things and Mortscript to perform majority of actions and logics, but is there something else in those EXEs that changes something in the system? Or will it simply be enough to verify the safety by reading thru the MSCRs and .REG files?

2. How much does the changing of settings affect the system? I acknowledge that You are not the author of most of the software included, but do You remember a case for example when someone has bricked something with some type of soft or settings?

3. Would there be a possibility to manually perform the installation? I see there is no CAB file (which the X10 doesn't allow to install), but just to be on the sure side, is there a guide for doing that? Or the main MSCR is pretty much like a guide? If I just want to exclude some of the software, can I simply delete it plus the corresponding .REG and MSCR and files? Or will MioPocket give an error then?

What I am trying to achieve here is to be sure that any soft or setting that looks like it's suspicious to change some system files or settings will not brick my device - I would leave it out.

Thanks in advance.
Go to Top of Page

adriancristina

Romania
19 Posts

Posted - 02 sept. 2010 :  21:14:40  Show Profile  Reply with Quote
Hello Osprey. Good job and respect! Problem: mio c520, installed mp 4.0.62 version, gps software installed on sdcard 2gb: amigo, primo, spirit..and miomap 2008. Each software, amigo, igo, spirit works smoothly BUT miomap 2008 starts, splash scrren and exit to MP 4.0.
I have installed, formated my sd, installed 10 versions of miomap 2008 NO success at all. The others works like a charm. I can tell that with MP 3.0.59 EVERITHING, including miomap 2008 works veeery good. What happened with this 4.0???
Go to Top of Page

John Dough

Andorra
397 Posts

Posted - 02 sept. 2010 :  23:32:03  Show Profile  Reply with Quote
Adrianchristy Have you set up the path to the .exe for miomap2008?

Mio V505TV CE 6 16gb microsd card MIO V735TV MP4 R68 16gb sdhccard /MIO C710 4gb sd card MP4 R68 Igo83tts Miomap V3.3ttsVexia 2 android
Go to Top of Page

bsweeny

USA
159 Posts

Posted - 03 sept. 2010 :  02:33:22  Show Profile  Reply with Quote
*Osprey, tried what you said and nothing just an error message about not being able to find the executable swflash32.exe or its libraries! tried opening the flash in Miopocket and nothing so tried it in windows and the exe error as described above. so I ran executable check and it says aygshel3.dll what ever that means? well im tired and have to work tonight I tried renaming the other aygshel to 3 and nothing error, error, error... Just to let you know I am executing the mortscript everytime I turn on my devise. if you can help please do I have tried what I could.

Omnitech 16878 WinCe 4.2 Core, Tabs V1 Unlock Files With a Modified NK.Bin and Miopocket 4 R66 Unlock! :-D
Go to Top of Page

wayway

Malaysia
5 Posts

Posted - 03 sept. 2010 :  04:37:32  Show Profile  Reply with Quote
Hi Osprey,

After unzip R62 and copied all the files into the SD card, I was not able to see any file at all in file manager unless connecting the device (with SD card in)via USB cable or read the SD card using card reader. So, basically i can't invoke the installation. I had tried hard reset the device also in vain, took out and put back in the SD card also could not kick start the installation. Guess the device just can't read the SD card. But with R59 it had no problem at all. I found the problem is with the MioAutoRun.exe file for as soon as i copied it into the SD card, suddenly all files went "missing" in SD card. But there all there for I can view them all via USB cable or card reader.

Rgds.


[quote]Originally posted by Osprey

wayway,
You haven't explained how installation failed. What happens on the screen, does the start menu display, how far does the installation get, what are the last lines in MioAutoRun\Backup\InstallLog.txt, etc.?

Go to Top of Page

antonis71

Greece
32 Posts

Posted - 03 sept. 2010 :  08:03:54  Show Profile  Reply with Quote
Osprey,

Thanks for the amazing new miopocket. Two bugs I noticed are that when I hard reset miopocket loses the settings for wallpaper and Gapi

MIO C320b
Go to Top of Page

Big Burgo

Australia
7 Posts

Posted - 03 sept. 2010 :  08:52:46  Show Profile  Reply with Quote
Hi Osprey, I don't always run the port scan utility, I just did it in this instance first because it's quicker than loading IGO.
With both programs,Igo and the portscan utility, after I renamed the mioautorun folder back to it's original name, and without rebooting, they found the GPS receiver in a couple of seconds. I then rebooted and when MioPocket loaded, the GPS receiver couldn't be discovered again.

Laser Navig8r L-43
Samsung ARM920T-S3C244A
64 MB Ram
WinCe 5.00
MioPocket 4.0 V62
Kingston 2G SDMMC
Go to Top of Page

adriancristina

Romania
19 Posts

Posted - 03 sept. 2010 :  09:17:36  Show Profile  Reply with Quote
to John Dough
Yes i setup correctly the path to miomap 2008, not to one exe i tried, more than 6 exe of miomap 2008. i copied the same folder as i had on mp 3.0.59, all files without exceptions, put the correct path by editing the icon and starts, splash screen, blinking progress bar till the end and..exit.This is it. I think that mio2008 it is not compatible with mp 4.0.
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 03 sept. 2010 :  11:01:15  Show Profile  Visit Osprey's Homepage  Reply with Quote
Anyone with CE4 devices,
Do Flash games work for you in R62 with my FlashFix.zip (FYI, same link as before)? Did they work prior to that patch? I'm trying to determine if we have a problem here or no problem at all.

Harpo,
No, no new idea. Honestly, I don't really remember the problem, since it was weeks ago. Maybe a clean installation of R63 (when I upload it) will work better for you.

Dany123,
Oh, well, if it happens when MioPocket is not installed, then MioPocket is not causing it. Still, I'll help you briefly. I would try using one of the task managers in MioPocket to kill processes and, hopefully, one of those processes will be responsible for the behavior that you're experiencing. If you find one, you can remove it from startup via MioPocket Settings -> System -> Manager Startup Apps. If none of the running processes are responsible, then I don't know what's going on with your device and would suggest that you look around online for forums and help specific to your device's brand and model.

aiiro,
All of your questions are good ones that you're wise to ask and I'm happy to answer.
1. The "changes" to the system all come from the scripting (.mscr files) and the registry files (.reg files), as you surmised. Installation imports a bunch of registry files and sets some other registry settings via the scripting. Installation starts with MioAutoRun.mscr and quickly goes to Unlock.mscr, which handles the actual installation. After it completes and (usually) the device resets, Initialize.mscr processes, followed by ShellStart.mscr and, finally, StartupPrograms.mscr. So, you can follow that order, if you want to.
2. If I understand your question, it sounds like you're asking if it's still possible to mess things up after a successful installation of MioPocket. It is, but basically just through the MioPocket Settings menu, where you can enable/tweak things that installation didn't.
3. Well, there's only installation and bypassing installation. If you want to bypass it, you can run MioAutoRun\Scripts\ShellStart.exe, but a lot of apps won't work.
4. Ok, none of that was very helpful, I know, but I didn't want to ignore your questions, since I know how annoying that can be. My real answer to you is...

The only real danger that I'm aware of with no-name Chinese units (and others with persistent registries) is in the installation of the keyboard and Transcriber drivers. Both are no longer installed by default and should now refuse to install on devices such as yours (both of which haven't always been the case, so the "brick" cases that you're reading about may've been with really old releases). If you want to be absolutely certain (and it sounds like you do), however, delete MioAutoRun\Scripts\InstallKeyboardDriver.mscr and InstallTranscriberDriver.mscr. That way, it's impossible for them to run, both now and later on (ex. by enabling them in MioPocket Settings). Also, you should know that installation makes a number of backups of registry information so that, even if something goes wrong, you should be able to restore old settings.

In all, I think that MioPocket is pretty safe on even devices like yours. I've heard only success stories this year and haven't heard any "brick" stories, so I think that I may've ironed out all of the problems. That said, there *is* a bug in R62 which could *possibly* cause a problem for you. If you don't want to wait for the next release, delete MioAutoRun\Registry\JOTKBD.reg and MioAutoRun\Registry\480x272\JOTKBD_480x272.reg, just to be safe.

adriancristina,
It may just be that, by default, it's running the wrong application. Go into MioPocket Settings -> General -> Edit Navigation Paths and change the MioMap path. The three MioMap 2008 possibilities are...
\My Flash Disk\Program Files\Navman\AppStartupSec.exe
\My Flash Disk\Program Files\Navman\SmartST_CE\SmartST_CE.exe
\My Flash Disk\Program Files\MioMap\MioMap.exe
...so try the two that it's not currently set to. If that works, I'm interested in hearing which one it was on and which one worked for you.

bsweeny,
If you're getting an error about missing libraries, I suspect that you didn't something right, probably in the renaming.

wayway,
The only way that that might make sense is if your device is setup to periodically check the SD card for a MioAutoRun.exe and run it if it's found. If that's the case, the only thing that I can see it being is that your device doesn't like MortScript.exe (which gets run when the dummy MioAutoRun.exe does). You could try copying MioAutoRun.exe but not MortScript.exe to see. If so, you could try copying the MortScript.exe from R59, instead.

antonis71,
I guess that you were setting the wallpaper through the Desktop Properties dialog box. I had meant for that to work, but it looks like the setting saved in MioPocket.ini was getting forcibly enforced during installation, so the setting stuck only if set via MioPocket Settings. I'll correct that. As for GAPI, I just tested it and it saved it. Did you happen to disable regular registry backup in MioPocket Settings? If so, you'll need to either re-enable that or manually press the Backup Registry icon on the Settings page.

Big_Burgo,
Ok, in that case, you'll need to narrow down to where the problem is. Start by opening MioAutoRun\MioPocket.ini, setting AlwaysRunning=0 (it's at the very bottom of the [Apps] section) and soft resetting, then opening a file manager and running iGO8.exe directly. If that doesn't solve it, then the problem is not with the launch scripts. In that case, try going into MioPocket Settings -> System -> Configure AutoLaunch, disabling MioPocket autolaunch and soft resetting, then double-clicking the My Device icon on the desktop and running iGO8 again. If that doesn't solve it, then the problem is not in ShellStart.mscr or StartupPrograms.mscr and, therefore, is likely in Unlock.mscr or Initialize.mscr. What you could try doing in both is, every here and there, add...
RunWait("<full path to iGO8.exe>")
...substituting the actual full path, of course. Then, during instalation and startup, iGO8 will run, wait for you to exit it (make sure that you have the sys.txt command that enables the exit button), then continue on. If the GPS works in iGO at one point and, 50 lines lower in the script, no longer works, then you've narrowed things down to something in those 25 lines.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 03 sept. 2010 :  14:01:44  Show Profile  Reply with Quote
Osprey
Sorry for not answering more quickly.
Anyway, sometimes it works, the off/on sequence, sometimes not. However, I found something that might be of help. When I was browsing the system using CE Commander and then power off/on, CE Commander comes back and I am still able to browse everything including the Storage Card. But when trying to close CE Commander I get "Cannot find WindowClose....". I tried using MortScript from R59 without success.

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

bsweeny

USA
159 Posts

Posted - 03 sept. 2010 :  15:06:44  Show Profile  Reply with Quote
Osprey, I think I did it right. to the t as you instructed me

Omnitech 16878 WinCe 4.2 Core, Tabs V1 Unlock Files With a Modified NK.Bin and Miopocket 4 R66 Unlock! :-D
Go to Top of Page
Page: of 190 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,06 seconds. Powered By: Snitz Forums 2000 Version 3.4.05