Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2265




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 MioPocket 4.0 (Unlock for GPS devices)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 190

John Dough

Andorra
397 Posts

Posted - 27 août 2010 :  22:16:39  Show Profile  Reply with Quote
quote:
Originally posted by BomBastiC

There seem to be some bug with the uninstall script under Mio Moov.
'Remove-MioPocket.mscr' have the following line:
RegDelete("HKLM", "Loader", "Launch9999")
While, at least on my Moov360, "Loader" should be replaced with "init".

Another problem, which was the reason that made me remove MioPocket, is while runnig different versions of MioMap.
MioPocket just keep popping out of the program.
I tried to run Miomap 3.3 and I could only see the screen for a few seconds before it was switched into MioPocket's "Loading..." screen.
Whenever



On my Moov 370 MP works perfectly with version R59 and I have moov/Mio3.3/Igo8 on it using a 4gb sdcard, I moved a lot of map files/pois from the flash to the sd card and this speeded things up considerably.

Mio V505TV CE 6 16gb microsd card MIO V735TV MP4 R68 16gb sdhccard /MIO C710 4gb sd card MP4 R68 Igo83tts Miomap V3.3ttsVexia 2 android
Go to Top of Page

Sega dude

8 Posts

Posted - 28 août 2010 :  01:10:46  Show Profile  Reply with Quote
Has anyone gotten this working on a Nextar g4-06? I prepared the SD card then touched the navigator icon like the readme said and nothing happened. So I did a hard reset then I got to the Malta Rom update utility v1.1. It said it couldn't find the SD card that had the update on it. How do I get it to boot?
Go to Top of Page

Sora1421

15 Posts

Posted - 28 août 2010 :  01:16:51  Show Profile  Reply with Quote
I recently purchased this ebay unit.

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=290461845796&viewitem=&sspagename=STRK%3AMEWNX%3AIT

and I cannot figure out how to install miopocket on it.

I tried to do it before on a unit I purchased and It was much easier to install, it's just the unit didnt like miopocket and would shut off at the use of any application so I got this one.

However, the SD card format is much different.

In the root, there is a folder "IGO8 480x272 USA 20090710"

inside that folder is many more folders for the gps itself. I see the file "iGO8.exe" and I tried placing the 3 files from miopocket inside that folder and renaming the mioautorun.exe to igo8.exe and the icon changes inside the folder, but it will not run.

Im sure this is a common set-up as a lot of people use chinese units. ANy help is greatly appreciated
Go to Top of Page

TiGuy82

15 Posts

Posted - 28 août 2010 :  01:36:44  Show Profile  Reply with Quote
Osprey,

I want to ask you if it's possible to create a script to open systeminformation.exe and hide the taskbar.

My idea is to use your unlock mode to call systeminformation using the MioAutoRun files and MortScript.exe renaming the mioautorun to CELauncher but I need a easy way to open systeminformation and hide the taskbar

Can you help me about it?

I did on this way but only calls the systeminformation! lol
Run("\SDMMC\Launchpad\systeminformation.exe")
Run("\SDMMC\Apps\TaskbarHide.exe")

Other problem, to use KILL i need to have the toolhelp, what's the code to copy it to the windows folder?

Call("SafeXCopy", SystemFolder\"toolhelp.dll", "\Windows", FALSE, FALSE) ?


Edited by - TiGuy82 on 28 août 2010 02:36:38
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 28 août 2010 :  04:53:48  Show Profile  Visit Osprey's Homepage  Reply with Quote
Everyone,
No feedback on my FlashFix.zip? I see that 11 people have downloaded it.

aiolos,
Have you installed R62 fresh yet (i.e. not just copied R62 over an earlier version)? Did it work in R60 or R61 or was R59 the last time? Is your "working backup" R59? If so, you could make a copy of that, rename its MioAutoRun\Scripts\SysInfo-Start.mscr to ShellStart.mscr, open Initialize.mscr and replace all instances of "SysInfo-Start" with "ShellStart", then copy Initialize.mscr, ShellStart.mscr and StartupPrograms.mscr to your R62's MioAutoRun\Scripts folder and soft reset your R62. If the power button works, then it tells us that there's a problem in one of those three files and you could copy back R62's version one at time to narrow it down to one file. Two more things to try are replacing R62's System and Registry folders with the ones in the working backup.

MrFrem82,
Unfortunately, I think that you're going to continue to have problems with installation because of your folder structure. You may be better off simply running MioAutoRun\Scripts\Initialize.exe to run MioPocket, thus bypassing installation.

lucianu,
Try pressing the icon next to the keyboard icon and choosing "Select Keyboard" from the menu. You should get a pop-up with a number of other SIP keyboards. Try selecting those. If that doesn't help, then it looks like your device is one of those that doesn't like the SIP keyboard. In that case, go into MioPocket Settings->MiniBar->Set MiniBar Keyboard and choose JOTKBD.

bumbum,
1. Is that a backlight control script that you wrote? What's in it?
2. You're not being clear about what isn't working. Are you choosing "Kill startup app not listed here" or is it listed, you're selecting it and choosing "Delete App"?
3. When you minimize a nav app, I write the name of the window to the top of NavMinimize.mscr so that, when you're back at MioPocket's shell, pressing the NavMinimize triangle knows which app to un-minimize. You must've pressed the triangle when the power options menu was on the screen. Either blank out everything after the "savedWindow=" or re-copy the NavMinimize.mscr that I uploaded earlier.

Janne,
1. Do you happen to have AutoStandby enabled? If so, I suggest turning that off so that we can be sure that that's not it or is not complicating things. After that, the questions and steps that I just gave to aiolos are applicable to you, too.
2. When you say that the keyboard is "missing," do you mean to say that it worked once? If so, with which release and did it work with R59? If you've told me before, I apologize. It's that I can't remember everything about everyone's case, especially when people are having similar problems. There's just a huge difference between "X has never worked" and "X hasn't worked since Release X."

Sega dude,
Are you using R62 and did you set your navigation icon to run MioAutoRun.exe?

Sora1421,
You need to also rename MioAutoRun.mscr to iGO8.mscr. Really, though, there's a better way to go about it. Set it back to the original iGO8.exe, then copy MioAutoRun.exe, MioAutoRun.mscr and MortScript.exe to the root of the drive, then find in your device's menu where to set what the navigation icon runs. It's likely set to iGO8.exe right now. Set it to run MioAutoRun.exe. If that doesn't work, make sure that you're using R62. If you can't find where to set the navigation icon, you could just do what you were doing before with the MioAutoRun.exe/iGO8.exe and MioAutoRun.mscr/iGO8.mscr renaming in the iGO folder.

TiGuy82,
Try switching the order of the two lines. If that doesn't help, try running MioPocket's MioAutoRun\Programs\ShowTaskbar.exe (it hides, too), instead. As for killing, you don't need to script copying toolhelp.dll; simply copy it from MioPocket to the same folder as your MortScript.exe and MortScript will find it when the Kill command is processed.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 28 août 2010 04:56:53
Go to Top of Page

lucianu

Romania
4 Posts

Posted - 28 août 2010 :  07:31:11  Show Profile  Visit lucianu's Homepage  Reply with Quote
thanks but it was something weird about the keyboard problem because the SIP keyboard was not appearing up and the JOYKBD didnt worked, but after a while the SIP began to work again, and now its fully working (just have to update to 62).
Donno why but it feels like working better ... more responsive when i close apps and stuff not hanging at all.

b33n th3r3 d0n3 th4t

Mio Moov 500 ModelNr: N210
MioPocket 4.0 Release 61/62 (freezed)
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 28 août 2010 :  10:37:19  Show Profile  Reply with Quote
Osprey
I only had time to test the powerbutton, will get back later with the other things.
1. Disabled AutoStandby, tried the poweroff button on the C710 and using the 3308 buttoncode in Tronik's Powerbutton.ini.
Using the commands "off" or "reset" I can poweroff/on without losing the SD-card.
Using a path, Poweroff.mscr also works. The PowerPrompt.mscr does not work. This is a huge step forward. Thanks for your suggestion.
I also tried with Igo, no success, but I will try later
with the steps you gave to aiolos.
Thanks much

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

KhaKev

385 Posts

Posted - 28 août 2010 :  11:01:21  Show Profile  Visit KhaKev's Homepage  Reply with Quote
quote:
Originally posted by Osprey

Everyone,
No feedback on my FlashFix.zip? I see that 11 people have downloaded it.

With this fix it's working great on CE6 now. I've been using the flash loader.exe from Route66. Now I no longer need it and yours swFlash32.exe is much smaller in size. Good job Osprey! Thanks for fixing the path issues too. Sorry, I missed your comments earlier.

With Nitrogen, when play music and press minimize, music is still playing in the bg which is great, however maximize does not bring the GUI back. Have tried Switch Window and select Nitrogen without success. Only seeing bottom tool bar of Nitrogen.

Edited by - KhaKev on 28 août 2010 11:22:16
Go to Top of Page

aiolos

26 Posts

Posted - 28 août 2010 :  13:12:25  Show Profile  Reply with Quote
The way I installed R62 (uninstall in R61 didn't work even after copying the uninstall script from R62) was to delete the folder on the SD and the flash, copy the new release to the SD and hard reset. I believe this leaves no trace of the older version.
The last version that worked was, strangely enough, R61. I'm guessing from your answer that nothing has changed on those scripts between R61 and R62.

Navigon 8110, 480x272
WinCE 5.0, SIRF Star III
CPU 533MHz, RAM 128 MB
Go to Top of Page

MrFrem82

Italy
14 Posts

Posted - 28 août 2010 :  14:23:08  Show Profile  Reply with Quote
quote:
Originally posted by Osprey

MrFrem82,
Unfortunately, I think that you're going to continue to have problems with installation because of your folder structure. You may be better off simply running MioAutoRun\Scripts\Initialize.exe to run MioPocket, thus bypassing installation.


Can you explain me what does it mean? I mean, in that why i've to run every time Initialize.exe when i startup my device?
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 28 août 2010 :  15:22:46  Show Profile  Visit Osprey's Homepage  Reply with Quote
KhaKev,
1. That's great to hear. Thanks for letting me know.
2. By "maximize," do you mean the Hide/Show Windows button? That works for me with Nitrogen, as does selecting it in PocketNav (what you described doing). Try using the Hide/Show Windows button to minimize Nitrogen, rather than its build-in button, then Hide/Show Windows again to un-minimize it.

aiolos,
Yeah, the changes in R62 are minimal and shouldn't even have touched power-related settings. I would go back to R61 (with a fresh installation, i.e. wipe the MioAutoRun folder) to make sure that it worked. If it works, then you can try copying bunches of files from R62, hard resetting and re-installing after copy operation, until things stop working. What I mean by is, for example, copy R62's Scripts folder, re-install, copy R62's Registry folder, re-install, copy R62's System folder, re-install, and so on until the problem occurs, then work backwards by copying some of R61's back to narrow it down further.

MrFrem82,
Do this: open your MioAutoRun.mscr, erase everything in it and put...

RegWriteString("HKLM", "init", "Launch9999", "\Program Files\MioAutoRun\Scripts\Initialize.exe")
Run("\Program Files\MioAutoRun\Scripts\Initialize.exe")

That will make it so that Initialize.exe runs automatically at startup for you.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe
Go to Top of Page

bumbum

519 Posts

Posted - 28 août 2010 :  15:47:40  Show Profile  Reply with Quote
Osprey,
quote:
1. Is that a backlight control script that you wrote? What's in it?

It is just a little script to get the Becker internal backlight activatet the first time. (Later with another script I can steer backlight from 30-100%)In the releases before R6x, I set it at the beginning of unlock.mscr. There you didn't see it working, just a little flash and backlight is on 100%. Now with IPT, I see the Becker shell for few seconds, which is at least not nice. I believe starting of IPT is much CPU usage and might slow down the script. I set it now at the end of unlock.mscr and this seems to work better. This is when I identified that Buttons are back again. However, still I can not see the reason why this script should influent HW Buttons!? (was also working in R59)

#
Run("\My Flash Disk\MNAV\Shell.exe")
Sleep(50)
If ( WndExists( "BeckerShell" ) )
Close( "BeckerShell" )
EndIf
Sleep(100)
If ( ProcExists( "Shell.EXE" ) )
Kill( "Shell.EXE" )
EndIf
#
quote:
2. You're not being clear about what isn't working. Are you choosing "Kill startup app not listed here" or is it listed, you're selecting it and choosing "Delete App"?

Sorry. There is listed Launch.exe and Startup.exe(Windows). The last one, I can not see for what is good for and deleted it. But as I said, when I start settings again, it is still listed and it is not in Miopocket.ini. Seems adding startup apps is the same.

quote:
3. When you minimize a nav app, I write the name of the window to the top of NavMinimize.mscr so that, when you're back at MioPocket's shell, pressing the NavMinimize triangle knows which app to un-minimize.

I don't understand that, as you are always starting nav apps from IPT screen, so unminimize should be alwys IPT.
quote:
You must've pressed the triangle when the power options menu was on the screen.

Then it could make sense, my device sometimes interupts charging for a short time (for whatever reason), probably Autostandby could let the Power Menu appear. But Autostandby was disabled. How else can the Power Menu be on screen, when I start iGO from favorites?
quote:
Either blank out everything after the "savedWindow=" or re-copy the NavMinimize.mscr that I uploaded earlier.

I try that. Thanks!

Falk F8, only used for real car Navigation, Miopocket Rel. 5? installed / Becker 7928 test device for car and writing desk, always newest Miopocket version / Medion 4435 only test device on writing desk, always newest Miopocket version / Often others
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 28 août 2010 :  20:11:47  Show Profile  Reply with Quote
Osprey
The functioning release I have is R59 where standby and power off/on works. As far as keyboard is concerned, I get the pulldown menu so I can select the SIP keyboard of choice and also ControlPanels InputPanel (CP IP) I can select a SIP-keyboard, and also when going back to CP IP the selected keyboard is displayed.

I had no luck with the steps you suggested to aiolos re
the three mscrs. I also tried with R59's Registry and System folders but no success. Power off/on works when I use buttoncode 3308 in Tronik's powerbutton.ini file.

The SIP-keyboards. They do not work in R60, 61 or 62.
When pressing "Select keyboard" in minibar I get a popup saying "SIP List" nothing more. Trying the input panel I get a list of all SIP keyboards to choose from. However, the entry doesn't stay. When re-entering the input panel the input field is blank. See my reply on pg 41. The last functioning release is R59.

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

TiGuy82

15 Posts

Posted - 28 août 2010 :  20:36:12  Show Profile  Reply with Quote
Osprey,

I'm making how I want the unlock thanks to you!

Can you give me your Paypal email account? I'm a poor guy but I would like to give you $10 for your help!

Thanks
Go to Top of Page

aiolos

26 Posts

Posted - 28 août 2010 :  20:55:32  Show Profile  Reply with Quote
I did a hard reset without changing anything on my SD (I've added a few apps, icons etc) and I got the menu that says 'Run Miopocket' etc. At that point the power button was working. So I let it install again and same as before the power button isn't working.
So I'm guessing it's something that miopocket writes to the registry that causes the power button to stop functioning, as a hard reset only restores the registry and not the flash (at least it doesn't delete user created directories in the flash).
Anything new in R62 written to the registry ?
If it was on a pc, I'd use some registry monitor to see what gets written during installation. Can this be done on winCE ? Or maybe export the whole registry with R61 installed and R62 installed and compare ?

Navigon 8110, 480x272
WinCE 5.0, SIRF Star III
CPU 533MHz, RAM 128 MB
Go to Top of Page
Page: of 190 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 2,89 seconds. Powered By: Snitz Forums 2000 Version 3.4.05