Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2239




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 MioPocket 4.0 (Unlock for GPS devices)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 190

jwoegerbauer

1863 Posts

Posted - 23 août 2010 :  13:28:46  Show Profile  Visit jwoegerbauer's Homepage  Reply with Quote
@Osprey,

yesterday I've played around with Rel.62 (SD-free installation & IPT shell), and I've found some oddities:

Tools:

FileMan => takes about 10 secs to return to shell if got closed (temporarily only black screen visible)
Cmd Prompt => error: Script \Storage Card\MioAutoRun\Scripts\CommandPrompt.mscr not found. Waiting for existance of storage card
Light => takes about 20 secs to return to shell if got closed (temporarily only black screen visible)
Search => error: Cannot find TascalSearch (or one of its components) ...
Task Manager => no exit possibility given, must do at least a soft-reset
iTaskMgr => takes about 10 secs to return to shell if got closed (temporarily only black screen visible)
Ruler => takes about 10 secs to return to shell if got closed (temporarily only a patchwork screen visible)
Alarm => takes about 15 secs to return to shell if got closed (temporarily only black screen visible)
Screenshot => error: Cannot find vSnap (or one of its components) ...

Settings:

Free RAM => obviously misplaced here, because you can't set anything, only view
Volume => you get the "Power Options menu" presented if got closed

Favorites:

XnView => error: Cannot find XnPocket (or one of its components) ...


Shortcut-files in \MioAutoRun\Windows\Desktop:
Shortcut-files in \MioAutoRun\Windows\Programs (inclusive subfolders):

=> aren't path-fixed: they still point to \Storage Card\....


Perhaps there are more!?

Edited by - jwoegerbauer on 23 août 2010 19:51:19
Go to Top of Page

Harpo

Sweden
184 Posts

Posted - 23 août 2010 :  20:06:06  Show Profile  Reply with Quote
luissss81 is right, there is something going on with rel 62.
I got the same problem,first explorer then IPhone today perfomes an illegal op.
Not a chance to install this one on a C220.

After first installation, after reboot i got questions about new backgrounds and icons and if i wanted to backup the old ones, than comes the errors.
After turning power off (button)and on again Lockscreen.exe also makes an ill op.

Minibar and keybord works but the shell dont.

C220 Miomap 3.3 Olivercp/split skin and Miopocket 4.0 v63 SD-based - IGO8.3/diMKa 1.5.9 /Navigon Mn6/Mn7.5 reality view light, IGO Primo 1.1
SE X1 IGO8-IGO Primo

Edited by - Harpo on 23 août 2010 20:07:31
Go to Top of Page

petrica_velvet

Romania
8 Posts

Posted - 23 août 2010 :  21:32:35  Show Profile  Reply with Quote
HELLO OSPREY

Back with a question for Mio A 510 C with R62, how to activate Keyboard for
introducing a program key (ozy explorer) in parallel with a running navigation program
Go to Top of Page

matip

35 Posts

Posted - 23 août 2010 :  21:43:37  Show Profile  Reply with Quote
quote:
Originally posted by Osprey

matip and everyone else with NavMinimize problems,
This should fix that. Copy to MioAutoRun\Scripts: AlwaysRunning.mscr
Note that I've also re-uploaded R62 with the fix.

I confirm it works great
quote:
1. Perhaps it was waking up for the regular registry backup that occurs every 10 minutes. You could try disabling that in MioPocket Settings or MioPocket.ini. If that's not, it might be one of the CE notifications waking your device. You could try deleting them via Control Panel -> Scheduled Tasks.

I will try to investigate that path and will let you know the results.
quote:
2. The code is the way of determining on and off, so I don't know what you can do if they're the same. I don't have any idea of why this might work, but have you tried going back to R59 to see if it works there or not? Also, a nice re-format of your card and re-copying of a fresh R62 is never a bad idea, though you may've already done that.

I sorted that out. It turned out that I had to go to "Control Panel -> Power" and change default settings for "Battery Power" to Never/Never/Never (the same as for "AC Power"). In such a case my device generates 1058 for OFF and 1060 for ON. On default setings it generated 1060 for both slider states even if AC power was plugged in.

Mio Moov S555 (WinCE 5.0)
Go to Top of Page

Lots

7 Posts

Posted - 24 août 2010 :  00:45:59  Show Profile  Reply with Quote
LOST KEYBOARD. after failed Miopocket install.

Hi all,

I am desperate, I have lost the standard Windows CE keyboard after removing the Miopocket files and directories from my noname Chinese PNA. I removed miopocket because the install was incomplete and some things were not working properly.

When in Windows CE I can click the small button on the far low right hand corner, and a series of input possibilities comes up, but when selecting one nothing happens, also the Transscribe utility does not work anymore.. actually nothing that is in the list.

I lost this after I removed the Miopocket 4 directories and files and then a hard reset. The normal shell is back and works OK, but when in Windows CE 5.0 environment, the keyboard does not work.. Normally it popped up when required for input a passkey or rename a file or whatever.

QUESTION: How can I get the windows CE input devices back?

BTW, the Miopocket 4 install failed when it tried to copy 'control_panel.lnk' because it was allready there or in use (dont remember exactly what was in the error message) then hiting the OK button at the bottom shut down the PNA. BUT after restart I could start Miopocket by going into Windows CE and hit a shortcut that appeared on the desktop.. ALL MP4 menus and buttons shown up, some even worked, EXEPT the Settings menu, that shows an empty page.. After that when closing down the PNA, everytime Miopocket tries to install again, but everytime fails at the Control_panel.lnk file. So I decided to remove by simply deleting all files.

Please help!

Thanks!

Lots
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 24 août 2010 :  05:05:02  Show Profile  Visit Osprey's Homepage  Reply with Quote
jwoegerbauer,
1. For the apps that stall on black screens, edit their icons and disable the launch animation for them.
2. Whoops. Command Prompt has an absolute path to Storage Card assigned. I'll fix that. Point the icon to <drive>\MioAutoRun\Scripts\CommandPrompt.mscr for now. Also, the MiniBar icon has the same problem and should be pointed to <drive>\MioAutoRun\Scripts\MiniBarToggle.mscr.
3. Search - Did it work for you in R60 or R61 on the same device? It's a DLL problem, but I don't see off-hand where the problem is. Perhaps re-writing the lib name of coredll.dll via EXE Check to coredl2.dll would help.
4. Task Manager - Try replacing MioAutoRun\System\CE5\imaging.dll with the one from R61.
5. vSnap - That's another DLL error that I don't see the reason for. Again, did it work for you in a previous release?
6. I didn't think about allowing the close button to kill the volume control. Thanks for the idea.
7. XnView - That's another DLL error. Again, did that work before? If so, the only thing that I can think of is that I moved winsock.dll from MioAutoRun\System\CE5 to MioAutoRun\System. That shouldn't make any difference on a CE5 device, but moving it back is something to try, anyways.
8. Whoops! That's a bug in FixPaths.mscr. You can fix it by looking at the 5th line from the bottom and swapping the positions of "subfolders" and "encodingtype"... then, you'll need to run the script manually (re-installing likely won't run it again). Thanks for pointing that out.

Harpo and luissss81,
Please try copying this icons.xml and this settings.xml to MioAutoRun\Skin\iPhoneToday\icons. If that doesn't make any difference, try replacing MioAutoRun\Skin\iPhoneToday\iPhoneToday.exe, MioAutoRun\Skin\LockScreen\LockScreen.exe and MioAutoRun\Skin\SkinChanger\SkinChanger.exe with those from R61. If one of those fixes it, please tell me which. Thanks.

petrica_velvet,
Are you asking about using a keyboard in Ozi Explorer? Ozi Explorer has a "KB" button at the top of dialogs to launch the keyboard. I just tested it.

matip,
Oh, so, the "Power" settings can affect PowerButtonTest.exe's values. Interesting.

Lots,
A hard reset or complete shutdown (by holding the power button down) ought to undo things. If not, did you use the "Remove MP" icon on the Settings to remove MioPocket or did you manually delete MioPocket's MioAutoRun folder? If you used the icon, there should be a "MioPocket Backup" folder or a MioAutoRun\Backup folder. If you just manually deleted everything, then those backups are gone. One thing that you can try is to copy the touch.dll from my device to your \Windows folder and soft reset.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe
Go to Top of Page

petrica_velvet

Romania
8 Posts

Posted - 24 août 2010 :  06:53:12  Show Profile  Reply with Quote


petrica_velvet,
Are you asking about using a keyboard in Ozi Explorer? Ozi Explorer has a "KB" button at the top of dialogs to launch the keyboard. I just tested it.

I tried on my mio c510 but nothing appears and if opened manually kb ( JOTKBD) is block
Go to Top of Page

jwoegerbauer

1863 Posts

Posted - 24 août 2010 :  09:41:31  Show Profile  Visit jwoegerbauer's Homepage  Reply with Quote
quote:
Originally posted by Osprey

jwoegerbauer,
1. For the apps that stall on black screens, edit their icons and disable the launch animation for them.
3. Search - Did it work for you in R60 or R61 on the same device? It's a DLL problem, but I don't see off-hand where the problem is. Perhaps re-writing the lib name of coredll.dll via EXE Check to coredl2.dll would help.
4. Task Manager - Try replacing MioAutoRun\System\CE5\imaging.dll with the one from R61.
5. vSnap - That's another DLL error that I don't see the reason for. Again, did it work for you in a previous release?
7. XnView - That's another DLL error. Again, did that work before? If so, the only thing that I can think of is that I moved winsock.dll from MioAutoRun\System\CE5 to MioAutoRun\System. That shouldn't make any difference on a CE5 device, but moving it back is something to try, anyways.



Updated iPhoneToday.exe (now using version 1.5.4.1 - 20.08.2010) and surprisingly all works well:
1) window switching => no more any distortions / wait times
2) the 4 apps mentioned run flawless

Only heaven knows why, I not.

BTW: In MioPocket's Readme in section 4.2 "Editing icons" you should provide this link:
http://forum.xda-developers.com/showpost.php?p=4238166&postcount=3

Edited by - jwoegerbauer on 24 août 2010 14:59:20
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 24 août 2010 :  10:21:58  Show Profile  Reply with Quote
Osprey
I tried your suggestions re. power scripts, no deal.
I tried all scripts from R59, R62 won't start.
I did the kbd dll check and move, no change.
I took all reg-files from R59, no change.
To summarize, I still have no keyboard, I still no SD-card after poweroff/standby - poweron.
It might be that something is introduced in R62 that requires different exe or dll files than I have in my C710. One example is the explorer.exe that eliminated a lot of problems. As I am not alone having the missing keyboard, it's seems to be a general problem for 4.2 systems at a certain SW level.

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

rauva

15 Posts

Posted - 24 août 2010 :  11:13:53  Show Profile  Reply with Quote
r62 Observation:

(i do the soft restart for all the mode)
I got no more pup up power option when i plug up my usb cable into my GPS and my computer (very good) with the mass storage mode but windows don't found noting

ActiveSync mode: i got the pup up power option, choose cancel, Windows found nothing again,

Magellan mode: i thing is just not working, cuz after i click on the option i re-came in MP with no popup off confirmation to do a soft restart or something else.

So i was in a not working ActiveSync mode and i create my USBscreen.exe icon, set path, try the icon, plug my cable, i got the power option menu popup, choose cancel, got a hide or cancel usb connection form MP i choose Hide. Windows pup up with ActiveSync i choose no to the partnership. After all that i got it. I can use the minibar button to use MP.

and i try the new AlwaysRunning (r62fix), but for me i got the same trouble, i my main GPS prog. i can't re-came back into MP, i click on the upper-right corner but nothing happen. For me the solve is to put a "#" on the front of Kill("MiniBar.exe") in the ShellClose.mscr file to keep the minibar button ON


Pocketpicture: error i got a pop up and it say, i got to install "NETCFv35.messages.fr.wn.cab" for windows mobile 5.0 or ""NETCFv35.messages.fr.cab" for other os. Then the app re-came in MP main menu. (but they Work in r61)

Piano: error pup up say:
PPL runtime Error
App: jbpianoplus.exe
file: jbpianoplus.exe
Proc: winmain(0,1)
Opcode: loadspriteformmem
char/line/offset: 0, 0, 0x003ff964
error loading image from memory
(but they Work in r61)

Agenda: i got a Debug 4 error, and if i try to change the path to setup it manually i got a Debug 1 error. All error say "Can't initialize POOM" (Never work)

Mah Jongg: Work good now! Thumb up

Pocketmail: error - pmail is not a valid windows Ce application.

task manager: i see the option but i loose the minibar button so i was stock in that app. i got to close up the GPS to restart.

minibar new icon: error wrong path. the pup up say "mortscript" script\storage card\mioautorun\scripts\minibartoogle.mscr
so i got to set up manually (edit icon) to ...\sdmmc\mioautorun\scripts\minibartoggle.mscr

cmd prompt: same error as minibar icon and i use the same setup to correct it (edit icon, change path...)

tankx for your help

Xp Sp3, Magellan 1470 v1.12, Miopocket 4 r64, Windows CE 5, SD install
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 24 août 2010 :  12:16:00  Show Profile  Reply with Quote
Stoozak
This may or may not be of public interest. What ROM level do you have on your C710. Secondly, what is the date of the files in the Windows directory. (those that presumably belong to the C710 when you bought it). The date I have on many files is 11/24/06.

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

Lots

7 Posts

Posted - 24 août 2010 :  14:40:09  Show Profile  Reply with Quote
Thanks Osprey, I will try to install the touch DLL, I did remove everything manually.. I know should not have done that, but Miopocket was so badly installed I had no other option.

BTW I tried to install DLL and other files to the root menu before, but after a hard reset everything I copied there is gone again (all other directories and files are just there) do you think the touch dll will be removed as well when resetting?

Thanks Anyways, I will try when I get home.
Go to Top of Page

Lots

7 Posts

Posted - 24 août 2010 :  15:02:13  Show Profile  Reply with Quote
BLUETOOTH Serial Port Protocol

Hi, anybody knows a way to get Bt Serial Port Protocol on my Chinese PNA with Windows CE 5.0? or check if it does have this capability allready installed but disabled in some way? Which DLL and exe files should be there to have Bt SPP capability?

It has Bt, but only very limited to connect with a phone. Tried to connect with a Solar Bluetooth GPS mouse, but failed to connect (it does see the Gps, but when trying to connect using passkey 0000 it stays in waiting screen for ever)

In worst case, when this is not possible, anybody knows of a cheap 5" screen (chinese) PNA that does have SPP bluetooth on board?

Little background what I have in mind to use it for:

I am a glider pilot, and we fly with GPS loggers allready for several years, it is now commonly used to fly competitions. These loggers have RS232 outlets and via a Bt module you now can connect these with PNA's and PDA's using the more accurate GPS data from the logger (it uses barometric height for vertical measurement in stead of GPS height) in special software for navigation and competition flying.

I planned to use this cheap PNA to connect to the Bluetooth module, but now discovering the Bt protocol on board these chinese PNA's are all very limited.. An Ipaq 314, as an example, seems to work OK and connects fine using Bt, but these are hard to find these days.

Any help is appreciated!

Thanks!
Go to Top of Page

jwoegerbauer

1863 Posts

Posted - 24 août 2010 :  16:09:07  Show Profile  Visit jwoegerbauer's Homepage  Reply with Quote
@Lots,

if you don't find in your device's registry the key HKEY_LOCAL_MACHINE\Software\Microsoft\Bluetooth then your device isn't fully Bluetooth enabled, only "Bluetooth Audio Gateway" is enabled, thus you can pair your device with a head-phone etc.
FYI: http://msdn.microsoft.com/en-us/library/ms880971.aspx

BTW: Every Windows CE device has a file named "CEConfig.h" in the \Windows folder. This file can be used to determine the license level of a Windows CE OS. "CEConfig.h" contains macro definitions for the OS components included in the project. In other words, it can tell you about the features that will be available at runtime. For example (Bluetooth related):

#define CE_MODULES_BTSVC 1
#define CE_MODULES_BTD 1
#define CE_MODULES_BTDRT 1
#define CE_MODULES_BTHHID 1
#define CE_MODULES_BTA2DP 1
#define CE_MODULES_BTAGSVC 1
#define CE_MODULES_BTHUART 1
#define CE_MODULES_BTHAMB 1
#define CE_MODULES_BTHSC 1
#define CE_MODULES_BTHCSR 1
#define CE_MODULES_BTHUNIV 1
#define CE_MODULES_BTHUSB 1
#define CE_MODULES_BTHSDIO 1

Edited by - jwoegerbauer on 24 août 2010 17:46:26
Go to Top of Page

boggybb

Romania
3 Posts

Posted - 24 août 2010 :  16:11:22  Show Profile  Reply with Quote
Hi!

I saw in MioPocket readme file at point 4 the models of mio supported by MioPocket. I have a Mio P550 pda. Can I install MioPocket and use igo8?
If yes, is there any release thaat you recommend for mio p550? I saw on some old pda/pna that newer releases are not very well supported and old releases should be used.
Thanks in advance!
Go to Top of Page
Page: of 190 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,86 seconds. Powered By: Snitz Forums 2000 Version 3.4.05