Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2317




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 MioPocket 4.0 (Unlock for GPS devices)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 190

Janne

Sweden
92 Posts

Posted - 21 août 2010 :  10:00:49  Show Profile  Reply with Quote
Osprey
A small summary and additional info.
1. Changing to MioPockets Explorer (not using the one from 4.2 eliminated most problems with programs not found.
2. Changing (rewriting) the OS-version to 4.2 in
Mortscript.exe using Execheck eliminated all install and start-up problems
3. The SIP panels. Using Minibar all I get is "Show Input Panel", nuttin' more. Going in to Control Panel and then Input Panel Properties, klicking on Current input method, I get a list of different inputs, for example Eurokeyboard, LargeKB, Transcriber and more.
Selecting e.g. Eurokeyboard and then pressing OK. Going back to the Input Panel just to check, the selection window is still empty (black). My guess is that Minibar takes it's info from here and as long as I cannot select a keyboard here, Minibar isn't able to pick up this list. Something to do with the registry?
4. Power-on after Standby still remains unsolved. I'll check out R62 when available.

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

KhaKev

385 Posts

Posted - 21 août 2010 :  10:12:27  Show Profile  Visit KhaKev's Homepage  Reply with Quote
quote:
Originally posted by Osprey
1. Your CE6 device has a hive registry, right (or my theory is shot)?
2. The emulator comes with commctrl.dll (and coredll.dll, obviously), so EXE Check was definitely using them.

1. No, it has no hive registry. I have confirmed with after a hard reset by the power switch.
2. Agreed. I am thinking commctrl.dll or coredll.dll is not compatible. If I can modify EXE Check to use commctr2.dll or coredl2.dll from another device for example, it might work. Will try to rename EXE Check to something else and do the change from working device CE5 and test.

Thanks.
Go to Top of Page

stoozak

South Africa
4 Posts

Posted - 21 août 2010 :  11:46:58  Show Profile  Reply with Quote
A million thanks for the update, it looks great!

Just one comment, its frustratingly slow on my c710. Garmin really struggles to render maps, and switching in and out of programs is a test of patience....

Did I miss something along the way to speed it up?
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 21 août 2010 :  12:48:05  Show Profile  Reply with Quote
Stoozak
Have you experienced any of the problems that I have?
If you look at the top of page 34 there is a summary.
What bothers me most is the power off/on thing where I
can't access the SD-card after a off-on sequence. From a performance point of view, it's very slow on a softreset
but otherwise it's as before comparing to R59.
I'd be happy for any comments you might have.

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

Tonnie

2 Posts

Posted - 21 août 2010 :  13:38:31  Show Profile  Reply with Quote
Osprey
I would like to run MIO Pocket on mij Pioneer Avic F500bt, wich steps do i have to take to let it work.
I dont have any experience with MIO Pocket, but i'm ready to learn.
Go to Top of Page

joegovernale

USA
18 Posts

Posted - 21 août 2010 :  15:24:44  Show Profile  Reply with Quote
I have 2 Navigon 2100's. One performed the update from version3, rev56 to version 4 with no problem, the other hung in the install until I deleted the registry HKLM MioPocket key as per Maximus9.

Osprey, absolutely no criticism here, more like praise for the excellent work you have done. Without the great file structure layout and comments/documentation in the files, I wouldn't have had the info/guts to troubleshoot.

E900 APAD, Mio C520, Mio C310x, Mio C230, Navigon 2100, Garmin eTrex Legend, DeLorme Earthmate
Go to Top of Page

edmaronline

5 Posts

Posted - 21 août 2010 :  16:04:47  Show Profile  Reply with Quote
Hi all!
I have a GPS Powerpack 4320 with a SD card of 2GB. I tried to run the MioAutorun.exe but I forgot to copy the folder MioAutorun . I received a message saying that it was not possible to find the folder. I copied the folder but now, when I try to run, nothing happens. I formated the SD card several times to FAT or FAT32. It doesn't work.
Somebody could have an idea of what's happening?
Thanks a lot!!!
Go to Top of Page

stoozak

South Africa
4 Posts

Posted - 21 août 2010 :  16:18:52  Show Profile  Reply with Quote
quote:
Originally posted by Janne

Stoozak
Have you experienced any of the problems that I have?
If you look at the top of page 34 there is a summary.
What bothers me most is the power off/on thing where I
can't access the SD-card after a off-on sequence. From a performance point of view, it's very slow on a softreset
but otherwise it's as before comparing to R59.
I'd be happy for any comments you might have.



Nope fortunately I don't seem to have those. The only one I've found besides the slow performance is that TomTom won't open but I haven't explored as to why yet.

Its just dam slow! Dont get me wrong I love the new look and functionality. Perhaps I'm just using a slow SD card, but v59 was much much faster....
Go to Top of Page

tomek

Poland
17 Posts

Posted - 21 août 2010 :  17:57:41  Show Profile  Reply with Quote
Hi, Osprey. I found a program to test card speed for MioPocket please check it.
http://www.mediafire.com/file/8553nskx38j37k2/CardSpeed.exe

MIO C520 + spectec sdw-821
MioPocket 4.0 r65
Go to Top of Page

Harpo

Sweden
184 Posts

Posted - 21 août 2010 :  21:56:39  Show Profile  Reply with Quote
Impressive Osprey and others.
Its working very well on my crippled C220, some apps doesnt work as usual but thats ok.

I am very impressed with the looks and the nice sliding menues.

Ill try to get you a new uppdated Swedish language file soon as the old one i did is lacking a lot of translations, i think it must be two years old by now.

Nice work!!

C220 Miomap 3.3 Olivercp/split skin and Miopocket 4.0 v63 SD-based - IGO8.3/diMKa 1.5.9 /Navigon Mn6/Mn7.5 reality view light, IGO Primo 1.1
SE X1 IGO8-IGO Primo
Go to Top of Page

tkuy2k

1 Posts

Posted - 22 août 2010 :  02:43:36  Show Profile  Reply with Quote
I am new to this please help......

Can this be loaded on Magellan RoadMate 1440?
Go to Top of Page

love2dance

Portugal
2 Posts

Posted - 22 août 2010 :  02:55:30  Show Profile  Reply with Quote
Hi everyone.

As a newcomer to this forum I would like to share my opinion regarding Miopocket, as installed on a in-dash GPS-DVD-radio unit I recently purchased (please forgive if this is not the correct/best section for posting this message).

First of all, congratulations to all who helped developing this application.

When I purchased my Kia Sorento 2011 I rushed to the internet and started searching for a better radio system. After some results, I bought a no-brand 7.0 inch digital(800*480) DVD player with GPS navigation system. This unit can be seen on:

http://www.cardct.com/kia-navi-dvd/kia-new-sorento-navigation-dvd-player

and

http://www.sharingdigital.com/show.asp?id=580&mnid=&classname=For%20Kia

KIA Sorento DVD Player with GPS Navigation System

After finding this a other GPS forums I recognise that I should have done a better homework.

Overall it works ok. The GPS finds the satelites very quicky, though I am not much of a fan of Igo (The unit came with a MicroSD having Igo8 as the navigation software; I managed to upgrade to Igo8.3 plus newer maps). Not sure why but despite the many attempts, Tomtom and Navigon won't work with this unit.


Despite GPS, it has radio capabilites, and music (either from SD card or CD). The is a video menu. I supposed if I loaded a video file, I could make it work but no luck.

Also, if I insert a DVD movie, it won't play in the main unit. This is claimed to work with rear seat screens (it kind of a TV ou system only).


I also bough a rear camera for better parking the vehicle, but it does not seem to work (despite many attemps to get help for the company selling this product. The short version: they sell you allright, but expect no assistance from them!)

I installed Miopocket 4 but does no work well (most of the programs won't open) in this unit. With miopocket 3, I got better luck. Only a few applications return an error. I imagine this relates to the inexistance of certain dll files.

Even running Tomtom and Navigon, under Miopocket, these won't work (I changed the maps to inside the "My documents" folder but the problems persisted: Navigon accuses a low battery problem and says it will shut down within 30 seconds; tomtom can't find the maps....).

Within Miopocket I found that my unit, a Samsung ARM926 processor with 125 Mb, runs on WinCE 5.0.

I strongly believe this problems are not associated with Miopocket.
Perhaps the unit's software is interering with Miopocket. I tried looking at the running processes but can't find a way to kill or terminate the native software.

Does anyone have any hints on how to surpass these limitations?
Any ideia why V4 won't run and V3 does?


Regards.
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 22 août 2010 :  05:45:37  Show Profile  Visit Osprey's Homepage  Reply with Quote
bumbum,
FYI, I've replied to you in the "MioPocket-Framework-Clarion" thread.

Janne,
3. Yes, it has to do with registry settings and DLLs. Check that softkb.dll and msim.dll are in your \Windows. If not, copy MioAutoRun\Windows\Windows\Keyboard\softkb.dll and MioAutoRun\System\msim.dll there, soft reset and see if the SIP works. FYI, the registry settings (at least all that I'm aware of) are in MioAutoRun\Registry\Keyboard.reg, which should definitely have been imported during installation, but you can double-click it if you want to be sure.
4. Does that mean that you followed my last idea (regarding the old skins)? Another thing to try is to copy all Power*.mscr scripts from R59's MioAutoRun\Scripts to R61, then, if that works, trace it down to the one script. Heck, if that doesn't work, you can copy all of R59's scripts. Most people don't seem to realize that they can do a lot of troubleshooting, themselves, that way, when they have one collection of files that works and one that doesn't.

KhaKev,
Ah, so it sounds like the issue is with MioAutoRun\Programs\HardReset.exe, the utility used for hard resetting. Unfortunately, I'm not aware of any alternative methods.

stoozak,
For most people, performance is the same or better than 3.0. Are you launching Garmin via the icon provided for it and is the icon still pointed to the GarminLauncher.mscr script? Also, by "switching in and out of programs," do you mean in and out of nav apps? If so, that's because the default in 4.0 is to close MioPocket while the nav apps are open. You can reverse that in MioPocket Settings so that MioPocket's shell stays running in the background, but that'll take up more memory, likely slowing things more. It should solve your switching issue, though. As for the speed issue, if you've checked the Garmin icon, wiping and re-installing MioPocket is recommended, especially if you happened to have tried to upgrade your R59 (which shouldn't be done). Just don't use the "Remove MP" icon, since the script has a bug in R61. Hard reset your device, connect to USB and delete the MioAutoRun folder, instead.

Tonnie,
I don't have any instructions specific to unlocking Pioneer devices. I suggest doing a web search. People appear to have done it, as shown by this video, which might also be of help to you. There are some generic, non-device-specific SDfree instructions in the MioPocket Readme, but you really are better off looking for specific Pioneer unlocking instructions (which appear to exist) first.

edmaronline,
I'll be uploading R62 very soon. I suggest that you try that, since I think that your problem has already been fixed.

tomek,
Thanks; however, MioPocket already has the "Benchmark" tool on the Tools page, which tests card speed, among other things.

Harpo,
Hey. It's good to see you again after so long. I'm happy to hear that 4.0 works well on your c220, one of those nightmare devices that gave me so many problems trying to figure out (with your help) a couple of years ago.

tkuy2k,
Yes, instructions are in the Readme.

love2dance,
I suggest upgrading to R62 when I upload it, since some of your issues might be solved by it.
BTW, this is off-topic, but the rear view camera needs its video plug connected to the stereo's AUX video input (which you've probably done) and its power wire connected to the stereo's "reverse" (as in driving in reverse) wire. I believe that what I had to do was identify which wire going into the ISO plug was for reverse and then jam the camera's power wire down into the same hole (so, two wires in one hole). Then, when you put the car in reverse, the camera gets its power and turns on (my device switches to AUX display automatically, but, if yours doesn't, try switching to it manually, probably via the Mode button).

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 22 août 2010 06:02:58
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 22 août 2010 :  07:10:55  Show Profile  Visit Osprey's Homepage  Reply with Quote
Everyone,
Here's Release 62. Thanks for being patient.

Download: MediaFire
Mirror: MegaUpload

Note that there's a bug in R61's "Remove MP" script, so, if you want to use that, replace MioAutoRun\Scripts\Remove-MioPocket.mscr with the one in R62 before pressing the icon. As usual, though, you don't need to use that icon if you're already using a 4.0 release. You can simply copy R62 over it, instead, then hard reset and re-install.

===============================================
** MioPocket 4.0 (Release 62) - Aug 21, 2010 ** (Osprey)
===============================================

1. Added Koule, another "connect the bubbles" game.

2. Fixed issue with installation not starting on CE 4.2 devices. (credit to TroNik)

3. Fixed a few bugs preventing Media Player from loading. Also replaced old plugins (which caused some errors) with updated ones. Also fixed errors with playing Windows Media files. Also disabled GAPI, meaning no more splash screen, slightly faster loading and no need to select a GAPI device when first loading the program. (credit to TroNik for a few of the bug fixes)

4. Changed the Volume and Bluetooth icons to ones that graphically indicate their states (ex. zero sound waves next to the speaker if the volume is muted, four if at 100% and so on).

5. Fixed an issue in CE6 where the start menu and Explorer would freeze.

6. Fixed killing user-specified apps at startup (using the AppToKill method).

7. Fixed "Sub SetMiniBar no found" error during installation on some devices.

8. Fixed registry settings that may've contributed to problems running Flash.

9. Fixed the "Command Prompt" console window being displayed for certain, rare apps.

10. When running a nav app via its script, MioPocket's shell and apps are now closed before the app is run, in case the app does a memory check.

11. Added some settings to allow JOTKBD to work on more devices. (thanks to euy)

12. Tweaked NavMinimize to work better. Also made it so that pressing the triangle a second time restores the nav app.

13. The MiniBar is no longer killed when Nitrogen runs.

14. Configured the Flash-based games to start up with quality settings that seem best for each one. Most use high quality, but a few use low quality for performance reasons. Also configured their scripts to use MioAutoRun\Scripts\Flash.mscr so that, if one should ever need to, a different Flash player could be used with the games.

15. Switching between "TopBar Icons" in Skin Changer now slightly adjusts the vertical spacing of icons to accommodate the new height of the TopBar. Also spaced out the icons a bit more in the default configuration.

16. Set the startup menu to scale the font size to the device's resolution (particularly making the fonts and buttons easier to read and press at 800x480).

17. MioPocket Settings now remembers your main menu choice (General/Skin/MiniBar/System) and highlights it when you return to the main menu, making it easier to remember which sub-menu you were just on and to return to it.

18. Minor icon changes, such as adding a MiniBar icon (same as on the BottomBar) to the Tools page and tweaking the GAPI image.

19. Added XN Resource Editor, another resource hacker, to Extras\Win32.

20. Lowered the required CE version number of a few apps from 5.0 to 4.20, *possibly* enabling them to run on CE4.2. The apps are Skyfire, IE, Pocket Mail, Remote Desktop, the shutdown app and a few insignificant others.

21. Fixed a registry importation error in the "Remove MioPocket" script. Also moved the line that deletes the "MioPocket" registry key to earlier in the script so that it is sure to execute even if the rest of the script encounters a problem.

22. Moved and added a few DLLs to possibly help CE4 devices.

23. Magellan-only: Added a "Magellan Mode" option to the USB Mode menu that runs USBScreen.exe, which some Magellans need for USB.

24. Moov-only: The Device Settings icon on the Settings page should now run the Moov Settings app on more Moov models.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 23 août 2010 09:40:00
Go to Top of Page

bsweeny

USA
159 Posts

Posted - 22 août 2010 :  07:13:15  Show Profile  Reply with Quote
Osprey, Can't wait to install R62! I have a problem I can't uninstall R61 what do I Do? Congratulations again

Omnitech 16878 WinCe 4.2 Core, Tabs V1 Unlock Files With a Modified NK.Bin and Miopocket 4 R66 Unlock! :-D

Edited by - bsweeny on 22 août 2010 07:27:06
Go to Top of Page
Page: of 190 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,12 seconds. Powered By: Snitz Forums 2000 Version 3.4.05