Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2275




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 MioPocket 4.0 (Unlock for GPS devices)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 190

TriggerNgo

USA
11 Posts

Posted - 15 août 2010 :  02:51:36  Show Profile  Reply with Quote
Osprey, if you can help me at all I would be most grateful. It's a bit complicated. I'll revert back to Miopkt 3 R59 for now. I'll be awaiting your reply. Thanks.
Go to Top of Page

visum

USA
4 Posts

Posted - 15 août 2010 :  03:58:39  Show Profile  Reply with Quote
Got MIP R61 running on my Insignia NAV01, but when trying to use IGO8.3.x the GPS freezes up and error message appears: "Out of memory. Requested 4064, Cache 144961"
Please advice, looks like I need to free up come RAM? How to do it?
Thanks for all great work you guys doing here, great forum!
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 15 août 2010 :  04:43:17  Show Profile  Visit Osprey's Homepage  Reply with Quote
TroNik,
I should've tested it in CE6, myself. I forgot in my hurry to post before going to bed. Oh well, but at least it helped work towards a solution.
The biggest issue last night seemed to be that some users still couldn't install because nothing would happen when MioAutoRun.exe was launched. It looks like the common thing with those devices, though, is CE 4.2 (all Mio Cx10 devices have 4.2, FYI), so it's likely just that version bug that you found yourself.

Question: Since b8 is 76KB uncompressed and b15 is 511KB uncompressed, might it not be a lot more memory-friendly to patch b8... or is that not an option because you don't have the b8 source or is it not recommended because of the overhaul to VS2008 is beneficial (maybe especially for CE6 devices)?

attila65 and Janne,
That's great to hear! If you would, though, please upgrade to the patched b15 that TroNik just uploaded. That'll tell us if the bug has been patched or not. I can't include in R62 the version that you just tested because it's no good in CE6, so, at this point, it's going to be the patched b15 that TroNik just posted, unless there's a need for further tweaking.

Janne,
1. The Control Panel applet number might be different on your device. Open MioAutoRun\Scripts\DateTime.mscr and change the number around (1-30 or so) until you find what works for you. If you do, feel free to tell me and I can make all CE 4.2 devices use that number for date/time, instead (unless a CE 4.2 user tells me that it works fine for them already).
2 & 4. Try changing the Explorer used via MioPocket Settings.
3. It's a real challenge to get iGO8 working on 32MB devices. Make sure that "Keep MioPocket open during nav apps" is showing in MioPocket Settings (meaning that it's currently being closed) and, under "Set CE wallpaper," choose "None" to save a bit more memory. Also, make sure that your iGO icon is pointed to MioAutoRun\Scripts\iGOLauncher.mscr, not directly to iGO8.exe. If you still have problems, I suggest looking online for help getting it working on 32MB. There are some sys.txt settings that might help.
5. I'm not sure why some people have issues with Pword.exe. A few things to try, though:
a. Run EXE Check against MioAutoRun\Programs\Office\Pword.exe, choose "Set lib name" and overwrite "COREDLL.DLL" with "COREDL2.DLL". Then, do the same with Office.dll in the same folder.
b. Delete the *.409.mui files from MioAutoRun\Programs\Office, which are English_US language files. If that doesn't help, copy them back and rename the "409" to whatever the code for your language is (EDIT: 041d for Swedish).
c. Copy Office.dll from MioAutoRun\System\CE5 to MioAutoRun\Programs\Office, overwriting.

aiolos,
Sorry, I misunderstood you, then. It works properly on my CE5 and no one else has reported your problem. One thing to try is to run "EXE Check" on the Tools page, select MioAutoRun\Programs\TaskMgr.exe, then press the "Re-write lib name" button, rename "AYGSHELL.DLL" to "AYGSHEL2.DLL" and press Overwrite. You could also try renaming "COREDLL.DLL" to "COREDL2.DLL".

ohh64,
The "init" and "Launch" files are created during installation, so they're not supposed to be there yet.
I don't see any way that error message could be erroneously given. If you take a look at MioAutoRun.mscr, there's first a check for the existence of the "Drive\"MioAutoRun" folder, so you passed that test and it verifies that "Drive" equals your installation drive name. So, I can't understand why it doesn't find the two scripts. That code is exactly the same as it was in R59. You could try copying R59's MortScript.exe to the same folder as MioAutoRun.mscr or putting # signs in MioAutoRun.mscr in front of lines 20 and 21 (the second "BigMessage" line and the second "Call("ExitScript")) line).

bsweeny,
Yes, that's a bug in R60. That's why I want you to use R61. Copy TroNik's MortScript patch from this page (25) and, hopefully, that failure to start will be gone.

matip,
1. Does this work better? NavMinimizeFix.zip
2. DeviceSettings.mscr checks for...
\My Flash Disk\Program Files\Navman\SmartST_CE\SmartST_CE.exe
\My Flash Disk\Program Files\Navman\SmartST_CE\SmartST_CE_orig.exe
\My Flash Disk\Program Files\MioMap\MioMap.exe
\My Flash Disk\Program Files\MioMap\MioMap_orig.exe
...and, if one of those is found, runs that new Moov Settings program. Your device must have something else. Tell me what I can check for so that the check will work for your device. Is \My Flash Disk\Program Files\Navman\AppStartupSec.exe valid? I'll add that for now, but let me know for sure. Thanks.

TriggerNgo and smaack,
Apply the patch that TroNik just posted on page 25.

visum,
Please see the section in the Readme on freeing up RAM.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 15 août 2010 07:04:29
Go to Top of Page

bsweeny

USA
159 Posts

Posted - 15 août 2010 :  04:57:47  Show Profile  Reply with Quote
Osprey, thank You soo much I will try it tonight! I already downloaded it

Omnitech 16878 WinCe 4.2 Core, Tabs V1 Unlock Files With a Modified NK.Bin and Miopocket 4 R66 Unlock! :-D
Go to Top of Page

TroNik

362 Posts

Posted - 15 août 2010 :  07:38:14  Show Profile  Reply with Quote
Osprey,
The size increased since b11 when Mort switched to VS2005 ( http://www.sto-helit.de/forum/viewtopic.php?f=12&t=5452&st=0&sk=t&sd=a&start=120 ).
Enabling "whole program optimization" did the trick.
http://rapidshare.com/files/413029491/MortScript_4.3b15_optimized.zip

http://iphonetoday.googlecode.com/
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 15 août 2010 :  07:49:24  Show Profile  Visit Osprey's Homepage  Reply with Quote
TroNik,
Yeah, I realized that. The change to VS2005 is why I hoped that b8 would do the trick.

Good job optimizing it. 400KB uncompressed is measurably better than 500KB. Also, I just realized that Mort released his b8 compressed, but not his b15. That explains the size difference from b8 to b15 as much as the VS2005 move. Uncompressing b8 reveals that it's really 300KB, four times larger than I thought, so it's not the issue that I thought. Thanks for the optimization.

Oh, also, thanks for correcting the misspelling. Most people aren't going to realize that that's a MortScript error, not one from one of my scripts or from your iPhoneToday, so it reflects better on you and me this way.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 15 août 2010 08:50:54
Go to Top of Page

JCarlosMilan

Mexico
7 Posts

Posted - 15 août 2010 :  09:08:49  Show Profile  Reply with Quote
Hi Osprey. First of all, congratulations for this new release. I believed nothing could be better than 3.0, and since I'm not a big fan of the Ipod style I was a little disapointed at first, but when I installed and experienced 4.0... Wooooww..!! You did it again...
Now the question/petition: Is there a chance to create a hovering button to minimize aplications (just like the closing button that hovers over all the aplications)? Nitrogen has its own Minimize feature, but other aplications don't. When I'm using Pocketgps and Nitrogen at the same time I would like to switch from Pocketgps to Nitrogen without closing Pocketgps. I used the Minibar->Task manager, but it takes many steps and when you are driving this is not convenient. I also tried Minibar->Switch windows but Pocketgps just stopped working, I had to close it from the task manager.
I have one of those chinese 2-din stereos, and Miopocket works just great. Thank you again for the great job, you gave a different life to my car. ;)
Go to Top of Page

jwoegerbauer

1865 Posts

Posted - 15 août 2010 :  09:21:07  Show Profile  Visit jwoegerbauer's Homepage  Reply with Quote
Because since some time chinese OEMs are selling devices powered by Microsoft Windows CE .NET 6.0 Core operating system, probably the next generation of problems arises, especially installing .NET CF 3.5 as the default one.

Edited by - jwoegerbauer on 15 août 2010 09:27:20
Go to Top of Page

oferwain

Israel
2 Posts

Posted - 15 août 2010 :  10:08:52  Show Profile  Reply with Quote
Hi Osprey,

I have the same installation problem as ohh64 with the error.

---------------------------------------------------------------
MioPocket not found.
Some scripts are missing under:My Flash Disk\MioAutoRun\Scripts Please re-cpoy files.
Your original navaigation application will now run instead.
---------------------------------------------------------------


release 60,61 didnt work so I moved back to release 59.
I tried several script to move from 59 to 61 but it still not working ,I belive we are not the only ones that have problems.

ofer wainshtain mio C320
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 15 août 2010 :  10:19:15  Show Profile  Visit Osprey's Homepage  Reply with Quote
JCarlosMilan,
Thanks. What you're asking for is what the "Hide/Show Windows" button" just underneath "Switch Windows" is for. It minimizes all apps and, when pressed again, un-minimizes them. You had the right idea with "Switch Windows," though, as that ought to switch between the windows that you have open. I just tried switching between PocketGPS and Nitrogen and had no problem. Well, I did notice a bit of a problem in that the Nitrogen script kills the MiniBar. I've gone ahead and removed that. See if this works better for you: Nitrogen.mscr

oferwain,
Strange. Maybe there's a bug in the "FileExists" function in MortScript. I guess that I could remove that check, as it's not essential. It just lets those who didn't copy things correctly know it and have an idea what to do about it. Anyways, you can do that on your own right now by putting # signs in front of lines 19-21 ("ElseIf..." through "Call...").

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 15 août 2010 10:29:54
Go to Top of Page

TroNik

362 Posts

Posted - 15 août 2010 :  12:18:23  Show Profile  Reply with Quote
Osprey,
I think oferwain is using the old script for SDFree (miomap.mscr of MP3r59) that is checking for ShellStart.mscr...
Notice his error message: "Your original navigation application will now run instead." that you removed in MP4.

http://iphonetoday.googlecode.com/
Go to Top of Page

oferwain

Israel
2 Posts

Posted - 15 août 2010 :  12:53:50  Show Profile  Reply with Quote
I did it !

I marked with # the 3 lines 19-21 at the mioautorun.mscr and it solve the case...

thank you

Ofer
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 15 août 2010 :  13:20:38  Show Profile  Reply with Quote
Osprey, Tronik
I tried Tronik's latest Mortscript. Didn't work. Execheck still says I'm on 4.2 Mortscript on version 5.
I changed the path-info for Igo, now it starts and abends which is a step forward. Funny though, I've been using it from r30 incl. R59 with no problem.
As for date/time I'm working on it. As additional info I have 7 Control Panel icons, Admin, DB, Network, Regional, Schedtask, Storagemgr and Systpath.
Pword is OK for 4.2. Haven't come around to Explorer yet.

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 15 août 2010 :  13:25:35  Show Profile  Visit Osprey's Homepage  Reply with Quote
TroNik,
You're right. I didn't look closely enough at the error. Thanks for catching that.

oferwain and ohh64,
You shouldn't still be using the old MioMap.mscr from MioPocket 3.0. You're supposed to replace that with the MioAutoRun.mscr in R61 (renaming as necessary).

Janne,
So, the MP_MortScript_4.3b15_Tronik.zip one works for you, but the MortScript_4.3b15_optimized.zip doesn't? That's odd. TroNik, was there something version-specific about the optimization? Janne, what do you mean by "Execheck still says I'm on 4.2 Mortscript on version 5"? MortScript is always going to report 4.2 to EXE Check, since it requires at least CE4.2; that's all that that means. Also, your device is 4.2, right, so why are you mentioning 5? Do you have two devices, one with CE4.2 and one with CE5? If so, which are you having problems with?

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 15 août 2010 14:38:52
Go to Top of Page

dexex

United Kingdom
13 Posts

Posted - 15 août 2010 :  14:39:25  Show Profile  Reply with Quote
How normal it is for "InstallLog.txt" to be empty? By the way, none of the new "Mortscript.exe" works for me. I'm beginning to think there may be something going on with the device's software that, on next reboot, it wipes every file you have written. Because the files written on "\My Flash Disk" are there, the ones on "\Storage Card" are there, but the ones that are supposed to be in "\Windows" are missing. Any thoughts?

Navigon 4350/6310 | CE 6.0 | Navigon 7.4.6 | iGO Primo | MioPocket 4.0 R61
Go to Top of Page
Page: of 190 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,38 seconds. Powered By: Snitz Forums 2000 Version 3.4.05