Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2204




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 MioPocket 4.0 (Unlock for GPS devices)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 190

stu.edwards

2 Posts

Posted - 02 déc. 2010 :  00:54:31  Show Profile  Reply with Quote
bumbum

Yes it really is any application. Any button/application I click on within miopocket gives me the error

"Cannot find ????'Miopocketsettings' (or one of its components). Make sure the path and filename are correct and that all the required libraries are installed"

Where ??? is the name of the application
Go to Top of Page

jamesvior

USA
5 Posts

Posted - 02 déc. 2010 :  01:52:29  Show Profile  Reply with Quote
I have a Magellan Roadmate 1700. Installed mioPocket 4.0 per instruction 4D, mioPocket seemed to have booted properly. I got all apps icons but it all ran with error, "Cannot find 'apps.xxx' make sure path is correct...". How come? Do I have to manually set the path? Bad installation? [ed]
Go to Top of Page

mr.nonobservant

52 Posts

Posted - 02 déc. 2010 :  03:42:03  Show Profile  Reply with Quote
Path errors and such cannot find application
It seems to me that those of you with that problem
need to replace FixPaths.mscr
See the thread and get the file here: http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=136798&whichpage=100
also there a a few shortcuts that are set wrong with MioPocket 'out of the box', in R67 GSFinder comes to mind

.... Magellan Roadmate 1220

Edited by - mr.nonobservant on 02 déc. 2010 03:53:25
Go to Top of Page

yellowstang73

USA
5 Posts

Posted - 02 déc. 2010 :  08:30:59  Show Profile  Reply with Quote
I found the cure for my problem. I used the supplied reg editor (win32 folder). Manually searched the registry found HKLM/ini/ 99999 mioautorun entry and deleted it. When I rebooted it automatically started the install and everything installed right this time.
Go to Top of Page

sergiozaki

Portugal
4 Posts

Posted - 02 déc. 2010 :  17:15:42  Show Profile  Reply with Quote
please help
Last week i bought a chinese GPS BLUETOOTH HD 800*480 4GB 5'' GPS Navi FM Atlas V 128RAM Wince 6
can i install Miopocket 4 here? What kind of device is this?? i dont have many info :/
Thank you for attention
Go to Top of Page

jwoegerbauer

1863 Posts

Posted - 02 déc. 2010 :  17:56:06  Show Profile  Visit jwoegerbauer's Homepage  Reply with Quote
@sergiozaki,

a detailed description of your chinese GPS you can read here. Why didn't you google for it by yourself?
Go to Top of Page

Danko.ba.nanko

27 Posts

Posted - 02 déc. 2010 :  18:29:31  Show Profile  Reply with Quote
Hello all,

I installed sucessfuly Miopocket 4.0 R67 into a chinese 5" (480X272) gps and all works great. Now it looks really like IPad, koz of its design. But the problem starts when I installed Old Skins addon.

I did all as it said in the instructions, just copied folders over one that was on my SDMMC card, and I can open old skins, but when I try to run icon edit mode it sais it has been disabled,also when in old skin I can not run MP Settings error sais (Sub " not found Line 368 (\SDMMC\MioAutoRun\Scripts\MioPocketSettings.mscr Call ("LoadPage")

Also when I run some games while in all old skins (I tried all 480x272 resolutions from old skins) when playing old games displaygoes into vertical view and it can not be changed back via orientation button depressed (screen just flickers but otientation stays the same).

Ones more I installed ifrst old skins, than patch than old games addon.

Now does this mean that I can not use the old skins (which is not that big of a deal since all skin work great when running 4.0 version). Or it requiers some tweaking in settings manually?

Also, I have problem with clock which runs 10-12 sec per sec when running MioPocket 4.0, so in one hour that passes it displays like 4 or 5 hours, so it is running fast.

Thanks

Edited by - Danko.ba.nanko on 02 déc. 2010 18:36:33
Go to Top of Page

Danko.ba.nanko

27 Posts

Posted - 02 déc. 2010 :  20:33:23  Show Profile  Reply with Quote
One more question regarding MioPocket 4.0, and that is connection to internet. I have been rading posts like http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=109954

and http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=123085

Did all as "ste" said in the instructions in the Zip, all goes well but when user needs to get authenticated I get this error message: "You have been disconnected from the remote computer you dialed. Verify the Baud Rate setting and retry the connection"

Sorry if I asked here, but above topics are over year old.

Any help is wellcome and appreciated

Ah I forgot to mention the unit is same chinese phone N97. Should I try older phones or?

Edited by - Danko.ba.nanko on 02 déc. 2010 20:49:56
Go to Top of Page

mr.nonobservant

52 Posts

Posted - 03 déc. 2010 :  04:27:45  Show Profile  Reply with Quote
My next question is regarding the Atheros Orion GPS Driver/Service.

Where in the world are the Orion files in '\Windows\' coming from?
(Orion.cpl, Orion.ini, OrionGo.exe, OrionSvc.dll, OrionSys.dll, OrionUNAV4.img, and OrionVsp.dll)

I've scoured the miopocket install and the device for these files
and can't find them till after install when they occupy \Windows\.

My problem is after Orion is enabled once I can't disable it and
get it to stay disabled through a hard reset.

\Windows\Orion.ini is the settings file but it doesn't get saved by MioPocket

I finally gave up and made registrybackup.mscr copy it to
mioAutoRun\Windows\Windows\Orion.ini so it gets saved once if it doesn't exist.

I then had to edit it, the file has these weird characters at the beginning  (in hex: EF BB BF)
which makes it unable to have its read only flag (or any attributes) changed.
So I Edited the AutoRun keys in orion.ini, Deleted the orignal and saved it
to mioAutoRun\Windows\Windows\Orion.ini.

Now it uses those settings and won't run the Orion GPS Navigation (Finally)
Although the Orion GPS Service its self is still running my gps software will work now.

The fact still remains that the settings aren't stored and can't be changed programmatically,
If I change them through the control panel applet they will all be set to enable again
in Orion.Ini.??

Isn't there any other way to disable it am I missing something? or is this something that needs to be fixed?

in Registrybackup.mscr I put this:

       If(FileExists("\Windows\Orion.ini") And not FileExists(WindowsFolder\"Windows\Orion.ini"))
           #copy orion.ini from /windows if it exists and doesnt exist in the ROM  
           Copy("\Windows\Orion.ini",WindowsFolder\"Windows\Orion.ini")
       EndIf


But this is still inadequate as it will only save once

In order to work properly the file still needs to be edited, the original deleted, and finally re-saved and
from now on the settings can not be changed through the control panel
(not that they truly could be saved before lol).

Perhaps you can incorporate a menu for these settings in miopocketsettings?

.... Magellan Roadmate 1220
Go to Top of Page

mr.nonobservant

52 Posts

Posted - 03 déc. 2010 :  07:14:37  Show Profile  Reply with Quote
Well I figured out how to start and stop services...

You can use the command prompt or do it from a command line.
first I tried 'services help' which was very helpful indeed,
for the orion driver the results of 'services list' gave me its name as OGS0
so at the command line I typed 'Services stop OGS0:'
I could also enter 'services unload OGS0:' and have similar results
maybe put this in Initialize.mscr if one desires it be stopped?
I put it in right after '#hide the taskbar'



#Hide the taskbar
CallScript("TaskbarHide.mscr")

#Unload Atheros Orion Service
Run("services.exe","unload OGS0:")
#Add message to log

WriteFile(StartupLogFile, "Initialize.mscr: Autolaunching MioPocket and/or the ""AutoLaunchApp""...^NL^", TRUE)

#Autolaunch app and MioPocket

Viola problem solved and it negates the need for saving orion.ini

hopefully I'm not reiterating something already discovered

.... Magellan Roadmate 1220
Go to Top of Page

jwoegerbauer

1863 Posts

Posted - 03 déc. 2010 :  09:39:48  Show Profile  Visit jwoegerbauer's Homepage  Reply with Quote
quote:
Originally posted by mr.nonobservant

Well I figured out how to start and stop services...

You can use the command prompt or do it from a command line.
first I tried 'services help' which was very helpful indeed,
for the orion driver the results of 'services list' gave me its name as OGS0

hopefully I'm not reiterating something already discovered


The main job of services.exe on Windows CE is to host service DLLs and provide a nice interprocess communication mechanism between them and applications. To a large extent it's very much like device.exe and in fact with it it's easy to move dlls back and forth between them. Services.exe is part of CE 4.2 NET, CE 5.0, CE 6.x, but not available at devices with CE 5.0 Core, most PNA/GPS come with. To overcome this lack, previous versions of MP provided commandline-tool "regsrvce.exe", today you start and/or stop DLLs (services) via TaskManager.

Edited by - jwoegerbauer on 03 déc. 2010 09:51:11
Go to Top of Page

mr.nonobservant

52 Posts

Posted - 03 déc. 2010 :  13:25:40  Show Profile  Reply with Quote
not on core 5.0 really? pretty sure my device has core 5.0 and it seems to work great??
how do you set the items that run under device.exe?

.... Magellan Roadmate 1220

Edited by - mr.nonobservant on 03 déc. 2010 13:32:11
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 05 déc. 2010 :  01:15:05  Show Profile  Visit Osprey's Homepage  Reply with Quote
Everyone,
I'm very sorry for taking so long to reply to everyone. I thought that it wasn't as long as it was. I've been busy, particularly with the holidays upcoming. I haven't been ignoring anyone... just taking a break to tend to other things.

vmax377,
Open MioAutoRun\Scripts\SubRoutines.mscr, search for the "Reset Device" sub-routine and change the order of the various reset commands, particularly putting the first one at the end (since chances are good that it's the one freezing your device).

eyal0,
1. I think that the fixed FixPaths.mscr that I uploaded at the top of page 100 will fix the MortScript file association issue, perhaps also fixing your other problems. Instead of downloading that now, though, I suggest just downloading R68 once I upload it.
2. Thanks. I've now fixed that. Yeah, this is the place to report bugs.

DeeNYC, jamesvior,
Please either download the new FixPaths.mscr in my post at the top of page 100 and copy it to MioAutoRun\Scripts or download the upcoming R68, which will have the fix included.

hawk196,
Thanks for sharing. I'll add that to the Readme. That's the first Motorola that I've heard of.

mundodisco,
1. Every time that MioPocket starts up, it sets the volume to the last one set via the volume control in MioPocket. So, what you should do is set your volume there, not in Garmin. If you want to prevent MioPocket from auto-setting the volume, though, you can do so by opening MioAutoRun\Scripts\StartupPrograms.mscr and putting a # in front of the SetVolume(...) command.
2. MioPocket doesn't come with the Control Panel expanded. Maybe you misspoke and meant that you're trying to keep them expanded and they're going back to unexpanded? If so, open up MioAutoRun\Registry\Explorer.reg and change the last 0 on the ExpandControlPanel line to 1. If you didn't misspeak, perhaps deleting your MioAutoRun\Registry\Custom\RegistryBackup.reg (and any other .reg files in that folder) will clear up the issue.

mdavis,
GAPI is in use only when you run supporting apps, which are few, so I doubt that that's your issue. It sounds like the chosen rotation executable/command simply doesn't work on your devices. If you open up MioAutoRun\Scripts\OrientationToggle.mscr and scroll down to the "Rotate" sub-routine, you can determine which one is run when you use the Rotate icons in MioPocket. What I would do is add a new line just above the "If(Shell eq..." line, put each of the following lines there one at a time, testing between each:

Run(ShellPath, "--rotate")
Rotate(90)
RunWait(ProgramsFolder\"RotateCE4.exe")
RunWait(ProgramsFolder\"Rotate.exe")

You mentioned running Rotate.exe already, but I mention it for thoroughness and for anyone else reading. If none of those lines work, then you may need to do your own searching around online for other ways to rotate (ex. freeware PocketPC software sites, other unlocks), since those above are the only ones that I know of.

CReePeR610,
No, there is no AM/FM radio tuner app in MioPocket, but what I believe that you misunderstand is that car DIN devices such as yours have two different operating systems. There's the GPS side and the side with everything else (radio, CD, DVD, MP3, TV, etc), and the GPS side (which is the only side that you can install MioPocket on) doesn't have access to those hardware features of the other side.

Ste.Bo,
I'm not sure, but that may be normal. Perhaps someone else can confirm or deny that the device can't turn itself back on when the ignition is started, at least with the Mio S760. I wouldn't be surprised if it doesn't, at least on some devices. You could try adding a line to PowerACOn.mscr to run something (like MioAutoRun\Programs\iTaskMgr.exe for testing and, if it works, something that doesn't doesn't display a window, like MioautoRun\Programs\PHM Tools\Desktop.exe or MioAutoRun\Programs\SetFullscreen.exe) to try to force the device awake. Also, you might check want to check that a power on notification was added (by PowerNotify.exe) in Control Panel->Scheduled Tasks and has the right path and everything. Finally, I'm not sure what it's for, but you could try enabling the "PowerResume" line in PowerNotify.ini and setting it to PowerACOn.mscr (since there is no PowerResume.mscr; TroNik just added it in case one were ever created).

John Dough,
When you run a nav app the correct way (via either of the two methods that I mentioned in my last post), the "KillApps" sub-routine in MioAutoRun\Scripts\AppLauncher.mscr is run. In that sub-routine, the ShellClose.mscr script is run and that script is where MiniBar.exe is killed. You can try putting # signs in front of the first line (the "ErrorLevel" line) of each of those scripts to see if you're getting any errors. You can also add Message commands on new lines (ex. Message("test") ) in the "KillApps" sub-routine and in ShellClose.mscr to debug whether they're getting run.

mayma,
Have you tried the Becker instructions under section "2.2 SD Installation" (specifically, 2.2a4D) of the Readme? If so, try explaining exactly what you have tried, step by step.

mr.nonobservant,
1. That's weird. I'm really glad and thankful that you solved it, though. I wouldn't have guessed that GPSTimeSync would've have anything to do with it.
2. Orion comes with your device, not with MioPocket. If you're saying that they don't appear in \Windows until after MioPocket is installed, then they're probably hidden files. In other words, they're always there, but MioPocket allows you to see them because that's one of the tweaks performed during installation.
3. BTW, good job with stopping the Orion service. Last January, I wrote... "Lexan in the MioPocket thread says that you can disable Orion in Control Panel, but I really need to find a way to disable it programmatically." ...You may've just found the solution for me. Thanks! I'll add that to Initialize.mscr.
4. Also, I'm impressed that you quickly figured out so much of MioPocket on your own (ex. tweaking Initialize.mscr, tweaking RegistryBackup.mscr, adding to MioAutoRun\Windows\Windows, etc.). Good job.

bumbum,
1. I believe that I disabled the GAPI splash screen in recent releases. Maybe the fact that you're using an R5x release (if your signature is up-to-date) is the reason. If you don't want to upgrade MioPocket, you could just copy MioAutoRun\system\gx.dll from the latest version to yours. If that doesn't change anything, then you could use a hex editor (like Extras\Win32\XVI32) to search in Primo.exe for "gx.dll" and change it to something else, like "g2.dll" (search both with and without the "Unicode Latin" box checked). That will disable GAPI in Primo entirely.
2. I don't understand. GAPI comes pre-installed in MioPocket. There shouldn't be any reason for you to install it manually.

stu.edwards,
It takes 30-60 seconds to install MioPocket (with the "MioPocket Installation" window on the screen), yes. As for the .mscr error, please see my post at the top of page 100 or upgrade to R68.

sergiozaki,
You should be able to use MioPocket on it, since it has Windows CE, yes. How well it'll work is unknown.

Danko.ba.nanko,
1. Thanks. I've identified the cause of both errors when using the Old Skin Add-on (and I'm surprised that no one has mentioned them before now) and the fixes will be in R68. If you just want to replace the two files that changed, they're MioAutoRun\Scripts\IconManager.mscr and MioPocketSettings.mscr.
2. App rotation works the same regardless of which skin you're using. Not being able to use the rotate button when running a rotated app/game is normal. That's because the rotation script is already running, waiting for the app/game to exit so that it can automatically rotate the screen back and a script can't run twice at the same time. You're meant to close the app in order to rotate back. If you'd like to make it so that you can rotate on your own, though, you can make a copy of MioAutoRun\Scripts\OrientationToggle.mscr (ex. OrientationToggle2.mscr), then edit the rotate button and make it run the copy that you made.
3. That's likely not a MioPocket thing. Windows CE controls the clock. I've never heard of that, though, and am not sure if you can do anything about it.
4. I don't know. I'd suggest posting in one of those threads. It doesn't matter much that they're old threads, since the info is still useful and posting in them will bump them up so people see them again.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 05 déc. 2010 02:13:24
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 05 déc. 2010 :  03:37:04  Show Profile  Visit Osprey's Homepage  Reply with Quote
Everyone,
Here's Release 68.

EDIT: I've re-uploaded R68 with some improvements and fixes. Please see my post on the next page for the links.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 06 déc. 2010 04:14:08
Go to Top of Page

mr.nonobservant

52 Posts

Posted - 05 déc. 2010 :  12:21:25  Show Profile  Reply with Quote
Osprey, thanks for the compliments I'm pretty deep into programming so its second nature.

That stuff with the GPS time sync was weird but its for sure what the problem was esp on cold starts of the gps and after crashes
when it had to wait for the GPS to get a fix I actually started by making two programs one that did a few window function and a second
to see if that one hung and did 100's of restarts till it hung and it never happened once on a warm start of the gps I haven't had
another problem since its been disabled and maybe since orion is disabled ill try it again soon and let you know if its changed



I have a few things that still need fixed from the last release
though I didnt see any mention of them so no wonder its still...

MioautoRun.mscr
navAppName is missing its assignment??

   NavAppName=SystemPath("ScriptName")        
        #If this is an SD installation, change the menu options
	If(ToLower(NavAppName) eq "mioautorun" OR ToLower(NavAppName) eq "auto" OR (not FileExists(SystemPath("ScriptPath")\NavAppName&"_orig.exe") AND not FileExists(SystemPath("ScriptPath")\NavAppName&"_org.exe"))
		NavAppOption = "Exit"
		SDtoSDFreeOption = "Install SDFree (via SD)"
	Else
		#Determine what name for the nav app to display in the menu
		NavAppName = SystemPath("ScriptName")
		NavAppName = ToUpper(CharAt(NavAppName, 1)) & SubStr(NavAppName, 2)
		Switch(ToLower(NavAppName))
		Case("miomap", "smartst_ce", "appstartupsec")
			NavAppName = "MioMap"
		Case("igo", "igo8", "igo2006", "primo", "amigo")
			NavAppName = "iGO"
		Case("mobilenavigator")
			NavAppName = "Mobile Navigator"
		Case("magellan_pna","mgnshell")
			NavAppName = "Navigator"
		Case("iguidanceqvga", "iguidance")
			NavAppName = "iGuidance"
		Case("polnav")
			NavAppName = "PolNav"
		Case("r66navigate8")
			NavAppname = "Route 66"
		EndSwitch

		NavAppOption = "Run " & NavAppName
		SDtoSDFreeOption = ""
	EndIf


The first one causes it to always be Exit because NavAppName="" and for the second my device uses mgnshell instead on magellan_pna

Currently, I'm having problems with the skin changer copying the exe from release 67 fixes it? did something change?
the versions are the same but I compared the files and the are quite different, maybe i got a corrupted file
but its unlikely since winzip didn't choke on the checksums....

#
#To backup the entire registry, pass "all" as the parameter:
#(Warning: At the moment, there's a nasty bug in the program used that exports some strings (like time zones) incorrectly, which might cause problems and is why the selected backup option above is recommended and used)
#

Does this 'Nasty' bug still exist? If so what exactly does it do as I've had the all setting selected for powerprompt
for about a week now with no discernible ill effects.

Why does console have to be set output to screen to run Batch(.bat) files? otherwise it fails stating it is low on memory or too many console windows are open

See this thread about the Magellan roadmate 1220's factory original software and starting it: http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=138757

Thanks for your work on another release, We all appreciate the
current and continued work on MioPocket and its pretty amazing
to see all you have working based on scripting
Ps. is there anyway to use vbscript(.vbs) on CE?

.... Magellan Roadmate 1220

Edited by - mr.nonobservant on 05 déc. 2010 12:36:21
Go to Top of Page
Page: of 190 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,11 seconds. Powered By: Snitz Forums 2000 Version 3.4.05