Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2299




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 How to upgrade/downgrade the firm. on Mio (Moov+C)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 167

srelioskoz

Greece
180 Posts

Posted - 01 févr. 2011 :  21:16:22  Show Profile  Visit srelioskoz's Homepage  Reply with Quote
ablbd

srelioskoz, not in Samsung directory but in NAND-FLASH; if you have older hjtag, take the newest from their site. Definition file goes to hjtag\fdevice\nand-flash and driver to hjtag\fdevice\nand-flash\drivers. In step 1 select driver also from nand-flash...

ok i put the files as you said
i start h-jtag server ,i see the application
i start h-flasher server ,i select nand-flash /S3C2443+K9G2G08_4bitECC
i try to read but and i see.......... error :can't download driver to specified address

what i do wrong again?

i see one more file with name:
C:\Program Files\H-JTAG\FDevice\NAND-FLASH\SourceCodes (ADS1.2)

is there a chance to do something with this file?

Edited by - srelioskoz on 01 févr. 2011 21:37:46
Go to Top of Page

navi-gps

49 Posts

Posted - 01 févr. 2011 :  21:18:44  Show Profile  Reply with Quote
@g_alin

Mio c520 and Your rom working fine. Thanks!

My mio Moov M300 is Poland version , i buy this device in Media Markt.
I have connect only h-flasher, and lcd screen its black.
whether it is possible to upload through h-jtag? if so, what place? Block Page
Thanks for Your help.

@ablbd

Sorry if you understood me wrong. I am very grateful for your help!!!
all the time I wrote about one and the same mio m300.
yes, it takes a GPS/gsm.
once again sorry.

Go to Top of Page

g_alin

USA
817 Posts

Posted - 01 févr. 2011 :  21:23:35  Show Profile  Reply with Quote
navi-gps,
"whether it is possible to upload through h-jtag?"
No ... you have to use the UPGRADE SCREEN (original bootloader).
(If you didn't changed the original bootloader) try to find the "LOCKEDUT" string (ablbd can give you some hints) and replaced with "UNLOCKED"
Go to Top of Page

navi-gps

49 Posts

Posted - 01 févr. 2011 :  21:34:06  Show Profile  Reply with Quote
Yes. But i write wrong image to my M300, and now even doesn't work lcd. Only h-jtag

Thx


i write this rom for my m300, and reseting device and black screen
http://www.failai.in/show/F/21F3AA4D2/Moov_M300___Adriatic___R00.00.1029.64M.zip

Edited by - navi-gps on 01 févr. 2011 21:37:27
Go to Top of Page

ablbd

361 Posts

Posted - 01 févr. 2011 :  23:14:51  Show Profile  Reply with Quote
srelioskoz
-Go to h-jtag "Settings", "LPT JTAG setting" and set both nTRST and nSRST to "No TAP RST"
-Save h-flasher settings so next time you will enter, everything will be set
-Leave opened h-jtag server and h-flaser, switch device off then on, press quickly detect on h-jtag (symbol of a magnifying glass) then in h-flasher "Check" button; if still cannot download driver, repeat this procedure. The explanation is that is no harwdare reset signal connected to jtag and h-jtag has some minor bug in resetting the hardware via a "special" jtag command... Don't blame them, the reset combination seams that has to be issued 4 times in order to work 100% but nobody knows why is not enough 1,2 or 3 times.

I'm almost sure that this time is going to work.

BTW: before jtag unlock, have you tried the iboot.exe trick? If you can start ceecmd, from there you can execute \windows\USBScreen.exe ...

Edited by - ablbd on 01 févr. 2011 23:43:49
Go to Top of Page

ablbd

361 Posts

Posted - 01 févr. 2011 :  23:28:00  Show Profile  Reply with Quote
navi-gps
It's OK
I don't want to go into exhausting technical details, you have to believe me that is not possible to upload OS on jtag.
What you can do is to replace on jtag boot blocks(allways save them before doing anything) as it sould go at least until blue screen. If you have those boot blocks for M300, I suggest that before reflashing them erase entire nand (erase comand, from block0/page0 to the last block/page available). After a full erase and after reflashing boot blocks, will enter blue screen if SD card is present.
Go to Top of Page

navi-gps

49 Posts

Posted - 01 févr. 2011 :  23:42:34  Show Profile  Reply with Quote
You write on 90 page

"For safety reasons, read also block0-page0 to block1-page127 and save this file as it's containing your boot blocks. It would be usefull for me or others to upload boot blocks."

I did dump as yet worked m300 Block=0 Page=0 to Block=1 Page =127 (1mb)

If I understand correctly, I erase the memory of (H-flasher)
then upload dump to Dst. Adres Block=0 Page=0 ?

screen:

new hosting
http://img148.imageshack.us/i/dumpp.jpg/

Thanks!


Edited by - navi-gps on 01 févr. 2011 23:50:49
Go to Top of Page

ablbd

361 Posts

Posted - 01 févr. 2011 :  23:46:03  Show Profile  Reply with Quote
Cannot open the picture (error 404) but YES, this is how you can recover blue screen.
Go to Top of Page

navi-gps

49 Posts

Posted - 01 févr. 2011 :  23:56:52  Show Profile  Reply with Quote
http://img9.imageshack.us/i/erasedanddump.jpg/

Unfortunately, still nothing, just black screen and connection to h-jtag
Go to Top of Page

g_alin

USA
817 Posts

Posted - 02 févr. 2011 :  03:23:59  Show Profile  Reply with Quote
navi-gps,
You should be able to access the BLUE SCREEN, even if you write the wrong firmware ... bootloader its a different part of the flash.
Go to Top of Page

ablbd

361 Posts

Posted - 02 févr. 2011 :  06:16:00  Show Profile  Reply with Quote
g_alin, you're right, theoretically blue screen(uboot menu) should not be affected by loading wrong OS. Only theoretically...

I was playing for a while with different boot blocks, OS's and cooked OS's (device remained all this time connected on jtag) and once happened that altough unlocked, it didn't reacted to presence of SD. OS was an R2 version for Moov330. I was forced to reflash boot blocks.

My guess is that after 1'st instalation, OS is writing into boot block region, in a place which it consideres to be empty, some initial bad block table and information about which physical sector corresponds to logical sector 0 (shortly, the physical location of MBR); a "very" wrong OS will/could overwrite code...

Edited by - ablbd on 02 févr. 2011 07:45:38
Go to Top of Page

alex2000

Romania
12 Posts

Posted - 02 févr. 2011 :  12:28:42  Show Profile  Reply with Quote
Hello
I have one big problem.I manage to enter blue screen on Navman N188 = F15, but i can't find the img file for this.On screen appear Cobia200_R02_0515 RAM 32 MLC 256M.If anyone can help me, i will apreciate.Thanks a lot
By the way on the motherboard it's write :

PWA:COBIAT300_MB
PCB:316168400001_R01
ASSY:411168400005

Edited by - alex2000 on 02 févr. 2011 12:45:09
Go to Top of Page

srelioskoz

Greece
180 Posts

Posted - 02 févr. 2011 :  16:58:16  Show Profile  Visit srelioskoz's Homepage  Reply with Quote
ablbd.
thank you for your usefull informations.
mio 330 works again !!!!!!

at 4th time h-flasher find the driver.
then i made read from block 16 ...page 127
then i found in this file the line locked and i made it unlock,and put the new file in mio with h-flasher.
when finish,i made reset my mio and i started up again with the sd card inside.
and i saw the blue screen.

thank you again!!!

Edited by - srelioskoz on 02 févr. 2011 16:58:59
Go to Top of Page

ablbd

361 Posts

Posted - 02 févr. 2011 :  17:42:56  Show Profile  Reply with Quote
srelioskoz, good work! After this experience I suggest to forget pin9 procedure as jtag is much safer and you have the possibility to save boot blocks too for each device.

alex2000, cobia200(...) means bootloader version, cobiat300_ means OS version.
Go to Top of Page

alex2000

Romania
12 Posts

Posted - 02 févr. 2011 :  18:13:55  Show Profile  Reply with Quote
Thanks, but can i do now ?
Go to Top of Page
Page: of 167 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 0,78 seconds. Powered By: Snitz Forums 2000 Version 3.4.05