Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 1941




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 How to upgrade/downgrade the firm. on Mio (Moov+C)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 167

srelioskoz

Greece
180 Posts

Posted - 31 janv. 2011 :  22:32:05  Show Profile  Visit srelioskoz's Homepage  Reply with Quote
yes it works with navi_gps program.
thank you.
ID=0xecda

but it writes...
[k9g8g08 nand flash jtag programmer]
error :k9g8g08 or k9lag08 is not detected.
detected id=0xecda.

Edited by - srelioskoz on 31 janv. 2011 22:47:42
Go to Top of Page

navi-gps

49 Posts

Posted - 01 févr. 2011 :  01:16:28  Show Profile  Reply with Quote
Ok i have bootloader menu

Mantas_415A320_UT_R16_0913 MLC 1G

which version rom do I load?

Model nr. MIO C520
Go to Top of Page

g_alin

USA
817 Posts

Posted - 01 févr. 2011 :  01:26:10  Show Profile  Reply with Quote
probably C520_WEU ...
Go to Top of Page

navi-gps

49 Posts

Posted - 01 févr. 2011 :  01:36:53  Show Profile  Reply with Quote
Oryginally my mio have rom C520_EEU_ROM_R02.3.9911.1018
i have this rom but i don't have checksum file.

========================================================

i write new rom and device working perfectly ;)

========================================================

last problem. When the device is a memory card, no matter whether clean or with the program, each time show up Blue Screen (bootloader menu).

How do I turn it off?


Edited by - navi-gps on 01 févr. 2011 01:46:28
Go to Top of Page

g_alin

USA
817 Posts

Posted - 01 févr. 2011 :  02:36:53  Show Profile  Reply with Quote
navi-gps,

Page 94:
On the first page (http://www.4shared.com/file/cvkc5b2z/UPGRADE_MIO_11Jun10.html ) there is a software that is able to unlock UPGRADE SCREEN (to change your firmware ...). If you insert the SDCard and the software doesn't start automatically ... you have to unlock your device (with any unlock procedure you want) and start manually 'YOUR_SD_CARD'\UPGRADE\w_coredll\cUPGRADE_APP_.exe if doesn't work try 'YOUR_SD_CARD'\UPGRADE\wo_coredll\UPGRADE_APP_.exe
Same software can be used to lock your UPGRADE SCREEN ... (Don't forget: If you left UPGRADE SCREEN open, you can always recover your device ... easily)
Go to Top of Page

ablbd

358 Posts

Posted - 01 févr. 2011 :  06:15:57  Show Profile  Reply with Quote
srelioskoz
Download this http://www.4shared.com/file/JrKGoBDS/2443_k9g2g08.html , put each file in it's place under h-jtag nand-flash directory then use h-flahser with this driver(1-flash selection), set RAM Start Addr to 0(2-Config) then goto 4-Programming.

Before doing anything, save your boot blocks: "Read" from block0/page0 to block3/page127; with that you can recover device from scratch... After that "Read" block16/page0 to block16/page127, edit LOCKEDUT string and "Program" it in same place(Src File: the modified one...)

Edited by - ablbd on 01 févr. 2011 07:20:26
Go to Top of Page

neriokas103

Lithuania
49 Posts

Posted - 01 févr. 2011 :  06:59:51  Show Profile  Reply with Quote
@ablbd @navi-gps

someone knows where i can get rom update file? maybe i can create myself if i have another all ready working the same novigation? Thanks..

Mio Navman M300
Go to Top of Page

ablbd

358 Posts

Posted - 01 févr. 2011 :  07:23:56  Show Profile  Reply with Quote
@neriokas103
Find a working and unlocked M300 and make a copy of SMFlash with DiskRW.
Go to Top of Page

navi-gps

49 Posts

Posted - 01 févr. 2011 :  11:20:13  Show Profile  Reply with Quote
@g_alin

thanks, Your link working ok :)

now i need checksume file for this rom
winceimg.cks


http://www.4shared.com/file/129461850/cb2a83d3/C520_EEU_ROM_R02399111018.html

how to calculate the checksum?
Go to Top of Page

peniko

20 Posts

Posted - 01 févr. 2011 :  13:41:37  Show Profile  Reply with Quote
Hello,

I bought bricked Mio s600 with no usb access. The guy who sold it to me told that he tried to install some shell and that it failed, so the device just showed Mio yellow screen. I bought it and managed to run some shell from sd card (iBoot.exe method)and to access all the files via total commander. As i use this device for my company's truck, I must have original software on it. The good thing is that he kept original software on device's flash storage, but changed everithing else. So I need someone to tell me how to restore it to it's original state (meaning that I'll need all the files beside those in MioMap folder. Thanks in advance
Go to Top of Page

navi-gps

49 Posts

Posted - 01 févr. 2011 :  15:27:28  Show Profile  Reply with Quote
I have 2 pcs. Mio Moov M300 (Model No. N254) R02.00.0766.STF64M

1. Working device and i read discrw SMFLASH (TATA 300 A/E WWE R01 2G C567)
- connect to h-jtag / h-flasher

@neriokas103

http://www.4shared.com/file/DU67i3ZQ/SMFlash_0_102760448.html
==========================================================================================
2. device don't worked :)
- only connect to h-jtag , h-flasher
- lcd its black
-don't connect to sjf2443 and dnw.exe :(

To this unit Uploader bad rom and after that did not even turn on the screen is black. The device is fortunately viewed by H-jtag , H-Flasher
how to copy a working device that defective to work?
======================================================================
@ablbd

When i read memory in H-FLASHER
Block=16 Page=0
to
Block=16 Page=127

i have 512kb

now in other device write this dump to Dst. Addr.

Block=16 Page=0 ??? or Block=16 Page=127

screen.

http://wgrajfoto.pl/pokazfoto/img0211/hjtag220e.jpg

what value I have read and exactly where to save?

Edited by - navi-gps on 01 févr. 2011 15:58:04
Go to Top of Page

srelioskoz

Greece
180 Posts

Posted - 01 févr. 2011 :  15:54:05  Show Profile  Visit srelioskoz's Homepage  Reply with Quote
ablbd.
thank you.

i put the file S3C2443+K9G2G08_4bitECC to fdevice/samsung
i put the file driver1309 to Fdevice/samsung/drivers.
but when i go to h-flasher 1 flash selection samsung,i can't see s3c2443+k9g2....file
i tryed with different ways and when i made to select S3C2443+K9G2G08_4bitECC ,and try to make ''read'' i have this...
error ..can't download driver to spesified address
Go to Top of Page

ablbd

358 Posts

Posted - 01 févr. 2011 :  17:13:15  Show Profile  Reply with Quote
srelioskoz, not in Samsung directory but in NAND-FLASH; if you have older hjtag, take the newest from their site. Definition file goes to hjtag\fdevice\nand-flash and driver to hjtag\fdevice\nand-flash\drivers. In step 1 select driver also from nand-flash...

navi-gps, don't mix devices; edited block has to go into device from where it was copied.
BTW, if I recall well, in last 2 weeks you asked assistance for 5 devices. Are you running a repair service or what? If so, would be better to learn more, internet is plenty of documentation!
And one more thing. You are not kindly asking but DEMANDING... as you would be my boss; the main difference is that my boss is paying me!

Edited by - ablbd on 01 févr. 2011 19:01:51
Go to Top of Page

hane12345

1 Posts

Posted - 01 févr. 2011 :  19:39:53  Show Profile  Reply with Quote
Hi!

I am encountering problems with Moov Mio 330.(Europe)

I have been able to upgrade the firmware with the pin 9 trick to
COBIA410.V1.00.0028

Upgrade screen says Cobia400_R06_0131 RAM64 MLC 1G
(Different to 410...hmmm..)

When upgrading, when i select 0=WINCE by SD/MMC (Format),
the upgrade does not seem to work:
Waiting!!
BOOTSEC is in Sector 243!!
MountDisk SUCCESS!
Open CEImage ...
CheckSum: 0x43a048e6
Writing CE image...
BINFS img
Read Progress:100%

And it stops here.

If i select without format, the upgrage works and asks to restart the device.

After the upgrade, the USB screen came up 2 times, and i tried to reinstall the software with MIO Desktop, but the Moov froze halfway through. Now it boots every time to the orange screen and freezes, as it did before starting the fixes. Is there something else to try out?

Help appreciated!
Go to Top of Page

g_alin

USA
817 Posts

Posted - 01 févr. 2011 :  20:09:17  Show Profile  Reply with Quote
navi-gps,
I updated the zip file (added the cks)
http://www.4shared.com/file/129461850/cb2a83d3/C520_EEU_ROM_R02399111018.html
As for M300 you have a Croatian version of the EU:
Moov_M300(N254)_EU_Croatia (ROM_R02.00.0766.STF64M) http://www.4shared.com/file/4yYzii76/Moov_M300_N254__EU_cr_ROM_R020.html
You can test also the Polland version: Moov_M300(N254)_EU_Poland (ROM_R02.00.0766.STF64M) http://www.4shared.com/file/qjhNeC-5/Moov_M300_N254__EU_pl_ROM_R020.html
(Both firmwares are identical .. the region.bin is different).
Let me know if are working.

peniko,
Copy all the files from My Flash Disk to a SDCard ... after that you have to download the SMFlash using DiscRW:
First page:
"If you have a different firmware you need to back-up your wince. To do that, you need DiscRW utility.
If your device is unlocked and you can run applications on your PNA, try to use this DiskRW software:
http://www.4shared.com/file/134354901/9ef633/DiskRW.html
instructions:
1.Start DiskRW
2.Select from combo-box (close to 'Store:') -> SMFlash
3.Press '...' button and select 'Storage Card' (where to save your SMFlash.img); If '...' doesn't work you can write (using any keyboard you have) the name of the SDCard folder of your PNA (ex: \Storage Card\, \SDMMC\ ...)
4.Press 'Read' button. A Hourglass will appear and it will take approx. 30 sec.
If the above application doesn't work, you should contact me to (on this thread) to fins a solution. Because every device is different I can’t give you a DiskRW custom made for your model."

hane12345,
sound like a hardware problem ... when wince is accessing the My Flash Disk at some point freeze. In BLUE SCREEN you have TOOLS ... check if you have some Test Memory ... or something like that (maybe you can mark the bads from flash and use the rest of the flash ...)

Edited by - g_alin on 01 févr. 2011 20:47:17
Go to Top of Page
Page: of 167 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 0,61 seconds. Powered By: Snitz Forums 2000 Version 3.4.05