Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2167




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 How to upgrade/downgrade the firm. on Mio (Moov+C)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 167

ventzel

Romania
11 Posts

Posted - 09 déc. 2010 :  00:02:53  Show Profile  Reply with Quote
@ablbd: Thanks, tomorrow i'll change back flash chip with k9gag08 ang i'll give it a try. I'n not entirely sure that s3c2450 boot up from iROM. It have 5 pins (OM) that configure how does it boot( IROM, Jtag, nand etc).
Yesterday i was connecting debugger to it and it seems that only was executing code from nand and it isnt anything from irom ( i don't find any call to adresses of copy functions described in datasheet). Im not sure what type of ecc uses but in first 8K of nand program adresses ecc registers.
Go to Top of Page

ablbd

358 Posts

Posted - 09 déc. 2010 :  06:14:02  Show Profile  Reply with Quote
Does it work with k4g0g08? ECC in spares from donor is 4bit, as I expected.
I made a confusion, you have moov500 and not moov360 so better not try this dump, it will not work, hardwares are too different.

Edited by - ablbd on 09 déc. 2010 06:15:53
Go to Top of Page

yolle

4 Posts

Posted - 09 déc. 2010 :  12:11:41  Show Profile  Reply with Quote
g_alin
Can you please extract Winceimg from this file.
will appreciate..

tnx
quote:
Originally posted by notmee

installed Miopocket 4 (had Miopocket Mini but it didt'n behave nicely) so i got the smflash file...

http://www.4shared.com/file/3jxyeXGk/SMFlash_0_35651584.html

cheers, notmee

Go to Top of Page

peniko

20 Posts

Posted - 09 déc. 2010 :  23:15:23  Show Profile  Reply with Quote
Hy guys, hope this is right place to post. Basically, I have a problem with Mio Moov M400 device. I tried to install Mio Move desktop and ended with the screen showing USB connection. I managed to make it to be recognized by a computer as flash disk, but there was no way to enter it with any of my computers, XP or Win7. It looked like messed USB stick or memory card, blocking my computer. So I entered UBOOT using pin-9 method and did something ingenious: Entered 6.Other Tools/8.Format.

So now I have a device which enters UBOOT when turned on, which doesn't have memory card slot and is recognized by a computer as SEC S3C2443X TEST B/D. So my question is: Is there a chance to somehow force the firmware to my device via USB? I have to mention that I tried with DNW.exe, but no luck, although the screen on GPS sais "USB Cable connected" when I try 3.Base CE Upgrade/1 and 2 Base by USB.

Thanks
Go to Top of Page

g_alin

USA
817 Posts

Posted - 09 déc. 2010 :  23:22:54  Show Profile  Reply with Quote
yolle and notmee

I extracted the firmware (I hope your Blue SCREEN menu has the "Base CE" and "Region" ... because I extracted according to this type of format ...).
You can update also the Region (if you have the same region ....).
http://www.4shared.com/file/ovARP6-J/Moov_M300_Adriatic_R0000102964.html
Please let me know if it works.

"I have to mention that I tried with DNW.exe, but no luck"
Did you tried to upgrade and what happened?

Edited by - g_alin on 09 déc. 2010 23:25:58
Go to Top of Page

peniko

20 Posts

Posted - 09 déc. 2010 :  23:34:41  Show Profile  Reply with Quote
quote:
Originally posted by g_alin

yolle and notmee

I extracted the firmware (I hope your Blue SCREEN menu has the "Base CE" and "Region" ... because I extracted according to this type of format ...).
You can update also the Region (if you have the same region ....).
http://www.4shared.com/file/ovARP6-J/Moov_M300_Adriatic_R0000102964.html
Please let me know if it works.

"I have to mention that I tried with DNW.exe, but no luck"
Did you tried to upgrade and what happened?



It has Base CE and REGION. Basically, i start DNW.exe, go to "Transmit/Transmit" and it says "Can't open USB Device". The main problem is that I can't access the device no matter what...
Go to Top of Page

peniko

20 Posts

Posted - 10 déc. 2010 :  02:14:43  Show Profile  Reply with Quote
Other thing, other device I bought is broken Moov 200. I tried with Cobia on SD card, tried pin 12/19 then pin9 method, but still cant enter UBOOT. When I start the device it says "Cobia300.v1.00.0030" and the flash disk model is "K9G4G08U0A". So, the guy who sold me these devices just didn't have nerves to deal with them. Since I can't enter UBOOT on this device and have annoying problem with Moov M400, it seems that he knew that there might be no chance to repair at least one of these devices. I think that I payed 80e for something that will be thrown away very soon... Is there a chance for me to repair Moov 200 at least??? Just to mention that when I turn the device on, I only get yellow screen with Mio written (not "the program database cannot be found" or something like that). Kind regards

Edited by - peniko on 10 déc. 2010 02:17:12
Go to Top of Page

g_alin

USA
817 Posts

Posted - 10 déc. 2010 :  04:48:00  Show Profile  Reply with Quote
peniko,

Maybe you have an old DNW ... don't trow away the devices (yet ... until we figure out). For sure you can JTAG the Moov 200 and change the UTLOCKED into UNLOCKED to access the BLUE SCREEN. Let me know if you have the knowledge and tools to connect to GPS through JTAG.
Go to Top of Page

peniko

20 Posts

Posted - 10 déc. 2010 :  08:44:51  Show Profile  Reply with Quote
quote:
Originally posted by g_alin

peniko,

Maybe you have an old DNW ... don't trow away the devices (yet ... until we figure out). For sure you can JTAG the Moov 200 and change the UTLOCKED into UNLOCKED to access the BLUE SCREEN. Let me know if you have the knowledge and tools to connect to GPS through JTAG.



Well, I'm an mechanical engineer (without a job; that's why I am buying old, unchecked devices ), so probably some knowledge is here. What is JTAG? What tools do I need? Thnx

Edited by - peniko on 10 déc. 2010 08:53:28
Go to Top of Page

white_flag

22 Posts

Posted - 10 déc. 2010 :  08:52:41  Show Profile  Reply with Quote
Hello g_alin,

did you do something with my image? (it is possible to extract the old firmware?)
thx
Go to Top of Page

yolle

4 Posts

Posted - 10 déc. 2010 :  10:33:30  Show Profile  Reply with Quote
g_alin
Basicly it works,device can connect to pc,but after that cannot run MioMap.
The reason for that is that when device starts up,it show Usb connection from Navman device. Now i must get UBOOT for changing to get splashcreen from Mio(when device powers it shows that screen).

tnx
Go to Top of Page

g_alin

USA
817 Posts

Posted - 10 déc. 2010 :  19:24:17  Show Profile  Reply with Quote
peniko,
Here (http://www.4shared.com/file/JAIsslVX/RecoverMioCX20.html) you have most of the informations .... ablbd is the most knowledgeable in JTAG recovery ... maybe does have some specific (for your memory) software to write the Flash through JTAG (modified SJFs.)

white_flag,
(very good that you remind me ...) I can recover the firmware from device ... (99% sure). Can you tell me the Region (NA, EU ... or what region ... for the record only ..)

yolle,
"Usb connection from Navman device" ... I am surprised !!!
Are you sure the SMFlash is from a Moov_M300 device? or is from a Navman device? (It is important to know ...)

Edited by - g_alin on 10 déc. 2010 20:22:30
Go to Top of Page

yolle

4 Posts

Posted - 10 déc. 2010 :  20:35:47  Show Profile  Reply with Quote
g_alin
I know, so was I. I,m not sure now :) but when i saw that FW which _notmee_ posted is for Adria-Balcan region i supposed that is right (all matches incl. uboot menu)
---If you will give a try i will get identical device and get the SMflash.Then we will now for sure.
I already had M400 with this "problem" and with uboot solved it. Because if it shows different screen original MioMap wont start-up.
Go to Top of Page

g_alin

USA
817 Posts

Posted - 10 déc. 2010 :  20:40:45  Show Profile  Reply with Quote
yolle,

Do you know the Device Name, Model and Region (for the record only ...) of the SMFlash extracted (from Navman device)? If you can get a SMFlash (from M300) I will extract the firmware ...
Go to Top of Page

yolle

4 Posts

Posted - 10 déc. 2010 :  20:59:09  Show Profile  Reply with Quote
g_alin
According to _notmee_ device is MioMoovM300Adriatic(EX Yugoslavia countries),board is TATA300_R02. Because of that i was suprised too how(WTF) usb-connection screen from Navman device showed along.But it posible that N.avman uses identical boards for other region markets.
I will try to dump new device this monday.
Go to Top of Page
Page: of 167 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 0,67 seconds. Powered By: Snitz Forums 2000 Version 3.4.05