Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2247




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 How to upgrade/downgrade the firm. on Mio (Moov+C)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 167

a33pul

USA
32 Posts

Posted - 19 août 2009 :  08:25:23  Show Profile  Reply with Quote
alin
can you tell me how to write an excutable file to bring up the killed menue.let me explain, i instaled the mio and then tried to kill the orginal start up app an killed the loader. exe and still th menue was running, then i killed the auto luanch.exe. now how can i replace or write an excutable file that unit can excute the menue. as i said when soft reset, i get the logo only and then nothing comes up. i donet see nothing on screen to hard reset or factory reset. i darined the battery but no change.do you have the mio pocket file
startupappsbackup.reg
i can not find it in downloads.in read me says to copy to costum and start reinstall again
5.16 How do I kill my device's original software?

Go into MioPocket Settings, then "System->Manage startup apps." The apps listed there are run at startup via the HKLM\init registry key. Identify the app that you want to kill (use Task Manager to confirm the filename), then tap on it and choose "Delete this app." Be careful with this, as stopping apps that were meant to run at startup could have unpredictable and undesirable results (ex. stopping USB from working). If you make a mistake, you can, at any time, choose "Restore original startup apps" to go back to the list of startup apps that you had before you made any changes. If, for some reason, you are unable to use that option, copy MioAutoRun\Registry\Exclude\StartupAppsBackup.reg to MioAutoRun\Registry\Custom and re-install MioPocket.
i need the startupappsbackup.reg file
Go to Top of Page

marian78

11 Posts

Posted - 19 août 2009 :  08:29:49  Show Profile  Reply with Quote
Hi,

i used miopocket many times. Read this " http://www.gpspassion.com/upload2/MioPocket%20Readme.html#2.2a ". There is wrote: "4D) Non-Mio devices
Warning: Some obscure GPS devices (especially no-name Chinese GPS devices) d o n o t r e v e r t W i n d o w s back to an unmodified condition when you perform a hard reset. You are advised against putting MioPocket on such devices because there is no way to undo any undesirable changes and you might permanently brick your unit. Most reputable brands, including all of the following, are fine." Maybe your after hard reset dont revert.



quote:
Originally posted by a33pul

thanks g_alin here are the info
my gps is a chineese version
4.3" SAMSUNG400MHz/GPS+Bluetooth+MAP+MP4+2G Card/SP-43A
romversion:18.jx.4.bf.1.4.2.8
processor: arm920t
ram size: 64mb
software version: 2.08
sirflll
i dont know how to up grade but my first concern is to get the gps back in order, no screen at all. when i soft reset it only the logo comes on

Go to Top of Page

zer0en

Belgium
8 Posts

Posted - 19 août 2009 :  14:02:40  Show Profile  Reply with Quote
Hallo all,

-Start miomore desktop, connect moov330 to pc, switch moov on.
-goto mio device with explorer on your pc and right click,then do a
format.
-disconnect device with hardware disconnect, close miomore desktop.
-do a hard reset on the device and wait a few minutes then start
device again.
-open miomore desktop and connect device to pc.
-in miomore desktop - extras - reinstall software.
-question: Do you want to backupp, answer yes or no.
-close miomore desktop and reopen.
-to the left there must be 8 choices.
-If only 4 options visible then close and reopen miomore desktop.
-option:reinstall speechfiles
-option:reinstall maps, first got to - extras - repair codes
then click on my maps in miomore, then choose where to install,
flashdisk or sd card.

thats it, btw, a have tried a cd shipped with the moov of a friend, and everything works as expected so i can conclude they shipped the wrong cd with my moov.

Best regard,

Julien


quote:
Originally posted by kener

zer0en

Can you post here in short the
explanation how to reinstall the software for the email.
Never know when it's needed.

Thanks.

Go to Top of Page

g_alin

USA
817 Posts

Posted - 19 août 2009 :  19:46:42  Show Profile  Reply with Quote
a33pul,
I don't have startupappsbackup.reg ... I don't know almost anything about mioPocket ... shame on me :( .
Now I understand your problem ...
You have a device that do not delete the ROM (RAM based in most of the situation) when you perform a hardware reset. That may happen in two situation: was designed by in idiot or doesn't have Flash at all (the wince is in a battery backuped RAM).
Your options are:
1. Remove the battery (not drain the battery ...). Disassemble the GPS and disconnect the connector that connect the rechargeable battery to PCB (board). Left that battery disconnected over night. Connect it back in the morning (don't assemble back the GPS ... you see later why ...) If there is no change go to option 2.
2. Find the backup battery (if nothing changed probably you have a back up battery for RAM). Backup battery are usually small coin battery (most of the time not rechargeable) - like a small cylinder with two terminals, that are shiny or are covered by a plastic tube (to avoid short circuit with components that are around battery). Usually you need a soldering machine to desolder that battery from PCB (in the same time the other battery also should be disconnected) ... left it over night. Connect the backup battery and the main battery back ... and try again.
Side effects: If you don't have the wince on Flash and is only in battery backuped RAM (theoretically is possible ...) then you'll loose your wince information and you'll have to find the way to upload your wince back to RAM - so is possible to make your device unusable (not that now is usable ... but is better to now the risks).

zer0en,
Interesting that they don't perform any OS / GPS model check before upgrade ... that is an amateur mistake.
Go to Top of Page

a33pul

USA
32 Posts

Posted - 19 août 2009 :  21:09:17  Show Profile  Reply with Quote
alin. thank you i will try let you knoe.
zeroen. i am an amateur. just loved the chalnge and changed to mio pocket but had three isues, not datasync, not seeing the blue tooth and the original menue was poping first, but it was working, i tried to fix it and messed it up.
Go to Top of Page

Foxer

Romania
17 Posts

Posted - 24 août 2009 :  04:07:25  Show Profile  Reply with Quote
so if i want to make a backup of "My Flash Disk", all i have to do is copy/paste it onto the SD/MMC card for safe keeping.. is that right?
Than all i have to do is upgrade the firmware from v3.1 to v3.3 on my C510, and then copy back the contents of My Flash Disk..?
(i just wanna know if i got everything right)
Thanks in advance. All this has been vere helpful!

Mio C510
Go to Top of Page

marian78

11 Posts

Posted - 24 août 2009 :  08:58:09  Show Profile  Reply with Quote
hi,
i try and nothing happend. Maybe my GPS is unrecoverable. I try DiskRW2, boot GPS, insert SD with extracted DiskRW2 and nothing.
Maybe my SD slot dont work too. Now only jtag maybe help but i dont now how.

Thx.

Marian.



quote:
Originally posted by g_alin

marian78,
try to use diskrw2.zip ... to download SMFlash.img.
1.Start DisKRW
2.Select from combo-box (close to 'Store:') -> SMFlash
3.Press '...' button and select 'Storage Card' (where to save your SMFlash.img)
4.Press 'Read' button
if you have any problems let me know.
Upload somewhere that file and we'll see from there.


Edited by - marian78 on 24 août 2009 09:00:57
Go to Top of Page

g_alin

USA
817 Posts

Posted - 24 août 2009 :  20:58:32  Show Profile  Reply with Quote
Foxer,
Yes .. but you need to be sure that you copied also the hidden files and folders (in explorer make sure you see Hidden and System files). But if you upgrade without Format ... everything from My Flash Disk should be untouched. Maybe you should consider to download your SMFlash (and I will extract the winceimg.bin) in case that you have any problems with this new firmware to be able to go back to your firmware ;) .

marian78,
Unfortunately I don't see any software option ... there are some claiming that on Moov they managed to reset somehow the device ... http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=114520 is one (risky) option before JTAG.
Another option (very few chances too work) is to make a bootable SDCard with a SMFlash image http://www.smart-host.ro/sd_card/ download from here an C520 image and using wimhex write the image on the SDCArd ... insert the SDCard and performa a hardware reset ... maybe is going to boot ...
Go to Top of Page

Foxer

Romania
17 Posts

Posted - 24 août 2009 :  21:40:17  Show Profile  Reply with Quote
thanks g_alin for the fast reply!
I'm extracting the ROM image from my c510 as we speek (or as i'm typing; to be more precise :P )
The link you posted with the c510 firmware, doesn't work; so i managed to find something on a russian website (Mitac Mio C510 Firmware (rus-eng) v.R35F.3.126.0711) http://www.x-drivers.com/catalog/bios_firmware/gps/companies/mitac_mio/models/c510/index.html ..what do you think?

I'm planing to go ahead with the firmware upgrade (from 3.1 to 3.3) altho i have no idea what good will that do..

I have miomap2006 installed, it came with the device, and i bought the device Second-Hand. I don't even have the DVD. It had already been Mod.-ed, coz when i tapped on the round MioMap icon, it took me to Total Commander, and from there i could browse through the device and start the application.

Today's atempt to upgrade to a 2008 map was a failure.. license problem. Don't really know what to do here..
I don't really want to install skins and all that on the device; i just have a few apps and a TaskMan that i'm verry contempt with, but most of all i want the GPS part to work as good as possible. The 2006 Romanian map is awful.. and u guessed it.. i live in Ro.

P.S. Thanks 4 all the help!

Mio C510

Edited by - Foxer on 24 août 2009 22:20:57
Go to Top of Page

Foxer

Romania
17 Posts

Posted - 24 août 2009 :  23:23:59  Show Profile  Reply with Quote
here are the .img files that i got from my device

http://www.filefactory.com/file/ah3h153/n/c510_img_files_rar

alternative link: http://ul.to/kxrjjk

Thank you so much for offering to help


Oh! and can you please post again the v3.3 firmware for the c510 ?

Mio C510

Edited by - Foxer on 24 août 2009 23:28:06
Go to Top of Page

Foxer

Romania
17 Posts

Posted - 25 août 2009 :  01:57:41  Show Profile  Reply with Quote
I upgraded to the new firmware. But now, when i start miomap, it says "Hardware ID Changed", and then the license error, and then it exits.
And also, by doing this i realised that if i upgrade the firmware, i WON'T automaticly have miov3.3 .. (stupid gulable me..)

Mio C510

Edited by - Foxer on 25 août 2009 01:58:24
Go to Top of Page

g_alin

USA
817 Posts

Posted - 25 août 2009 :  02:15:41  Show Profile  Reply with Quote
Foxer,
give me some time and I will extract the winceimg. But why the file is 160M? Don't tel me that you gave me also the My Flash Disk.img!?

LE: Done. check first page. Your ROM is R33F. Let me know if it works.

Edited by - g_alin on 25 août 2009 04:33:18
Go to Top of Page

sken79

1 Posts

Posted - 25 août 2009 :  14:11:45  Show Profile  Reply with Quote
Dear g_alin, dear all,
I'm luca and I'm the owner of a mio C250 bought in Italy. My original PNA was equipped with r09 firmware, for west european model I guess, So, I would say that my PNA was a mio c250 WEU. I applied g_alin cure last July and my PNA has been R03-firmwared for EEU.
I've not experienced any major flaws so far and I'm running Igo 8.3 without any trouble.
Unfortunately I did not backup my firmware, otherwise I would share it to the forum community.
Actually, I know that exist different versions of firmware for C250 WEU (r09,r11,r17...): does someone know what is the newer firmware among the WEU r09/11/17 and EEU r03?
If someone in this forum has a newer c250 WEU, please could he/she post the firmware so that I can try to bring my C250 back to Western countries with a better firmware than r09.

Thanks!

Luca

ps: thanks to g_alin for his effort!
Go to Top of Page

Foxer

Romania
17 Posts

Posted - 25 août 2009 :  22:32:30  Show Profile  Reply with Quote
quote:
Originally posted by g_alin

Foxer,
give me some time and I will extract the winceimg. But why the file is 160M? Don't tel me that you gave me also the My Flash Disk.img!?

LE: Done. check first page. Your ROM is R33F. Let me know if it works.



Hey, thanks!
For now i'm planing to tinker a little more with miomap while using this firmware.
A few major changes are these:
- my saved v3.1 miomap doesn't work anymore; it says "Hardware ID Changed" and it exits.
- The "Contacts" icon in the Mio startup screen, is no more.
- The GPS connection seems (i'm not sure) to be a little weaker than before.

..for now i'm still trying to get any damn version to work.. The good versions i have (meaning 3.1 and 3.3) don't have a good C r 4 c k ; and the only good -ahem- "patch" i have is for v3.2 (which i don't have).
I've been pulling my hair for almost 2 days now, with DATA.zip
Nobody seems to have a good, cleen/unmodified, working 3.3version. Only the QuickSilver one, which (from my point of view) is awful to work with while you're driving.. + it moves horible compairing to the normal un-modded version



I'm planing in the near future to switch back to the previous ROM, even if it's just for a short while. But i really wish i could get miomap working, first.

Mio C510

Edited by - Foxer on 25 août 2009 22:33:25
Go to Top of Page

g_alin

USA
817 Posts

Posted - 26 août 2009 :  03:45:50  Show Profile  Reply with Quote
grosales,
Download:
C320_NA http://www.gpspassion.com/upload2/C320_NA_ROM_R40.3.9904.0720.zip
from that package copy files: winceimg.bin and winceimg.cks to an empty SDCard (in root of the SDCard ... not in a folder)
You should keep the SDCard with UPGRADE (the one that you used to activate UPGRADE screen - blue screen) ... you'll needed it later to disable the UPGRADE screen. Use another SDCard for winceimg.bin.
Enter in UPGRADE screen and use:
FIRST SCREEN Choose -> 0 = WinCE Upgrade
SECOND SCREEN choose -> 1 = WinCE by SD/MMC
and wait ...
After you receive the message to restart your device ... wait for another 1 minute,, remove the SDCard from GPS and do a hardware reset (power button pressed for 12 seconds until shutdown ... and press again 12 seconds for power up).
Connect GPS to PC and copy all navigation software to Mio Device drive.
Disconnect the GPS and check if the navigation software works.
After you are sure that is working (use it for couple days), insert the SDCard with software that activate/deactivate UPGRADE screen. After application starts press NormalUser button. Hardware Reset your GPS ... to test if you deactivate the UPGRADE screen.
Let me know if you succeed.
Go to Top of Page
Page: of 167 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,09 seconds. Powered By: Snitz Forums 2000 Version 3.4.05