Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2175




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 "All in One" Navigation Systems
 [TOPIC] Sanyo NVM-4370 General Discussion
 New Topic  Reply/Répondre
 Printer Friendly
Next Page
Author Previous Topic Topic Next Topic
Page: of 15

KhaKev

385 Posts

Posted - 01 mai 2009 :  04:08:01  Show Profile  Visit KhaKev's Homepage  Reply with Quote
TOPIC - SANYO NVM-4370



Product page on the Sanyo site : >> LINK <<

Features:

Mobile Navigator v1.00.00.03 with NAVTEQ onboard
Music Player (MP3,WMA, WAV)
Photo Viewer (JPEG)
Video Player (MPEG4/H.264, but cannot play all)
BlueTooth for hands-free phone calls
FM Transmitter
Video Input
Audio Output (3.5mm jack)

Specifications:

OS: Windows CE 5.00.0
MEM: ~60 MB RAM
CPU: ARM920T S3C2443 (400 MHz)
VGA: 480x272 pixels, 4.3"
COLOR: 65536 colors
USB 2.0 (mini)
4GB Internal Flash Drive
SDHC: upto 32GB

Communication Settings:

COM1 - S2443 GPS COM1 (SiRFstarIII)
Baud: 38400
COM3 - TMC COM3
Baud: 38400
COM5: S2443 BT COM5
Baud: 38400
COM9: S2443 DVBT COM9
Baud: 38400

Storage Names:

\MyFlashDisk - (Sanyo maps live here)
\ShellDisk - (Sanyo software lives here, make copy of it and store in safe location)
\SDMMC - (MioPocket software if SD AutoRun method is chosen)

Advanced Storage Info:

ROM (WinCE)
SMFlash Samsung Flash:
Capacity: 100 MB
Sector Size: 512 B

ShellDisk
DSK1: NAND MLC Drive
Capacity: 96 MB
Sector Size: 2.00 KB

MyFlashDisk
DSK2: PocketMory MLC Disk
Capacity: 3.53 GB
Sector Size: 2.00 KB

DSK3 is your SD/MMC Card

Device AutoRun Options:

\SDMMC\AutoRun.inf - (specify the path of the file to execute plus a checksum at the end of the file)
\MyFlaskDisk\AutoRun_USB.inf - (same as above)

MioPocket SD AutoRun Setup:

1. Download latest MioPocket 3.0 Release (see link below, note: Sanyo_AutoRun.inf is bundled starting MP 2.0 R45)
2. Extract MioPocket_3.0_Release_##.zip on a PC
3. In "MioPocket 3.0 Release ##" folder, rename Sanyo_AutoRun.inf to AutoRun.inf
4. Copy needed MioAutoRun files and folders to root of SD card as shown below
Note: SDMMC is not a folder name. It represents a disk name in Sanyo.

SD File Structure should look like this:

\SDMMC\MioAutoRun
\SDMMC\Media
\SDMMC\AutoRun.inf
\SDMMC\MioAutoRun.exe
\SDMMC\MioAutoRun.mscr
\SDMMC\MortScript.exe

5. Power on Sanyo device and insert SD card
6. Wait for the MioPocket install to complete and have fun with the new interfaces and features!

FAQ AND LINKS

SD Autorun is supported from MioPocket 2.0 R45
Refer to http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=109690&whichpage=386

Latest MioPocket 3.0 Release
http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=126303

Latest MioPocket 2.0 Release
http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=109690&whichpage=1

OSD Volume Indicator (should be ported in R46)
http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=123189&whichpage=9

Other Sanyo and MioPocket Install Help
http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=123189&whichpage=1

ShellDisk software in case yours is corrupted
http://www.megaupload.com/?d=FMXUH1DR

No warning message on startup
http://rapidshare.com/files/234648852/Sanyo_NVM-4370_Warn.exe_no_warning.zip

New AutoRun_USB.inf for SDFree install (it calls \MyShellDisk\MioAutoRun.exe)
http://rapidshare.com/files/228547203/AutoRun_USB.inf

Video on YouTube
http://www.youtube.com/watch?v=m0Z8AydT2kY

This post is subject to change without notice.
We're not responsible for any misuse of the procedures. Use it as your own risk.

Edited by - KhaKev on 28 juil. 2009 10:38:03

Ads


TroNik

362 Posts

Posted - 01 mai 2009 :  09:45:02  Show Profile  Reply with Quote
KhaKev,
I was going to suggest you to collect all interesting posts here but you already did it. Nice.

http://iphonetoday.googlecode.com/
Go to Top of Page

Sam Ontario

USA
169 Posts

Posted - 01 mai 2009 :  09:47:13  Show Profile  Reply with Quote
4GB internal flash drive as well.

Sam
Magellan Maestro 3140, Sanyo NVM-4370, Mio C310x
Go to Top of Page

KhaKev

385 Posts

Posted - 01 mai 2009 :  11:25:50  Show Profile  Visit KhaKev's Homepage  Reply with Quote
Added. Thanks Sam Ontario.
Go to Top of Page

gpspassion

93896 Posts

Posted - 01 mai 2009 :  11:34:54  Show Profile  Visit gpspassion's Homepage  Reply with Quote
Good idea to start this topic, I did some formatting in the first message and added a picture and link to the Sanyo site.

Also, not that it really matters but its software looks really close to the one now used by Sony doesn't it : http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=107391 !

Discounts and Assistance/Réductions et Assistance (Club GpsPasSion) / Où commencer?
Go to Top of Page

KhaKev

385 Posts

Posted - 02 mai 2009 :  04:10:59  Show Profile  Visit KhaKev's Homepage  Reply with Quote
Thanks gpspassion. It looks neaty now. You're right about the Sony's. The map software looks identical. It has to be MobileNavigator. Oh well, what's good when there is no map updates. The Sanyo beats on features and price and very hackable. No more sending back to Tech Support even ShellDisk is corrupted. Kudos to TroNik.
Go to Top of Page

nashi2000

8 Posts

Posted - 02 mai 2009 :  07:51:53  Show Profile  Reply with Quote
Hey I want to add that I tested my Sanyo 4370 with a 32GB SDHC and it worked just fine. I currenlty have a 16GB. The 32GB is still expensive about $80 (returning it) You can get the 16GB for $30.

Tronik, in other posts you explain well Sanyo design with with ShellDisk and Flashdisk. It would be nice to put that link on top here. It may be something people are not paying attention to. I have had two other 4370 ShellDisk becomming corrupt. In the first one I Icons disspeared somehow. In the second one I could not get pass couple dialog box errror on start up. "BTGUI not a valid CE app". There's not a way to get the USB port active since I can not even get to the initial screen. Unfortunately as you well explained you can not do a restore if ShellDisk is corrupt. So, if I got it right, now I can on my third unit if this happens again as long I make sure I include the couples files you provided. Is this correct? If yes I hope all who own a 4370 will follow up your suggestion and that's why we may need to put that post above.

Thanks,
Nashi2000
Go to Top of Page

KhaKev

385 Posts

Posted - 02 mai 2009 :  09:36:42  Show Profile  Visit KhaKev's Homepage  Reply with Quote
nashi2000,
The link you're refering to is already on the top. TroNik explained it well - "Now if ShellDisk becomes corrupted then the device can still be restored." So all you need is boot MioPocket from SD. After this you can restore ShellDisk with your own copy or the one I posted above.

I'm thinking of another solution just for the restore of ShellDisk.
We can use MortScript to automate the delete/copy of ShellDisk.

If ShellDisk is totally toasted we can use Storage Manager in Control Panel to format it but you have to be very careful with this task when selecting the partition.

Go to Top of Page

nashi2000

8 Posts

Posted - 02 mai 2009 :  23:00:59  Show Profile  Reply with Quote
Thanks Khakev for the link. I did not notice you had the link: but I went thru the important Tronik post is burried down and unless one reads the all thread he may not know of the need to include the file AUTORUN_USB.INF on MyflashDisk. I believe this not currently being done by the R45 SD install. Can we include that step in the SD install installation steps or at least isolate that post here. Don't think people are paying attention to this.

Thanks!

Edited by - nashi2000 on 02 mai 2009 23:23:55
Go to Top of Page

KhaKev

385 Posts

Posted - 02 mai 2009 :  23:56:49  Show Profile  Visit KhaKev's Homepage  Reply with Quote
nashi2000,
So here's how it works, the unit has a ROM (Read Only Memory). ROM is where the Windows CE lives and Windows\CeLauncher.exe is part of it.
At startup CeLauncher.exe calls PnaShell.exe (Sanyo Main Menu), \MyFlashDisk\AUTORUN_USB.INF and \SDMMC\AUTORUN.INF.
Think of this way, the unit has 3 partitions\disks: ROM, ShellDisk, MyFlashDisk.

So if ShellDisk is toasted the device can boot to the Sanyo splash screen and you should also hear a startup chime. Meaning Windows CE desktop is there but we cannot get to it because of the splash screen. The reason is because PnaShell.exe could not startup. That's why you need the \SDMMC\AUTORUN.INF as a back door.

The AUTORUN.INF that comes with MioPocket 2.0 R45 and higher is configured specifically for MioAutoRun.exe checksum. You can create your own AUTORUN.INF to call other executable program. In this file you need to specify the path of the file to execute plus a checksum at the end of the file as TroNik discovered.

You don't need AUTORUN_USB.INF in \MyFlashDisk for the SD autorun to work. I found a little problem with it. Refer to http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=123189&whichpage=9

I added the SD AutoRun setup guide to the first post.

Hope this helps.

Edited by - KhaKev on 03 mai 2009 02:07:05
Go to Top of Page

nashi2000

8 Posts

Posted - 03 mai 2009 :  06:05:12  Show Profile  Reply with Quote
Thanks a lot Khakev. Now I got it. I still have my second toasted unit. I tried to pop in the my SD card containing MP from my third unit install, but was not able to boot thru MP. Anyway to do this? I understand this is different since this unit never went thru a MP install before. Is there a way to fix this? There's first error dialog box "Contact is not a valid CE Application" I click OK then I get a second one "Btgui is not a valid CE Application". Once I clik ok on this it does not go away it statys on top. Then I would hear the startup chime which means CE is behind the splashscreen but the error box is still on top. Now I tried to pop out and pop in again MP SD card with the hope that CE will detect it but no luck. Anyother way to force CE to launch MIO install here?

Thanks,
Nashi2000

Thanks!

Edited by - nashi2000 on 03 mai 2009 06:05:50
Go to Top of Page

KhaKev

385 Posts

Posted - 03 mai 2009 :  08:03:16  Show Profile  Visit KhaKev's Homepage  Reply with Quote
nashi2000,
First you need a good copy of ShellDisk on your SD card. Try with a fresh MP install. Meaning copy needed files/folders from the original MP extracted folder over to SD. It should work.

Alternatively, you can configure a new AUTORUN.INF to call SoftButton.exe. You need to know SoftButton checksum for it to work.
Insert SD, SoftButton should startup. From SoftButton menu kill PnaShell and other Sanyo procceses. Then run CECMD.exe and try to restore ShellDisk.

Edited by - KhaKev on 03 mai 2009 08:08:42
Go to Top of Page

nashi2000

8 Posts

Posted - 03 mai 2009 :  12:01:17  Show Profile  Reply with Quote
Khakev,

Followed your first suggetion and still no luck at all. CE is not launching autorun.inf! When I pop in and out the SD, I can not hear a sound notifying it's been recognized. Power button, which works on my third unit to kick in the the SD install, is not doing anything. It's as if these two errors are freezing the unit. Only option is hard reset which take you back into the same situation over and over. Has anyone ever tested a severe ShellDisk corruption preventing pnashell booting and was successfull booting thru MP?

I did not try your second suggestion. Don't know the checksum for the softbutton.exe: not sure it will work since the buttons seem unresponsive here and the SD Card is not being recognized by WCE at all.

Tronik, any suggestions on this one?

I will return this unit and get a new one since I had bought the replacement contract from Frys. Or I can send it in to Sanyo(costing me shipping). However Frys does not have it anymore and will ask me to choose a different brand. Any other brand you guys can suggest which would be close to Sanyo features and still compatible with MP? Or at least come close to Sanyo features after MP installed on it brings in extra features?

By the way, I found out Walmart.com is selling the previous model Sanyo 4070 for $94. I had owned that before I decided to replace it with 4073. It also was a very good. More solid, but heavier, longer battery life,stronger FM transmitter, louder audio volume but no camera input, incorporated Traffic antena but (nothing extra to buy), included Homer Charger and car charger, Video would not play H264 but would play xvid. However it has smaller flash memory 2G and I did not like the navigation map(display too small), could not find an adress in Atlanta I was travelling to, would route me thru Memphis,TN for going to Atlanta from Dallas while both mapquest and 4370 were routing me thru Shreevport, La
But It has a pedestrian mode, can search the POI by name, can save trips, can give you detailed routing for the all trip at start(4370 gives you detailed routing for the first few miles, and more details as you travel)....
Now here's the question: anybody ever successfully installed MP on 4070? How did it work? I think 4070 has very similar file structure as 4050. Please let me know If what you guys think of it running MP.

Thanks again!
Nash2000

Edited by - nashi2000 on 03 mai 2009 12:04:18
Go to Top of Page

KhaKev

385 Posts

Posted - 04 mai 2009 :  00:22:34  Show Profile  Visit KhaKev's Homepage  Reply with Quote
nashi2000,

Sorry to hear it's still not working. Looks like those apps freeze the unit. I will look into this further to see if we can by pass it. I know \MyFlashDisk\AutoRun_USB.inf gets triggered first but you couldn't even connect the unit to a PC so it does not help.

Check out http://piiis.blogspot.com/2008/06/notes-on-my-sanyo-nvm-4050.html for some info on NVM-4050. I suggest you bring your MP SD autorun to a store and pop it in and find out.

Edited by - KhaKev on 04 mai 2009 00:24:18
Go to Top of Page

Sam Ontario

USA
169 Posts

Posted - 06 mai 2009 :  02:32:47  Show Profile  Reply with Quote
My friend has a NVM-4050 asked me to hack it for him after seeing what MP2 can do on my 4370. It was a bit of scary to install MP2 on this 4050 when it black out after installation trying to reboot. trying to turn off, no go. Popped the SD card out and in still no go. Saw my friend's face darkened! Eventually pressing the on/off button together with the reset, it brought back the original software. What a relief! At that time, I did not give up since, it can be revived. I vaguely remembered in the last try after failing reboot, I took out the SD card, then pressed the on/off and pushed the reset together, it worked and booted to MP2!

Sam
Magellan Maestro 3140, Sanyo NVM-4370, Mio C310x
Go to Top of Page

star

4 Posts

Posted - 07 mai 2009 :  03:18:31  Show Profile  Reply with Quote
My Sanyo 4370 hangs on Sanyo logo screen, showed fatal error with contact.exe, cannot boot, cannot connect to PC, anyone knows how to reset it so that it can pass the start screen?
Go to Top of Page
Page: of 15 Previous Topic Topic Next Topic  
Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,08 seconds. Powered By: Snitz Forums 2000 Version 3.4.05