Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2169




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 "All in One" Navigation Systems
 Sanyo 4370 and Mio pocket install help
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 24

desimtor

92 Posts

Posted - 20 oct. 2009 :  00:46:52  Show Profile  Reply with Quote
KhaKev,

Here are the SMFlash and DSK1 images made with DiskRW, I'm still trying to make ActiveSync work on my Sanyo unit with MP.

http://rapidshare.com/files/295250784/Sanyo-DiskRW_files.7z

Just as a history my Sanyo unit has the failed bitmap error and both MyFlashDisk and ShellDisk seem to be corrupted = any attempt to write in any of these areas will freeze the unit, this is why I modified the MP installation script to run without accessing anything on the internal flash memory hence some limitations like ActiveSync (I think)

Hope it helps get you started.

Cheers.
Go to Top of Page

KhaKev

385 Posts

Posted - 21 oct. 2009 :  11:20:07  Show Profile  Visit KhaKev's Homepage  Reply with Quote
Thanks desimtor. The image size is close to 100 MB each. It does not seem right but I will take a look.
Go to Top of Page

don2

USA
86 Posts

Posted - 22 oct. 2009 :  03:21:49  Show Profile  Reply with Quote
KhaKev,

1.I am not experienced with ActiveSync. I understand the concept but not sure where I invoke it on the PC or on the Miopocket or both. I see a directory in MioPocket under settings called USB mode. In side this folder I have ActiveSync(Active) and Mass Storage is I guess not active. Those are the only two choices. I can not see anywhere else in MioPocket to start active sync.

2. I am running Miopocket off a external card.

3. I do not see any app in WIndows XP on my laptop for starting ActiveSync.

4. In regards to pdocread . I downloaded all the files to c:\itsutils folder and unzipped them.

5. I then found that I can not run C:\itsutils>pdocread.exe -l
6. When I tried running it thru Start -> run -> cmd.exe I got missing rapi.dll
7. I then observed that I needed a command called "make" - (to build: type 'make' in the itsutils directory, it will then build 'src', 'dll', apihook, rilhook, some stuff from 'leds' )
8. I downloaded "Make" and tried running it from command line and got missing cygwinl.dll.
9. It appears we need someone that has the following on their computer: (to compile it you need visual studio 2005, with the windows mobile 6 SDK. and also header files from the wince3, wince4 and wince5 platformbuilders. and cygwin, with probably at least these packages installed: bash, perl, make. )
10. Not having done development work in a long time, I hope someone else out there with more experience with Visual Studio can run the needed command.

Sorry ,

Don
Go to Top of Page

KhaKev

385 Posts

Posted - 22 oct. 2009 :  12:46:48  Show Profile  Visit KhaKev's Homepage  Reply with Quote
don2,

Thanks for trying. ActiveSync is enabled by default in MP. You need to download ActiveSync from MS and install on your XP. Once the device is connected to a PC, ActiveSync will automatically detect it and connect. Note the green icon in your task bar (the icons tray).

After the connection is established you can run the commands again. Thanks
Go to Top of Page

don2

USA
86 Posts

Posted - 23 oct. 2009 :  14:51:27  Show Profile  Reply with Quote
KhaKev,

There appears to be two versions of Active Sync:

1. For Windows Mobile 6, ActiveSync 4.5 is required

2. Windows Mobile 6 or 6.1 requires an upgrade to Windows Mobile Device Center 6.1

Which would you suggest.

Don

Edited by - don2 on 25 oct. 2009 15:17:45
Go to Top of Page

desimtor

92 Posts

Posted - 23 oct. 2009 :  16:56:49  Show Profile  Reply with Quote
Don2,

I use this http://www.microsoft.com/windowsmobile/en-us/downloads/eulas/eula_activesync45.mspx?ProductID=76 for my XP machine it works with MP3.0 no problem on my other GPS (Asus R300).

Cheers.

Go to Top of Page

don2

USA
86 Posts

Posted - 23 oct. 2009 :  19:56:12  Show Profile  Reply with Quote
desimtor, That appears to be the one I installed. When I attempted to do the sync it would say device not found and USB error.

However I could see the device thru file manager so I do the USB was working.

Do I have to turn on ActiveSync on the Miopocket somehow? Khakev made me think it was always on.

-Don
Go to Top of Page

KhaKev

385 Posts

Posted - 23 oct. 2009 :  20:31:00  Show Profile  Visit KhaKev's Homepage  Reply with Quote
don2,

Double check USB/ActiveSync under Settings page and ensure ActiveSync mode is active. If not select it and press OK. You might need to perform a soft reset for ActiveSync mode to take affect. Hope this helps.

desimtor,

Attempted to dumprom SMFlash image created by DiskRW for verification but was not successful. Only 6 files were dumped. The file size does not seem to be correct.

I hope pdocread will grab the correct size.
Go to Top of Page

don2

USA
86 Posts

Posted - 23 oct. 2009 :  21:04:02  Show Profile  Reply with Quote
desimtor, I installed the one you suggested and it was not seen until I did the soft reset as KhahKev suggested. So thanks !

KhahKev, You may find this interesting. I now have the GPS connected with ActiveSync on the same computer you were helping me with a few post back on the other gpspassion Sanyo forum that would not see my replacement GPS thru the USB port. Must be ActiveSync reset something that all other USB fixes did not fix.

-Don

Well learned one thing Google Chrome does not show the Edit command in gpsfashion, I had to open up IE to get edit capability.

KhahKev,

Here is a hand typed copy of what I got back running C:\itsutils>pdocread.exe -l

Error: CeProcessConfig – r=00000000 ce=00000000 le=00000000 hr=80004005
- Unspecified error
Error: CeProcessConfig – r=00000000 ce=00000000 le=00002746 hr=80072746
- An existing connection was forcibly closed bu the remote host.

rapi reinitializing
Error: CeProcessConfig – r=00000000 ce=00000000 le=00000000 hr=80004005
- Unspecified error

Error: CeProcessConfig – r=00000000 ce=00000000 le=00002746 hr=80072746
- An existing connection was forcibly closed bu the remote host.

rapi reinitializing
Error: CeProcessConfig – r=00000000 ce=00000000 le=00000000 hr=80004005
- Unspecified error
ERROR loading itsutils.dll – probably denied by policy restriction

I do not know how to copy from cmd window so typed above by hand if you see any typos.

-Don

Edited by - don2 on 23 oct. 2009 22:01:03
Go to Top of Page

desimtor

92 Posts

Posted - 23 oct. 2009 :  22:21:57  Show Profile  Reply with Quote
Don2,

I know KhaKev wanted both pdocread and DiskRW dumps, since my DiskRW dump doesn't seem to be right can you try it on your unit?

Thank you.

Go to Top of Page

don2

USA
86 Posts

Posted - 23 oct. 2009 :  22:49:09  Show Profile  Reply with Quote
desimtor,

I will see if I can figure out DiskRW. I am holding my breath that trying these dumps does not brick my second GPS. I feel like a bull in a China Shop.

-Don
Go to Top of Page

KhaKev

385 Posts

Posted - 23 oct. 2009 :  23:20:57  Show Profile  Visit KhaKev's Homepage  Reply with Quote
don2,

Glad to hear the UBS connection is working again on the same PC. As for the above errors I suspect that a firewall or anti virus software might be blocking it. If possible please temporary disable both and try again.

To copy text from Command Prompt window, right click on Command Prompt title bar -> Properties -> tick QuickEdit Mode then click OK. Select (Modify shortcut that started this window) and click OK again. Now you can freely high light text and copy.

DiskRW will not harm the device as we only need to read the ROM. Don't attempt to run anything else beside Read as instructed. Make sure you have sufficient space on your SD card when you specify the destination where the image to be written to.

Let us know if you have any questions. Thanks.

desimtor,

Have you tried ActiveSync connection with your device again? Any lucks?
Go to Top of Page

desimtor

92 Posts

Posted - 24 oct. 2009 :  01:13:14  Show Profile  Reply with Quote
KhaKev,

The problem I have with my unit is that soft reset will not work so I can switch from Mass Storage to ActiveSync.
If I try to soft reset the unit will get stuck at the Sanyo screen.

Looks like not too much help from my side, but I sure like to test any of your ideas.

Don, thanks for your efforts, I do hope you don't brick your unit ;)
Go to Top of Page

don2

USA
86 Posts

Posted - 24 oct. 2009 :  15:58:50  Show Profile  Reply with Quote
I did something in MioPocket that has disabled the Taskmanager at lower right of Main screen and also I can not click on keyboard Icon in lower right of the screen - when I do nothing happens.

ALso when I open apps the X in upper right or any other means to close the app is missing and I can not get out of it without using the slide switch.(Which I do not want to do)

Before this all happened I had tried a few apps that threw errors one of which was JB Piano.

Thankfully OEM apps appear to still be working when I remove the SD mem card.

Also Standby Hibernate does not shut down the Mio Pocket like it did previously instead it says waiting for SD card to initialize and then just comes back to the Mio pocket screen.

Thanks in advance for any help.
-Don
Go to Top of Page

desimtor

92 Posts

Posted - 24 oct. 2009 :  20:17:31  Show Profile  Reply with Quote
My recommendation would be to just re-install MP - this solves the problems most of the time.

I also added a small video here on how I did the DiskRW SMFlash and DSK1 dump.
http://rapidshare.com/files/297365858/Sanyo_DiskRW_0001.wmv
the whole process takes about 2 minutes for each.

Cheers.
Go to Top of Page
Page: of 24 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 0,75 seconds. Powered By: Snitz Forums 2000 Version 3.4.05