Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2173




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Garmin Advanced Navigation Systems
 Run a Garmin Gps under Linux
 New Topic  Reply/Répondre
 Printer Friendly
Next Page
Author Previous Topic Topic Next Topic
Page: of 2

fep1343

49 Posts

Posted - 10 janv. 2009 :  16:00:31  Show Profile  Reply with Quote
UPDATED: Here is how to run a Garmin Gps device under Ubuntu Linux:

1-Install the following open source programs via Synaptic:
- GPSBabel:converts waypoints, tracks, and routes between popular GPS, generate
custom POIs files(.gpi)
- Gpsd: receives data from a GPS divice for real time navigation
- Gebabbel: A graphical user interface for gpsbabel


2- to access the USB GPS device as "USB:" for the first time and to have the system automatically detect the Gps USB device afterwards, open up a terminal and copy/paste this command:

sudo gedit /etc/udev/rules.d/51-garmin.rules

and add this content:

SYSFS{idVendor}=="091e", SYSFS{idProduct}=="0003", MODE="666"

save and restart.

3- Google earth under ubuntu Linux.
- Installation: open up a terminal & paste this:
wget http://dl.google.com/earth/client/current/GoogleEarthLinux.bin && sh GoogleEarthLinux.bin && rm GoogleEarthLinux.bin

and follow instructions.

4- QLandkarte GT is a GeoTiff viewer for the PC. Next to displaying maps it is able to visualize data acquired by a GPS on the map. With QLandkarte GT you are able to produce smaller map subsets (gmapsupp.img) to send & be used by GPS device.

Here are some key features of "QLandkarte GT":

Maps:

· Import collection of GeoTiff files
· Convert raw bitmaps into GeoTiff
· Export sub-area from GeoTiff
· Zooming / moving
· Relief shading
. 3D map
. Create a customized map

Waypoints:

· Create waypoint
· Edit waypoint
· Delete waypoint
· Move waypoint
. Download from or upload to GPS device
· Save / load wayoints as GPX
· Save / Load waypoints as QLandkarte binary

Tracks:

· Show tracks on map
· Purge / delete trackpoints
· Edit track properties
. Download from or upload to GPS device
· Save / load tracks as GPX
· Save / load tracks as QLandkarte binary

Routes:
. Download from or upload to GPS device
. real time navigation

Installation via synaptics since Ubuntu 10.04 lucid:
- QLandkarte GT
- qlandkartegt-garmin: plugins for QLandkarteGT to talk to Garmin GPS devices
NB: to install the last version (works like a charm), remove qlandkartegt & garmin driver via synaptic, download & install the latest version of them here:

https://launchpad.net/~mms-prodeia/+archive/ppa/+packages

NB: If you need a map (mapsource) for cycling, Mountain biking or Hiking with autorouting, you can install it in qlandkartegt by using these links (download a free map then import .tdb and osmmap*.img to qlandkartegt) & then send maps to Garmin gps device.

http://www.velomap.org/download/

http://openmtbmap.org/download/

More maps around the world:
http://downloads.cloudmade.com/










5- Viking: free program to import and plot tracks and waypoints, show openstreet
maps under it, download geocaches for an area on the map,make new tracks and
waypoints, see real-time GPS position, get route from googlemap & send it to GPS,
etc. Installation via synaptic.










6-TangoGps: real time navigation on a desktop by using map data from the Openstreetmap project or Googlemap(not allowed by Google), gets route & directions for real navigation, shows track & photo map, etc .

NB: for real time navigation with tangogps, upload garmin_gps driver. In a terminal:
sudo /sbin/modprobe garmin_gps






for more information:
http://www.tangogps.org/gps/cat/About

7-Garmin Communicator Plugin for Linuxin Ubuntu Lucid to transfer Geocaches from Geocaching.com, or to upload fitness data to websites etc
*Install Garmin Communicator Plugin for Linux, open a terminal:

sudo add-apt-repository ppa:andreas-diesner/garminplugin
sudo apt-get update
sudo apt-get install garminplugin


*Download & add "User Agent Switcher" Plugin to Firefox
https://addons.mozilla.org/de/firefox/addon/59/

*Configure "User Agent Switcher":
save this page as XML file in your computer:(right click, save link as)
http://www.andreas-diesner.de/garminplugin/useragentswitcher.xml
then in firefox go to Tools menu-->Default user agent-->User agent switcher-->option-->Import saved xml file.

*To connect Garmin gps (forerunner 305 tested) & upload directly workout data to Garmin Connect for example (or other sites):
go to http://connect.garmin.com/ & sign in.
then in firefox go to Tools menu--> Default user agent-->GarminPluginFake-->Firefox(winXp)



for more information:
http://www.andreas-diesner.de/garminplugin/

Edited by - fep1343 on 18 déc. 2010 16:51:40

Ads


gpspassion

93894 Posts

Posted - 20 janv. 2009 :  02:08:51  Show Profile  Visit gpspassion's Homepage  Reply with Quote
Thanks for sharing news item posted on the portal http://www.gpspassion.com/fr/news.asp?id=448 ;-)

Discounts and Assistance/Réductions et Assistance (Club GpsPasSion) / Où commencer?
Go to Top of Page

hansole

Denmark
2 Posts

Posted - 10 févr. 2009 :  13:52:36  Show Profile  Reply with Quote
Concerning fep 1343: How to run a Garmin under Ubuntu

- I am a rather new Ubuntu user - Ubuntu 8.10
I am about to - I think -to have solved som of my major problems
with the change in system.
-However, being a keen motionist (running, trecking and cycling) I most sincerely would like, if my Garmin 305 worked in the Ubuntu world -
If possible with same easyness, as it did in Windows

I have therefore several times tried to install the three programmes
GPSBabel -Gpsd - Viking etc as mentioned

- In so far without result - other than hours spent on the subject.

As i get the Pop-up message:

Status:detecting gpsbabel
GPS equipment: Forerunner305 Software Version 2.80

- it looks like my Garmin is detected -correctly
but nothing happens

I may add, that I have succedded in getting maps downloaded showing Denmark and my home area - insofar without my tracks

Any suppestions about my wrong doing, or does it simply not work with
Garmin 305

Hans Joergensen - Denmark

hans j
Go to Top of Page

hansole

Denmark
2 Posts

Posted - 10 févr. 2009 :  17:01:35  Show Profile  Reply with Quote
I am a New Ubuntu user
For some monthe have I tried to solve the problems - going from a windows world to Ubuntu

I would like to be able to download data from my Garmin305
- if possible as easy as in windows

I have carefully installed the three programmes;
GPSBabel -GPsd - Viking

I have altered in the /etc/modprobe.d/blacklist
- and i should be working - I have gone through the procedure again
-and again once more - no result

When I try downloading data from Garmin305
I get the Pop-up message:
Statue: detecting gpsbabel
GPS equipment:Forerunner305 Software Version 2.80

- I therefore conclude, that there is connection from the Garmin 305
to the Ubuntu system
- that is not enough

Any suggestions what I do wrong ? - or is it simplely not working with
the Garmin 305 ?

I must say, that I have been able to download maps covering Denmark
and my home area -but to my despair untill now without my running
tracks

kind regards from

hans joergensen
Denmark

hans j
Go to Top of Page

HankB

USA
53 Posts

Posted - 30 mars 2009 :  02:47:14  Show Profile  Reply with Quote
Thanks for looking onto this information. I wasn't aware of Viking and will have to look into it.

I thought I'd add another tidbit that I found today. It pertains to Linux because I can only run MapSource on Linux in a VM and I am lately jonesing for a netbook. My present laptop - easily capable of running Windows in a VM - does not so easily fit in my motorcycle side case. ;)

It turns out that there is a shortcut at http://www.elsewhere.org/journal/gmaptogpx/ that can be used to convert a route created on Google Maps to GPX format. I can then use GPSbabel to send this to my 2720 or just copy the file to the right place in wife's Zumo 450.

I don't know how useful this outside the US, and it does require an Internet connection, but it dose provide a way to create routes and get them into the GPS w/out the need of Windows and Mapsource.
Go to Top of Page

fep1343

49 Posts

Posted - 30 mars 2009 :  20:46:56  Show Profile  Reply with Quote
Hi
Here is another website to create a route on Google Maps in GPX format & vice versa.
http://www.marengo-ltd.com/map/

Viking is great. There is also another developing free program "QLandkarte GT" under Linux that is the ultimate outdoor aficionado's tool. It supports all of features of Mapsource, Google map, GPS maps in GeoTiff format as well as Garmin's img vector map format.For more information:

http://www.qlandkarte.org/index.php?option=com_content&view=article&id=9&Itemid=10

http://www.qlandkarte.org/index.php?option=com_content&view=article&id=11&Itemid=12

Edited by - fep1343 on 30 mars 2009 20:53:38
Go to Top of Page

fep1343

49 Posts

Posted - 04 avr. 2009 :  22:31:43  Show Profile  Reply with Quote
Hi
I tested a Garmin forerunner 305 under Linux & it works fine.To know how to run a forerunner 305 under Linux see this post:

http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=124627

Go to Top of Page

fep1343

49 Posts

Posted - 25 avr. 2009 :  15:44:02  Show Profile  Reply with Quote
Hi
I use "usb:" in Ubuntu Linux to talk to my Garmin devices & this works fine. I dont use any serial port. But what to do if you want to run an old application like "gpsd" that supports only a serial port. To create a serial port as "dev/ttyUSB0" you must load manually an old garmin_gps driver by executing the following script. Open a text editor and add:
#!/bin/sh
sudo /sbin/modprobe garmin_gps

Save as anyname.sh -> right click -> properties -> permissions -> Allow executing file as program and close. Double click on the "anyname.sh" and select "run in terminal". Now the application can talk to gps via a serial port.

To unload manually the garmin_gps driver, execute this script as above:
#!/bin/sh
sudo /sbin/rmmod garmin_gps

I hope this help Garmin gps users in ubuntu Linux.
Go to Top of Page

CecilHayduke

2 Posts

Posted - 22 juin 2009 :  04:41:08  Show Profile  Reply with Quote
I've followed the instructions on this forum for setting up my Forerunner 305 as dev/ttyUSBO on Ubuntu Jaunty.
dmesg confirms that this has been done:

[ 118.870486] usbcore: registered new interface driver usbserial
[ 118.870508] USB Serial support registered for generic
[ 118.870533] usbcore: registered new interface driver usbserial_generic
[ 118.870536] usbserial: USB Serial Driver core
[ 118.896144] USB Serial support registered for Garmin GPS usb/tty
[ 118.896171] usbcore: registered new interface driver garmin_gps
[ 118.896174] garmin_gps: v0.31:garmin gps driver
[ 152.832047] usb 2-2: new full speed USB device using ohci_hcd and address 3
[ 153.059583] usb 2-2: configuration #1 chosen from 1 choice
[ 153.061734] garmin_gps 2-2:1.0: Garmin GPS usb/tty converter detected
[ 153.061857] usb 2-2: Garmin GPS usb/tty converter now attached to ttyUSB0


However, when I run mytourbook after this, it immediately locks up when I attempt to connect to the device.
Mytourbook runs fine if I do not try to connect.
I do not know the exact error messages because the terminal becomes locked without showing any.
I can connect fine to Gebabbel, gpsbabel, and Sport Turtle without this fix. However, I would really prefer to use mytourbook. Any suggestions?

Go to Top of Page

fep1343

49 Posts

Posted - 22 juin 2009 :  19:54:45  Show Profile  Reply with Quote
Hi CecilHayduke
Concerning Mytourbook, the USB plug must be connected with the computer before the transfer dialog is opened. When the transfer dialog is opened and a serial port is not available, the data transfer can not be performed.
You can also download your gps data by using TCXConverter, a free application, & import it to Mytourbook or any other application supporting tcx format.
Please use the following forum if you have any problem with forerunner 305 under Linux.

http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=124627
Go to Top of Page

CecilHayduke

2 Posts

Posted - 23 juin 2009 :  00:29:36  Show Profile  Reply with Quote
Thanks for the response. I am sorry if I was unclear. I used the forum thread that you cited to get started with my Forerunner 305 and followed all the instructions. I connected the serial port and verified that with dmesg as quoted before I started mytourbook and opened the transfer dialog. Even so, opening the transfer dialog freezes both mytourbook and the terminal. It also takes over the garmin_gps module and does not let me kill it with rmmod.

I am also unable to communicate with my Forerunner using TCXConverter.

I can use all of the command line tools fine. Right now, I am using garmin-sync to dump my .tcx files and then opening them in another application or on Cyclogz.com (which, unlike Garmin Connect allows uploading of .tcx from the browser without a plugin.)

I would prefer to get mytourbook running so that I can use a single app instead of a series of steps or running XP on a virtual machine (yuck).

Thanks again for the response.
Go to Top of Page

fep1343

49 Posts

Posted - 29 août 2009 :  15:47:07  Show Profile  Reply with Quote
Hi CecilHayduke

The garmin_gps module stopped working & is buggy since updating to kernel 2.6.26 or later (ubuntu jaunty). It freezes gpsbabel, mytourbook, the terminal & even the computer. Here is a PATCH may fix the bug (I've not tested):

http://sourceforge.net/tracker/?func=detail&aid=2821531&group_id=115375&atid=671991
Go to Top of Page

fep1343

49 Posts

Posted - 04 mai 2010 :  20:59:08  Show Profile  Reply with Quote
After upgrading to Ubuntu 10.04, garmin_gps driver works fine again & can talk again to Garmin GPS via serial port dev/ttyUSB0.
Go to Top of Page

0d0a

Netherlands
1 Posts

Posted - 06 nov. 2011 :  19:48:30  Show Profile  Visit 0d0a's Homepage  Reply with Quote
Hello all you folks out there!
I have it working too! Forget the garmin_gps driver. No need for it!
It took me a while to figure out that in setup general of Qlandkarte GT you need not only to select your device but your model as well! Stupid me! Now it works like a charm!
Go to Top of Page

pwabrahams

USA
1 Posts

Posted - 01 déc. 2012 :  03:45:21  Show Profile  Reply with Quote
I just got a Nuvi 2405. I can read the device under Ubuntu without any difficulty. But when I try to go to myDashboard online, I get the message that I need to install the Garmin Communicator Plugin, which apparently is available only for Windows/Mac. Is it still possible to use myDashboard under Ubuntu? If so, how can I activate it?

Right now the device just displays the Garmin logo when plugged in, and I don't know how to get it to do anything else.
Go to Top of Page

fep1343

49 Posts

Posted - 01 déc. 2012 :  11:18:26  Show Profile  Reply with Quote
Here is how to install Garmin Communicator Plugin for Linux

http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=124627&whichpage=3
Go to Top of Page
Page: of 2 Previous Topic Topic Next Topic  
Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 0,77 seconds. Powered By: Snitz Forums 2000 Version 3.4.05