Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2250




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Advanced Topics
 Live GPS Tracking Systems
 [TOPIC] Xexun "TK102" Tracker - User Experiences
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 176

bartods

Poland
8 Posts

Posted - 30 nov. 2011 :  14:59:32  Show Profile  Reply with Quote
OK. it's seems that I must do this on computer in my work :P, maybe my cheef do not kill me for that. This machine has ubuntu and the dsl connection.
So I must install PHP, Apache and Mysql.

Go to Top of Page

barbudor

France
1732 Posts

Posted - 30 nov. 2011 :  22:10:59  Show Profile  Visit barbudor's Homepage  Reply with Quote
bartods

You don't need to run the TCP server that will receive connection from the tracker on the same machine than the one running web server and SQL.
In my case, my basic C++ app runs on this home PC but forward the data through HTTP request to a PHP script running on the free home-page server of my ISP.
Of course if you can make an app that directly writes the tracker's data into SQL, that would be good but it was forbidden in my case (SQL server only allows connection from PHP running on same server).


Modérateur Forum Traceurs GPS et Suivi GPS Temps Réel, son Index (français) et Les bons plan SIM pour traceurs GPS
Moderator Forum Live GPS Tracking Systems and its Index (english)
CartoExploreur3D | OziPC+OziCE(iPaq314) | TTGoLive950 | Carminat TomTom Live | Tracker Coban GPS-102
Go to Top of Page

bartods

Poland
8 Posts

Posted - 01 déc. 2011 :  11:37:39  Show Profile  Reply with Quote
Hello barbudor, I don't know C++ :(, today I've run apache and php on my cheffs computer :/ but i have some problems white configure my apache.
I'll try everything to runn tracker.php but in xampp (lampp) i have Fatal error: Call to undefined function pcntl_fork()
Under Apache not Lampp and PHP CGI not an module of apache i can't run PHP :/
I have tested few tutorials about Apache nad PHP but i Can't make it ...
I know it's funny but I'am beginer in that.

May you share you c++ app? I've be very gratefull for it :)

Edited by - bartods on 01 déc. 2011 12:19:17
Go to Top of Page

barbudor

France
1732 Posts

Posted - 01 déc. 2011 :  18:08:48  Show Profile  Visit barbudor's Homepage  Reply with Quote
Ok.
I may share my basic C++ code. I will try to find some time this week-end for a little clean-up.
Would you need it for Windows or Linux ?

Modérateur Forum Traceurs GPS et Suivi GPS Temps Réel, son Index (français) et Les bons plan SIM pour traceurs GPS
Moderator Forum Live GPS Tracking Systems and its Index (english)
CartoExploreur3D | OziPC+OziCE(iPaq314) | TTGoLive950 | Carminat TomTom Live | Tracker Coban GPS-102
Go to Top of Page

e_lm_70

6 Posts

Posted - 02 déc. 2011 :  12:37:01  Show Profile  Visit e_lm_70's Homepage  Reply with Quote
Hi Guys.

First of all, thanks ... I did read many messages here and they did help to better understand.

Mainly on page 33, the diagram from Kokos, is excellent ... thanks to it, I manage to read the GPS and get the prompt from my GPS Tracker.

Now, back to my problem.

I just got a GPS Tracker TK201 from ebay: exactly this one: http://www.ebay.com/itm/220893353886
Apparently is produced by "zclelec" and is a clone of the TK102

Now my problem is this: (after an initial fight with a bad battery connection ...)

So far I was not able to made this tracker to get and send an SMS.

When I plug the battery it start automatically ... it flash every 1 seconds, for around 30 seconds ... and then it does not flash the led anymore.
If I press the ON-OFF button ... it will start again to blink-flash the led, with different speed rate, and this time it appears that it will not stop on doing it.

Strangely the behaviour for my non expert eye is the same, doesn't matter if the SIM is in or not. So I guess maybe it has some problem with GSM.

My Sim is a dual GSM & UMTS sim (back years ago the telecom operator had to change me the sim for allow me to use UMTS), and I normally use in GSM network, so it does support 900MHz without problem. Where I'm located I can get GSM signal in no time with my normal mobile phone ...

I did already double check that there is plenty of pressure for the sim to be read properly from the contacts.

So ... any idea what can be wrong ?

Is here any tool or command that I can give over the serial interface for further analyse the problem ?
I can eventually send it back to the seller on ebay, but I will need to pay for shipment ... so ... not sure I'm going to do it ... since in worst case I can use the internal GPS that is working for some of my projects.

Any idea if a firmware update will help ?
I'm not so confident on it, since this has been just acquired on eBay, so the seller may have done the firmware update on his own already if this would make the GPS tracker less problematic.

Thanks in advance

e_lm_70
Go to Top of Page

pmlewisuk

15 Posts

Posted - 02 déc. 2011 :  22:04:56  Show Profile  Reply with Quote
@ barbudor Windows please for your basic C++ code!

regards

Mark
Go to Top of Page

e_lm_70

6 Posts

Posted - 02 déc. 2011 :  22:10:44  Show Profile  Visit e_lm_70's Homepage  Reply with Quote
Please ..help ...

I can monitor the GPS ... and is looking it is functional.

While I monitor the GSM activity I got always :
AT+CREG?
AT+CREG?
AT+CPOWD=1

....

Only once by accident ... after power up ... after it did switch on automatically ... pressing some on-off and SOS .. I got a different sequence ...

ATE1
ATE1
ATE1
ATE1
ATE1
ATE1
ATE1
ATE1
ATE1
ATE1
ATE1
AT+CLIP=1
AT+CLIP=1
AT+CLIP=1
AT+CLIP=1
AT+CLIP=1
AT+CLIP=1
AT+CLIP=1
AT+CLIP=1
AT+CLIP=1
AT+CLIP=1
AT+CLIP=1
AT+CSCLK?
AT
AT
AT
AT
AT
AT
AT
AT
AT
AT
AT
AT+CLVL=4
AT+CLVL=4
AT+CLVL=4
AT+CLVL=4
AT+CLVL=4
AT+CLVL=4
AT+CLVL=4
AT+CLVL=4
AT+CLVL=4
AT+CLVL=4
AT+CLVL=4
AT+CMGF=1
AT+CMGF=1
AT+CMGF=1
AT+CMGF=1
AT+CMGF=1
AT+CMGF=1
AT+CMGF=1
AT+CMGF=1
AT+CMGF=1
AT+CMGF=1
AT+CMGF=1
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CNMI=2,1,0,0,0
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+CIPHEAD=1
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+IPR=19200;&W
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CGSN
AT+CMGR=01
AT+CMGR=02
AT+CMGR=03
AT+CMGR=04
AT+CMGR=05
AT+CMGR=06
AT+CMGR=07
AT+CMGR=08
AT+CMGR=09
AT+CMGR=10
AT+CMGR=11
AT+CMGF=1
AT+CSCLK=1


-----

But when I monitor the GPS ... I did find it dead ...

Can anybody help ?

How can I send a command to the GPS tracker over the terminal ?

just "begin123456" + <cr> ?
or I need to send AT+begin123456 ?

Please ...
Go to Top of Page

Grottenolm

Germany
206 Posts

Posted - 02 déc. 2011 :  22:18:31  Show Profile  Reply with Quote
Some time ago i have written a small tool for that which makes it little bit easier than using terminal editors.

http://*******/download/tools.php

Tool: TK102 configuration tool by USB cable (TK102-2 only) [WIN]
Go to Top of Page

e_lm_70

6 Posts

Posted - 03 déc. 2011 :  00:03:18  Show Profile  Visit e_lm_70's Homepage  Reply with Quote
Hi,

I'm using my 2.5$ USB to USART TTL converter ... any my custom plug, from the charger plug ...

So ... I had to learn a lot ...

I made some progress ... so now I know that I can read 3 different signal: GPS + Monitor 1 + Monitor 2 ... so the USB cable should have 3 ending in theory.

Anyhow, only on Monitor 2, I can type some command.

I did type format ... and I got a replay ok
I did type begin123456 ... but I got ERROR

Which command are allowed here ? Only Firmware update specific ?

Till few minutes ago I was getting:

RDY

+CFUN: 1

+CPIN: READY
AT+CREG?
+CREG: 0,2

OK
AT+CREG?
+CREG: 0,2

OK
AT+CREG?
+CREG: 0,2

OK
AT+CREG?
+CREG: 0,2

OK

Call Ready
AT+CREG?
+CREG: 0,2

OK
AT+CREG?
+CREG: 0,2


-----------------

But now I'm getting:

RDY

+CFUN: 1

+CPIN: READY

Call Ready


....

But it does not look to work fine for me ....

-----------------------------

Help please ....
Go to Top of Page

e_lm_70

6 Posts

Posted - 03 déc. 2011 :  00:11:25  Show Profile  Visit e_lm_70's Homepage  Reply with Quote
it looks like I can sent AT commands ...

at+gsn=?
OK
at+gsn

This did gave me the IMEI number :-o

at+cgmi
SIMCOM_Ltd

So the module is not a Siemens MC55 .. oder ?

Edited by - e_lm_70 on 03 déc. 2011 00:13:29
Go to Top of Page

e_lm_70

6 Posts

Posted - 03 déc. 2011 :  11:21:04  Show Profile  Visit e_lm_70's Homepage  Reply with Quote
I'm still trouble shutting my GPS-track TK201, the cheapest one shipped on eBay ...

Starting to thinking that the problem is a missing antenna or a very weak one ...

I asked the unit to provide the the available network ... and only once I got a single entry ... with my mobile phone I get strong signal and I see 4 operators.

These are the at command result:

at+cops?
+COPS: 0

OK
at+cops=?
+COPS: (3,"IDEA Centertel","IDEA","26003"),,(0-4),(0-2)

OK
at+cops=?
+COPS: ,,(0-4),(0-2)

OK
at+cops=?
+COPS: ,,(0-4),(0-2)

OK
at+cops=?
+COPS: ,,(0-4),(0-2)


-----------------

Can anybody confirm it that is an antenna problem ?

How easy is to open the device ? And check the antenna ...
Go to Top of Page

krister

Spain
158 Posts

Posted - 03 déc. 2011 :  11:32:56  Show Profile  Reply with Quote
@e_lm_70,

Just in case you did not notice, this is a thread about Xexun TK102 trackers. There is of course place for other Xexun trackers, and also for TK102 clones, but come on... You paid $47 with shipping for that tracker, what did you expect to have but a piece of junk? If you just looked for the cheapest unit on ebay, that's all you get :)

If you need a working unit and your time is worth something to you, forget about this tracker, and buy a good unit. Use the tracker you have as a learning unit, feel free to open it, hack it, use what is working for other projects as you say, etc, but I do not think you will get much help here.

Edited by - krister on 03 déc. 2011 11:33:42
Go to Top of Page

e_lm_70

6 Posts

Posted - 03 déc. 2011 :  17:05:54  Show Profile  Visit e_lm_70's Homepage  Reply with Quote
Actually in this thread I read more about clone then not real Xexun.

Anyhow ... whatever ... I find what is the problem.

Either the RF is bad or the antenna is not connected properly ... for the rest is looking functional, and exactly the same as a Xenun

Anyhow ... how much should this unit cost?

In these days a GPS cost 15€, a GSM-GPRS modem unit cost 20€, a chip for handle the two serial communication cost 5$ .. and these are end user prices, not mass order price.
The firmware for tracking is trivial. So few days of development for an expert firmware guy.

Anyhow, I did learn a lot in this process ... and in a rare moment that I got enough signal, I was able to send an AT command for send an SMS .. and it did work.

BTW .. does the Xenun support Sim with a pin, or they need to disable the PIN ?
This one of the dummy thing, that is trivial to enter the pin from the firmware and it will help security ... if the GPS tracker get stolen, who take it can use it also for make calls, even expensive one .

Tchuss

e_lm_70

ps: There is thread about my cheap and junky GPS tracker, but it is in Spanish ... maybe it works fine in LAT
Go to Top of Page

wozzzzza

19 Posts

Posted - 04 déc. 2011 :  11:43:19  Show Profile  Reply with Quote
still cannot contact Xenun, do they even exist?? i ahve sent several emails, filled out their contact form but no reply. i think i will change my mind about getting one of their GPS units if their presales support is non-existent, i hate to think what their aftersales would be like.
Go to Top of Page

Grottenolm

Germany
206 Posts

Posted - 04 déc. 2011 :  13:13:00  Show Profile  Reply with Quote
I had already some more contact with xexun and both, pre sales support and after sales too are okay. I got my replies same day or one day later (because of timediff to china). I am not sure if you are using the proper address to communicate with xexun. Otherwise i cannot post the right address here because forum admins will delete the post after that.
Go to Top of Page
Page: of 176 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,39 seconds. Powered By: Snitz Forums 2000 Version 3.4.05