Google
  Web www.gpspassion.com
fiogf49gjkf0d


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2791




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Magellan Roadmate and Maestro AIOs
 Unlocking Magellan Maestro series
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 20

cmjpaj

USA
14 Posts

Posted - 18 oct. 2008 :  19:50:38  Show Profile  Reply with Quote
Hi
I would like to recap what I have Done, Learned an Think so far.
Bricked my 2200t Hardware Version 1=> I have 2 units they differ in button set on the side, but are the same??
I can access the BOOT SCREEN ONLY.

Read 100+ pages and looked in many many diff forums looking for solutions Nothing worked.

Found threads by Tricorn, Harry A, Zaaidu, Bainos ect.. that stated get firmware Image file and checksum and load from Bootloader menu.

Used Bainos extact file version and Checksum and the unit started load Image and files !!!! I thought Great
I watched the load sequence and there was a part wher it showed "FORMATING FLASH FOR BINF ?? I though hell thats what it said when i messed it up but it kept going and booted up to White screen whith Load Bar moving all the way to the other side of the screen but no Image ?

Read somwhere that differant Hardware versions on the MIO would cause white screen due to diff drivers even though the units were the smame model but thats a different issue for now ?

Read that when people upgraded from ealier version it had to be in sequence i.e 1.5, 1.6, 1.7 to 2.1 but I don't think it means anything due to what I said about the FLASH FORMAT BINF when loading IMG file.

I remember that everyone who upgraded to the Crossover could not get Magellan PC Tools working until the new
updated tools version came out? Was there a driver the firmware 2.14, did not have and that the unit could not be seen? if that was true maybe the new PC Tools has what is needed for a computer to see it ?

My new plan is to start over and Load the Image file from an earlier firmware upgrade like 1.72 because it has file/folder structures similar to the examples posted for the second part of the restore process, where you make APP folder and put system files ect.Rename to Autorun ect..

My real problem right now is that to do this I need to create a Checksum value for the 1.72 firmware that I use. there are many posted on this forum and on the Magellan website. I have registered both of my units there and I can, and have downloaded their firmware. 1.72

Bainos, has given me instructions on how to arrive at the proper Checksum value but I am "dumb like a rock" when it comes to this type of thing, hopefully when I try this procedure I will be able to wrap my head around it, and get what I need.

Thanks to all for the Info and help I know it comes from many many hours of research trial and error.
sharing that info is appreciated by me and I am sure by all who read these threads
Go to Top of Page

cmjpaj

USA
14 Posts

Posted - 19 oct. 2008 :  00:32:43  Show Profile  Reply with Quote
Hi Again,
Can you calculate the Checksum Value for this winceimg.bin file. This is where I got it from
I am not even close to figuring out how. I tried to boot from the img file but it asked for Checksum
I was semi succesful in loading the 2.14 but I think I will have better luck with the older version

http://www.gpshelp.org/cross168.html

Thanks for the help if/when you get the chance
Go to Top of Page

bainos

Italy
16 Posts

Posted - 19 oct. 2008 :  12:05:44  Show Profile  Reply with Quote
hi! i downloaded the file and extracted it, but it does not contain any winceimg.. :(
if you have winceimg from older firmware, pleas share them and i'll try to get a valid checksum and also will try them on my (still bricked) magellan!

reagrds
bainos
Go to Top of Page

cmjpaj

USA
14 Posts

Posted - 19 oct. 2008 :  19:14:49  Show Profile  Reply with Quote
Hi
Try This Version
https://www.magellangps.com/support/download.asp?supportID=470
I am sorry I saw that the 168 did not have an IMG file last night Forgot to let you know. This is the 172 I have run it through Winhex over and over but I still get a checksum error.
Thanks again
Go to Top of Page

cmjpaj

USA
14 Posts

Posted - 20 oct. 2008 :  07:50:22  Show Profile  Reply with Quote
Hi Bainos,
Sorry, You need this
cmjpaj@sbcglobal.net
117999
Go to Top of Page

bainos

Italy
16 Posts

Posted - 20 oct. 2008 :  20:08:41  Show Profile  Reply with Quote
hmmm..
quote:

Try This Version
https://www.magellangps.com/support/download.asp?supportID=470


sorry but i cannot get this file, cose i do not have that product, it let me download only if i have one that product registere..
if you downloaded it, try to send me it by mail (if is not too large..)..

you can try the checksum in two ways:
-- normal way: open the file with winhex and calculate the checksum (32bit)
-- another way: calculate the checksum without the last 4 bits (read again my previous post)

i'm interessed in that file too, but i cannot find one..

regards bainos
Go to Top of Page

bainos

Italy
16 Posts

Posted - 20 oct. 2008 :  20:12:18  Show Profile  Reply with Quote
i trie with uor user and your passw .. but it says me it is wrong.. maybe you chaged it in the while.. bye
Go to Top of Page

cmjpaj

USA
14 Posts

Posted - 20 oct. 2008 :  23:12:05  Show Profile  Reply with Quote
Hi, bainos
Use email + leeland5 that will work for now
I have tried Winhex
Steps
Open the Img. file
Position GOTO OFFSET = 0 Begining to the end i.e entire block
Tools Hash Checksum 32bit
gives me ox22e9c4e3 but the last 4 bits read ox22e9c28b ?
I use bin size 5786792 the size -4
Email me if you cannot get file I be here most of the night
Go to Top of Page

cmjpaj

USA
14 Posts

Posted - 21 oct. 2008 :  04:36:47  Show Profile  Reply with Quote
hi bainos
Did you get the file? if not you will have to email me. I do not know how to upload it from here
Go to Top of Page

bainos

Italy
16 Posts

Posted - 23 oct. 2008 :  00:30:16  Show Profile  Reply with Quote
hi! i sent you a mail.. let me know if you recieved it..
quote:

Open the Img. file
Position GOTO OFFSET = 0 Begining to the end i.e entire block
Tools Hash Checksum 32bit
gives me ox22e9c4e3 but the last 4 bits read ox22e9c28b ?
I use bin size 5786792 the size -4



after you open the file in WinHex you have to select it with the mouse from the beginnig to the end except the four bits
if i understand well a bit is a sequence of tu characters in the right panel of the windows, so
you have to exclude from selection the last 8 characters of the file..
when the file is selected (except the last 4 bits) you can go to tools hash checsum ..
hope this helps!!
(sorry if i repeat myself but english isn't my language so i always think that what i write could not be understandable (?))

regards
bainos
Go to Top of Page

cmjpaj

USA
14 Posts

Posted - 24 oct. 2008 :  10:23:42  Show Profile  Reply with Quote
Hi bainos,
Did you get the file ? I still cannot get past checksum error?
using
Bin: 5786792
CH: ox22e9c28b & ox22epc4e3
At least the 214 version loads but with White screen
Also noticed that in the control panel under system hardware that Magellan roadmate shows up when
connected but I cannot see it in explorer ?
anyway hope you can figure out the correct size and checksum
Go to Top of Page

cmjpaj

USA
14 Posts

Posted - 26 oct. 2008 :  20:46:26  Show Profile  Reply with Quote
Hi,
I have restored OS "Maybe" took the WinCeimg. bin and ck files an loaded through the Bootloader. I can see it in the control panel under USB devices "Magellan Raodmate" it says it is working ect.. but cannot do a thing with the unit. I quess that there is some kind of hard code in the unit that must be called before the unit can be seen by the Tools program. I believe that leaves me dead in the water unless I can edit the image file or something on that line. Anyone have any other ideas. Can this unit/ARM setup be used to run anything else besides the 2200t software. Thanks for any input
P.S They did a good job of keeping these unit tamper proof !!!
Go to Top of Page

myshyak

3 Posts

Posted - 02 nov. 2008 :  13:38:54  Show Profile  Reply with Quote
Hello All
Doing my best to make 2 things working on my Magellan Maestro 3200, unlocked with Softbutton
1.Garmin XT
2.Any self made menu
have tried to play with Dll, checking needed with ExecCheck or Peinfo.
Guess the meain problem for garmin is that it needs Explorer, which doesn\t exist in Magellan
Have tried several of them , but none working
Do anyone managed to launch Garmin?
Would appreciate your help a lot.
P.S Managed to launch Miopocket on Magellan but Garmin do not start even from there.

Edited by - myshyak on 02 nov. 2008 13:43:56
Go to Top of Page

alehouse

United Kingdom
36 Posts

Posted - 02 nov. 2008 :  16:34:36  Show Profile  Reply with Quote
I've got a 4010(same/similar to 4040/4050). Would someone be kind enough to give me a quick rundown on how to get the windows CE to show up on this unit. Many thanks.

HTC Desire - NUVI - Ipaq 314
Go to Top of Page

Skitals

2 Posts

Posted - 04 nov. 2008 :  06:54:23  Show Profile  Visit Skitals's Homepage  Reply with Quote
quote:
Originally posted by xmen8

How did you get iGo8 to work on the magellan?
Any tips?
Thanks


quote:
Originally posted by mjmeans

Some new info... I'm pretty sure the 18r6 update for the 3100 has the updated host controller sdhc_sc2443.dll since it is dated June 12, 2007, since it's dated after the May 7th SD 2.0 update. However, the built-in sdbus.dll and sdmemory.dll are dated March 7, 2007 so the problem is likely only with these two drivers. I think I read somewhere that a Mio running CE 5 and a 2443 processor has been confirmed to work with SDHC. If anyone has the hc, bus and memory dll files from that please share them.

Also, even though the 3100 has sdmemory.dll, there is no [HKEY_LOCAL_MACHINE\Drivers\BuiltIn\SDMemory] key and entries in the default registry. Yet the SD card works with 2GB and lower cards. But if I add the key and entries to enable the already Magellan supplied dll, it stops recognizing any SD card. So this is pretty weird.

I am building a collection of .reg and .mscr files that mostly unlock the 3100. I have working: Windows CE Desktop (Explorer), Control Panel, SIP, CAB Install and Start Menu with several utilities (regedit, resmgr, editor, calc and some others), and iGo8 works! Also the script, upon hard reset asks if it should be installed or not.

A few more things I want to finish before the unlock is finished enough to post: My Device, Recycle Bin, SDHC, and more control panel applets.

And I still need to test \Windows\Startup entries to make sure they work as expected.





I am also looking to get iGo8 or the like running on my 3100. Any insight is appreciated!
Go to Top of Page
Page: of 20 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2017_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,11 seconds. Powered By: Snitz Forums 2000 Version 3.4.05