Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2243




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 "All in One" Navigation Systems
 [TOPIC] Customizing the HP iPaq 310
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 244

k000

USA
137 Posts

Posted - 13 mai 2008 :  04:29:29  Show Profile  Reply with Quote
specter - I know you said you are going to fix it - did you get a chance to see is you could permanently disappear the large turnicon ? Right now it comes back afetr the next turn... I could completely get rid of it and use that space for one of your upcoming mods ;)
Go to Top of Page

redeyes717

Italy
26 Posts

Posted - 13 mai 2008 :  09:09:09  Show Profile  Reply with Quote
@Specter

I've just figured out that in IPAQ314 (european version) there's no:

"run sc_SetAvoidButtonText" within FILE: ui_hpi_sagan/common/ui/navigatemap.ui

; adding this command from your mod gives rise to an error and corrupted mod as soon as the map button is pressed in main view.

For IPAQ314 users: just remove this line to get the FULL SCREEN VIEW as default.

Red.

HP Ipaq 314, Magellan 4370, Mio Spirit V735
IPhone-3GS 32GB, Sony Xperia, HTC Dream

Edited by - redeyes717 on 13 mai 2008 10:37:52
Go to Top of Page

grandous

127 Posts

Posted - 13 mai 2008 :  17:11:00  Show Profile  Reply with Quote
quote:
Originally posted by specter

Roeka,
YOU ARE THE MAN! adding visiblemodel="navigation.eta_at_destination.valid" after the z worked. I got that grey bmp and the black around the white text from the beta version of navngo 8. I just cut and pasted parts from the data.zip file. Oh, and navngo 8 will run on the HP 310. The only problem is that it will only support up to 640x480. It runs in a small window instead of full screen, but at least it runs.

I updated rar file you can download to have the "navigation.eta_at_destination.valid".

DOWNLOAD HERE: http://www.ebay-pictures.com/efm_specter_version.rar

If anyone wants to update their EFM (specter mod). here are the changes (thanks to Roeka).

BEFORE:
;******* GREY SQUARE FOR TIME, ETA...
<SPRITE sprNMIDataBG bmp="blackstripe.bmp" x=-315 y=195 z=0>
<SPRITE sprNMIDataBG2 bmp="blackstripe.bmp" x=-315 y=215 z=0>
<SPRITE sprNMIDataBG3 bmp="blackstripe.bmp" x=-315 y=235 z=0>
<SPRITE sprNMIDataBG4 bmp="blackstripe.bmp" x=-315 y=255 z=0>
<SPRITE sprNMIDataBG5 bmp="blackstripe.bmp" x=-315 y=275 z=0>
<SPRITE sprNMIDataBG6 bmp="blackstripe.bmp" x=-315 y=295 z=0>

AFTER:
;******* GREY SQUARE FOR TIME, ETA...
<SPRITE sprNMIDataBG bmp="blackstripe.bmp" x=-315 y=195 z=0 visiblemodel="navigation.eta_at_destination.valid">
<SPRITE sprNMIDataBG2 bmp="blackstripe.bmp" x=-315 y=215 z=0 visiblemodel="navigation.eta_at_destination.valid">
<SPRITE sprNMIDataBG3 bmp="blackstripe.bmp" x=-315 y=235 z=0 visiblemodel="navigation.eta_at_destination.valid">
<SPRITE sprNMIDataBG4 bmp="blackstripe.bmp" x=-315 y=255 z=0 visiblemodel="navigation.eta_at_destination.valid">
<SPRITE sprNMIDataBG5 bmp="blackstripe.bmp" x=-315 y=275 z=0 visiblemodel="navigation.eta_at_destination.valid">
<SPRITE sprNMIDataBG6 bmp="blackstripe.bmp" x=-315 y=295 z=0 visiblemodel="navigation.eta_at_destination.valid">


This will remove the grey square area on the left side of the screen until there is text to display.



@ Specter:
Why ipaq does not go up 640x480? 400x200 with vga=1?

Edited by - grandous on 14 mai 2008 07:47:22
Go to Top of Page

specter

USA
98 Posts

Posted - 13 mai 2008 :  20:06:37  Show Profile  Visit specter's Homepage  Reply with Quote
quote:
Originally posted by k000

specter - I know you said you are going to fix it - did you get a chance to see is you could permanently disappear the large turnicon ? Right now it comes back afetr the next turn... I could completely get rid of it and use that space for one of your upcoming mods ;)



in navigatemap_800_480.ui
TRY THIS: put a semicolon in front of these lines.

<layer ui_Cockpit z=10000>
;SPECTER MOD - HIDE THE BIG ICON
; <BUTTON xxx bmp="hp_cockpit_bg.bmp" x=0 y=76 z=1 onrelease='ui_Cockpit.hide' visiblemodel="navigation.distance_to_manuver.valid&navigation.direction_id.valid">

; <BUTTON xxx bmp="hp_cockpit_bg.bmp" x=0 y=76 z=1 onrelease='run sc_MapClicked' visiblemodel="navigation.distance_to_manuver.valid&navigation.direction_id.valid">
; <SPRITE xxx bmp="$hp_diriconbig_cockpit.spr" x=6 y=82 z=10 phasemodel="navigation.direction_id" visiblemodel="navigation.distance_to_manuver.valid&navigation.direction_id.valid">

WEBSITE: diMka Skin Homepage

WEBSITE: Ipaq Travel Companion mods

Edited by - specter on 13 mai 2008 20:07:15
Go to Top of Page

gpsuser

57 Posts

Posted - 14 mai 2008 :  00:46:53  Show Profile  Reply with Quote
I have successfully updated my 310 with Mod 2. It is a huge improvement! Thank you very much to Roeka, Specter, jyqureshi and others. Great work!

I do have one issue that I am wondering if it relates to the blackstipe.bmp. I have the grey, translucent bar on the top and bottom but there is a ½ inch gap in the center of both strips where the background shows through like the main screen. Did I miss a step or maybe it is the blackstipe.bmp?
Go to Top of Page

specter

USA
98 Posts

Posted - 14 mai 2008 :  02:24:15  Show Profile  Visit specter's Homepage  Reply with Quote
quote:
Originally posted by gpsuser

I have successfully updated my 310 with Mod 2. It is a huge improvement! Thank you very much to Roeka, Specter, jyqureshi and others. Great work!

I do have one issue that I am wondering if it relates to the blackstipe.bmp. I have the grey, translucent bar on the top and bottom but there is a ½ inch gap in the center of both strips where the background shows through like the main screen. Did I miss a step or maybe it is the blackstipe.bmp?




Try downloading the blackstripe.bmp again and replace the one you have and let me know if that fixes it. I don't think you did anything wrong. sounds like the file. When you go to the MOD2 page, hit refresh on your browser so it will download the latest file. I want to be sure it doesn't save a picture from your browser cache.

WEBSITE: diMka Skin Homepage

WEBSITE: Ipaq Travel Companion mods

Edited by - specter on 14 mai 2008 02:26:38
Go to Top of Page

gpsuser

57 Posts

Posted - 14 mai 2008 :  02:32:17  Show Profile  Reply with Quote
specter. I followed your instructions but I get an icon with small x that I am unable to save as ... ( I know I can not view it). How do I save it? thanks
Go to Top of Page

specter

USA
98 Posts

Posted - 14 mai 2008 :  03:38:47  Show Profile  Visit specter's Homepage  Reply with Quote
quote:
Originally posted by gpsuser

specter. I followed your instructions but I get an icon with small x that I am unable to save as ... ( I know I can not view it). How do I save it? thanks



do the SAVE AS on the link. don't left click on the link, you have to right click it.

WEBSITE: diMka Skin Homepage

WEBSITE: Ipaq Travel Companion mods
Go to Top of Page

hank1

3 Posts

Posted - 14 mai 2008 :  05:10:27  Show Profile  Reply with Quote
Specter,
Thank you for your latest mod. I have a issue with the top gray bar. It does not look like the picture you have posted. The size is approximately 3/4
compared to yours. I did everything according to your instruction in Mod 2, I hope. Is there any way to increase it.
Thanks
Go to Top of Page

specter

USA
98 Posts

Posted - 14 mai 2008 :  07:06:12  Show Profile  Visit specter's Homepage  Reply with Quote
quote:
Originally posted by hank1

Specter,
Thank you for your latest mod. I have a issue with the top gray bar. It does not look like the picture you have posted. The size is approximately 3/4
compared to yours. I did everything according to your instruction in Mod 2, I hope. Is there any way to increase it.
Thanks



It was the blackstripe.bmp file. Just go back to the site and download it again. then put the new blackstripe.bmp in your data.zip file, replacing the other one. sorry about that.

WEBSITE: diMka Skin Homepage

WEBSITE: Ipaq Travel Companion mods
Go to Top of Page

gpsuser

57 Posts

Posted - 14 mai 2008 :  13:38:39  Show Profile  Reply with Quote
Specter,
I have downloaded the blackstripe.bmp again and copied it to the 800_480 directory but continue to have the same problem, where there is a gap in the grey top and bottom stripes. All other features seem to work.
Go to Top of Page

gpsuser

57 Posts

Posted - 14 mai 2008 :  16:06:26  Show Profile  Reply with Quote
Specter, A friend suggested maybe the stripe on the top and bottom of the screen is blackstipe.bmp displayed 5 times horizontally and the center component is not being displayed. Is blackstipe one object that fits across the top and bottom of the screen or is it assembled from 5 objects with equal width.
Go to Top of Page

k000

USA
137 Posts

Posted - 14 mai 2008 :  16:29:48  Show Profile  Reply with Quote
Specter - the big turn sign is gone, but the distance to next turm is still there... so I see two distances one with the top left small turn sign, and another one orphaned fron the big turn sign.

quote:
Originally posted by specter

quote:
Originally posted by k000

specter - I know you said you are going to fix it - did you get a chance to see is you could permanently disappear the large turnicon ? Right now it comes back afetr the next turn... I could completely get rid of it and use that space for one of your upcoming mods ;)



in navigatemap_800_480.ui
TRY THIS: put a semicolon in front of these lines.

<layer ui_Cockpit z=10000>
;SPECTER MOD - HIDE THE BIG ICON
; <BUTTON xxx bmp="hp_cockpit_bg.bmp" x=0 y=76 z=1 onrelease='ui_Cockpit.hide' visiblemodel="navigation.distance_to_manuver.valid&navigation.direction_id.valid">

; <BUTTON xxx bmp="hp_cockpit_bg.bmp" x=0 y=76 z=1 onrelease='run sc_MapClicked' visiblemodel="navigation.distance_to_manuver.valid&navigation.direction_id.valid">
; <SPRITE xxx bmp="$hp_diriconbig_cockpit.spr" x=6 y=82 z=10 phasemodel="navigation.direction_id" visiblemodel="navigation.distance_to_manuver.valid&navigation.direction_id.valid">

Go to Top of Page

Olegus

66 Posts

Posted - 14 mai 2008 :  17:09:49  Show Profile  Reply with Quote
Here is an enhancement I did for my convenience. First of all, I must say even though Roeka, Specter, jyqureshi and Co. mods are awesome, I gave up to use them - never had them work as suppose - got lost in xml, trying to hybrid both. My little enhancement switches from "original size map" (with blue bars) to "full size map" automatically after several seconds delay and get back to original size after you tap a screen. It requires changes in one file - ui_hp_sagan\common\ui\navigatemap.ui .
My changes are embraced in ;OLEG.. ;. If you see "......" it means I just skipped the rest of the script to save space. Do not just Copy and Paste code below to your file. You will need to go through your navigatemap.ui, look for needed scripts and apply my changes thoughtfully.
These changes were made to the original navigatemap.ui.
As usual, I do not provide any warranty on these changes and please make a backup copy before applying them. Amen.

<script done>
term sc_HideViewControls_delay
;OLEG
term sc_ShowFullMap_delay
;
.........
</script>

<script sc_MapClicked>
run sc_tmc_announce_done
ui_NavigateMapZoomControls2D.isvisible vtmp
runif vtmp 1 'vShowCursor.set 1, map.showcursor 1, run sc_followoff'
ui_NavigateMapZoomControls3D.isvisible vtmp
runif vtmp 1 'vShowCursor.set 1, map.showcursor 1, run sc_followoff'
runif vMapMode L"3D" sc_ShowViewControls3D
else_runif vMapMode L"2D" sc_ShowViewControls2D
run sc_HideViewControls_delay_restart
map.ONMAPCLICK sc_MapClicked 2
;OLEG
runif vFooterShow 0 'run sc_Original_MapSize'
;
</script>
<script sc_MapClicked_mapgrabd>
run sc_tmc_announce_done
map.ONMAPCLICK sc_MapClicked 2
runif vMapMode L"3D" 'ui_NavigateMapZoomControls3D.show'
else_runif vMapMode L"2D" 'ui_NavigateMapZoomControls2D.show'
ui_cockpit.hide
run sc_HideViewControls_delay_restart
;OLEG
run sc_ShowFullMap_delay_restart
;
1 map.showcursor 0
</script>

add 2 new scripts

;OLEG - 550 prefix- I think it is delay in milliseconds to switch to full screen, but probably because of other
;delays real time delay is about 10 sec in my case
<script sc_ShowFullMap_delay>
550 run sc_Full_MapSize
</script>

<script sc_ShowFullMap_delay_restart>
term sc_ShowFullMap_delay
1 run sc_ShowFullMap_delay
</script>
;


changes are at the very end of sc_Original_MapSize script:

<script sc_Original_MapSize>
........
;OLEG
run sc_ShowFullMap_delay_restart
;
</script>

iPAQ 310

Edited by - Olegus on 14 mai 2008 17:15:44
Go to Top of Page

specter

USA
98 Posts

Posted - 14 mai 2008 :  17:20:13  Show Profile  Visit specter's Homepage  Reply with Quote
@GPSUSER

That stripe is only 480 pixels wide by 20 pixels tall. That is why i had to use so many of them to make it work on a 800x480 screen. What happened, i think is that I copied the wrong blackstripe.bmp file to the server. Probably 360x20. could you try downloading the rar file below and extract the blackstrip.bmp out of it and try it. I copied this straight from my data.zip and tested it before hand. this should definitely fix it.

http://www.ebay-pictures.com/gps/images/blackstripe.rar

WEBSITE: diMka Skin Homepage

WEBSITE: Ipaq Travel Companion mods
Go to Top of Page
Page: of 244 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 4,12 seconds. Powered By: Snitz Forums 2000 Version 3.4.05