Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2172




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 GPS Programming
 "Beta" GPS software
 Port Splitter, yeat , another port splitter

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

  Check here to include your profile signature.
Check here to subscribe to this topic.
    

T O P I C    R E V I E W
jaluna Posted - 12 juil. 2006 : 15:16:56
Betatester needs!!



http://www.gpsmeter.com/index.php?page=portsplitter

Please, submit your impressions here.

Regards,
JAL
15   L A T E S T    R E P L I E S    (Newest First)
veco08 Posted - 26 sept. 2012 : 13:27:19
everything is very simple but this port splitter not working in my device :-(
jaluna Posted - 26 sept. 2012 : 12:19:57
Easy, configure the program to create it.
veco08 Posted - 26 sept. 2012 : 11:25:02
Hi,
how to i manuely create file settings.dat for my parameters (input port 2 baud 4800 output port 3 or 5 )?
jaluna Posted - 26 sept. 2012 : 10:43:20
quote:
AS PER THE FAQ, NO NEED TO QUOTE A MESSAGE DIRECTLY ABOVE YOURS, MAKES THE FORUMS EASIER TO READ, THANKS ;-) GPSPASSION TEAM
Hello,

If I remember well, in the last version (V1.31) the settings are saved to a file (Settings.dat). At least for the CE5 version.

Regards, JAL,
http://www.gpsmeter.com/
veco08 Posted - 26 sept. 2012 : 09:08:18
Hi,
I instaled mort script and port splitter on my Navigon 40 plus because i using Igo Primo in this navigation. In folder igo,created on My Flash disk memory Navigon device,existed file Start iGO.mscr ,when there is


# You must copy all the files into the iGO directory otherwise you will need to edit all the paths!
# Fatboyfun 2011 www.navitotal.com

# Write registry entries
RegWriteString ("HKLM", "SOFTWARE\JAL\Port Splitter", "InstallPath", SystemPath("ScriptPath") )
RegWriteDWord ("HKLM", "SOFTWARE\JAL\Port Splitter", "MajorVersion", 1 )
RegWriteDWord ("HKCU", "Software\JAL\Port Splitter", "Split", 2 )
RegWriteDWord ("HKCU", "Software\JAL\Port Splitter", "Autostart", 1 )
RegWriteDWord ("HKCU", "Software\JAL\Port Splitter", "Baud", 11 ) (<- 10 = 56000, 11 = 57600, 12 = 115200)
RegWriteDWord ("HKCU", "Software\JAL\Port Splitter", "Port", 5 )
Sleep (100)

# Check if process exists and start Port Splitter if not
If(not ProcExists("Port Splitter.exe"))
Run(SystemPath("ScriptPath")\"Port Splitter.exe")
Sleep(500)
EndIf

# Start iGO and wait...
RunWait (SystemPath("ScriptPath")\"iGO.exe")

# iGO has closed so...
# Stop Port Splitter properly otherwise it needs a reboot to restart
If(WndExists("Port Splitter V1.20"))
SendCommand("Port Splitter V1.20", 1010)
Sleep(500)
SendCommand("Port Splitter V1.20", 2)
Sleep(500)
EndIf

# Kill Port Splitter process
If(ProcExists("Port Splitter.exe"))
Kill("Port Splitter.exe")
EndIf

# remove registry entries
RegDeleteKey( "HKLM", "SOFTWARE\JAL", TRUE, TRUE )
RegDeleteKey( "HKCU", "Software\JAL", TRUE, TRUE )
when i started primo,no gps port detect but if i manualy seting output port to say 5,clik to Add and clik to Start primo find gps receiver and my position.
Is there comand would i in dis file programed port spliter to add output port say 5 and starting automaticly (comand RegWriteDWord ("HKCU", "Software\JAL\Port Splitter", "Autostart", 1 )
RegWriteDWord ("HKCU", "Software\JAL\Port Splitter", "Baud", 11 ) (<- 10 = 56000, 11 = 57600, 12 = 115200)
RegWriteDWord ("HKCU", "Software\JAL\Port Splitter", "Port", 5 )
working and portspliter automaticly programed input port and baud rate

Thanks and sory for my bad english
jaluna Posted - 23 août 2012 : 16:45:02
Are you sure???

Regards, JAL,
http://www.gpsmeter.com/

quote:
Originally posted by jwoegerbauer

WARNING WARNING WARNING

Portsplitter hardcoded installs as Launch96/Depend96 in HKLM\init. At my chinese device Launch96 is by default set to 'GPSLogin.exe'

[HKEY_LOCAL_MACHINE\init]
"Launch20"="device.dll"
"Launch30"="gwes.dll"
"Depend30"=hex: 14,00
"Launch60"="servicesStart.exe"
"Depend60"=hex: 14,00
"Launch100"="Gpsmc.exe"
"Depend100"=hex: 1E,00
"Launch96"="GPSLogin.exe"
"Depend96"=hex: 14,00,1E,00
"Launch101"="TimePatch.exe"
"Depend101"=hex: 14,00,1E,00

If my CE 6.0 device's USB-mode wouldn't have been 'ActiveSync', my device would have got bricked.


jwoegerbauer Posted - 23 août 2012 : 15:30:35
WARNING WARNING WARNING

Portsplitter hardcoded installs as Launch96/Depend96 in HKLM\init. At my chinese device Launch96 is by default set to 'GPSLogin.exe'

[HKEY_LOCAL_MACHINE\init]
"Launch20"="device.dll"
"Launch30"="gwes.dll"
"Depend30"=hex: 14,00
"Launch60"="servicesStart.exe"
"Depend60"=hex: 14,00
"Launch100"="Gpsmc.exe"
"Depend100"=hex: 1E,00
"Launch96"="GPSLogin.exe"
"Depend96"=hex: 14,00,1E,00
"Launch101"="TimePatch.exe"
"Depend101"=hex: 14,00,1E,00

If my CE 6.0 device's USB-mode wouldn't have been 'ActiveSync', my device would have got bricked.
mvpuiu Posted - 04 juil. 2012 : 16:30:33
hi,
i have a navigon 3310. i put the port splitter on its my flash disk, i started with filemanCE and when i try to start port splitter, nothing happens...i used portsplitter_wince5.zip
can anyone help me with this?
jaluna Posted - 06 mai 2012 : 12:59:44
quote:
Originally posted by testerics

Hi jaluna, I'm using the last version of port splitter on my Navigon 4350max to be posible to "redirect" the GPS port com2 to com7 (for Primo 2.0 to work). Everything is ok, only one issue I have: my device is generating only the GGA and RMC NMEA sentences (I could see this with SirfTech.exe)
This is ok for Navigon, but for iGO8, Primo and other navigation software is not ok (for example, on iGO8 I have full GPS signal, but I can't see the altitude and signal bars because GSA and GSV sentences are not generated...). If I use SirfTech I could enable even GSA and GSV sentences and after this I start the Primo using a script that is launching the port splitter first. But this application doesen't have the possibility to set NMEA message rate from command line, so I need after every restart of my device to set manually the new sentences.
Maybe I'm off-topic, but... do you think that is possile to implement in your port splitter the possibility to see and set the NMEA sentences... or something similar?
Thank you very much!




yes, sorry, this matter is totally off-topic. Portsplitter will redirect the traffic one-way over the input port with independance of the nature of data sent.
Maybe you can control SirfTech with some script to automate this task.

Regards, JAL,
http://www.gpsmeter.com/
testerics Posted - 05 mai 2012 : 15:50:35
Hi jaluna, I'm using the last version of port splitter on my Navigon 4350max to be posible to "redirect" the GPS port com2 to com7 (for Primo 2.0 to work). Everything is ok, only one issue I have: my device is generating only the GGA and RMC NMEA sentences (I could see this with SirfTech.exe)
This is ok for Navigon, but for iGO8, Primo and other navigation software is not ok (for example, on iGO8 I have full GPS signal, but I can't see the altitude and signal bars because GSA and GSV sentences are not generated...). If I use SirfTech I could enable even GSA and GSV sentences and after this I start the Primo using a script that is launching the port splitter first. But this application doesen't have the possibility to set NMEA message rate from command line, so I need after every restart of my device to set manually the new sentences.
Maybe I'm off-topic, but... do you think that is possile to implement in your port splitter the possibility to see and set the NMEA sentences... or something similar?
Thank you very much!
jaluna Posted - 20 avr. 2012 : 11:17:47
quote:
Originally posted by Kevinjansen

Dear jaluna,

First of all I would like to say that your port splitter app is the effect solution for my GPS!
My Com 2 port wasn't visible for GPS apps but now with the port splitter app I can split the port and the spitted port becomes visible!
Just great! Everything works again tom-tom Igo and all other small GPS apps!
My only problem now is that the app doesn't start automatically on boot up with my unlock for my mio Visual.
With this unlock the port splitter app was already installed. Port Splitter V1.31
Once again I would like to thank you so much for this app! I really love how I can use my GPS apps now with help from Port Splitter.

I would like to ask you how to get the app lunched at startup.
I have a Mio Moov S505 GPS system with Visual unlock installed.

I hope you can help me with my problem

Kind regards,

Kevin Jansen.



This feature just copies the shortcut (Port Splitter.lnk) to \Windows\AutoStart

Maybe your device clear the content of \Windows\AutoStart at boot... and the shortcut is never called.

Regards, JAL,
http://www.gpsmeter.com/
Kevinjansen Posted - 20 avr. 2012 : 09:19:21
Dear jaluna,

First of all I would like to say that your port splitter app is the effect solution for my GPS!
My Com 2 port wasn't visible for GPS apps but now with the port splitter app I can split the port and the spitted port becomes visible!
Just great! Everything works again tom-tom Igo and all other small GPS apps!
My only problem now is that the app doesn't start automatically on boot up with my unlock for my mio Visual.
With this unlock the port splitter app was already installed. Port Splitter V1.31
Once again I would like to thank you so much for this app! I really love how I can use my GPS apps now with help from Port Splitter.

I would like to ask you how to get the app lunched at startup.
I have a Mio Moov S505 GPS system with Visual unlock installed.

I hope you can help me with my problem

Kind regards,

Kevin Jansen.
mg1 Posted - 09 avr. 2012 : 23:45:48
quote:
Originally posted by mg1

built-in GPS receiver. It seems like it is not assigned to a COM port, but rather to the GPS1: device.



All,

I confirmed that the port named GPS1 on the device I was mentioning outputs NMEA data and so I would love to be able to redirect it to a more canonical port name. Any way to use ports that do not have a COM prefix as inputs for portsplitter?

A few years ago there was a user (Kuruto) with a similar problem, who wanted to use a FTD0: port as input, but I am not sure if his problem was ever solved.

Any advice?

Many thanks
artlov Posted - 30 mars 2012 : 12:21:54
Quite quiet here...
I have been tried to split port in my HP iPAQ310. Downloaded last available PortSplitter_WinCE5, but i have empty Output fileds. Please help me to fill it with some value. Screenshot example: http://dl.dropbox.com/u/13532720/hp310_port_splitter.jpg
sucro Posted - 08 mars 2012 : 16:12:00
quote:
Originally posted by xd-data-ii

Hi,

I have an issue where my gps receiver is on comm port 2 with baud rate 38400.
When i connect my external Royaltek RTA-3000 TMC recevier is seems to connect on comm port 2 and it uses 9600 baud rate.
So therefore in iGO i cant get it to recognise the TMC receiver as the GPS receiver is using comm 2. When i disable the gps it finds the TMC on comm 2.
I tried port splitter to split the port but its seems i can only split the port with a specified baud rate. So when i split comm 2 to, say, 7 and 8 with 9600 baud rate, the gps receiver cannot be found anywhere. TMC is found. If i split it with 38400 baud rate, gps is found and tmc cant be found.

Is there a way to split the port and have it irrelevant of baud rate?
Or do you know of a way for me to achieve what i need to get the TMC and GPS working on my WinCE5 device?

Thanks


GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 0,44 seconds. Powered By: Snitz Forums 2000 Version 3.4.05