Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 1952




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 "All in One" Navigation Systems
 [TOPIC] Customizing the HP iPaq 310

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

  Check here to include your profile signature.
Check here to subscribe to this topic.
    

T O P I C    R E V I E W
gpspassion Posted - 17 nov. 2007 : 20:06:32
READ FIRST : "Customizing" the iPaq 310 means that you are adding applications that were not specifically designed to run on the device, therefore there is a risk that you will alter its normal operation the way it was intended by HP.

While many applications have been found to run properly (TCPMP for DivX playing, OziCE for off-road GPS), there is always a risk that you will prevent your unit from operating normally, especially since there is currently no way of returning it to its factory settings (the changes to the crucial registry are permanent). Only proceed with caution and under your sole responsibility (On Page 3 of the HP "Global limited warranty and technical support" leaflet, it states quite clearly that the said warranty does not apply to "... any product...that has been damaged or rendered ineffective by ...(c) software, interfacing, parts or supplies not supplied by HP...").


1. WinCE Tricks and Tips

1. Applauncher by Hagar, download link and instructions here on page 58


2. List of tweaks to the GPS Software UI
MOD: Compass

Step 1: EDIT: Download these files http://www.gpspassion.com/upload/ui_hp_sagan.rar and extract them in your ui_hp_sagan\common folder

Step 2:
Open your ui_hp_sagan\800_480\ui\navigatemap_800_480.ui

Copy these VSPRITE lines:


<VSPRITE dayCompass vec="$compass.vpr" x=9 y=200 z=11 rotatemodel="map.rotation_angle" hide>
<VSPRITE nightCompass vec="$ncompass.vpr" x=9 y=200 z=11 rotatemodel="map.rotation_angle" hide>


and look for the following layer:

<layer ui_NavigateMapTOP z=100>
and paste VSPRITE lines anywhere here
</layer>

A VSPRITE is a vector sprite, if you open the files I provided in the rar file in text editor, you'll find some polygons defined. The top line defines the grid height, width, and its center point based on which the polygon is drawn.

Any curious being can use a graph paper and start plotting these dots and connecting them, starting from top.
Save and close this file.

Step 3:
Open your ui_hp_sagan\800_480\ui\scripts_800_480.ui

copy and paste these scripts at the end:
People who have done the "Full Screen" mod I posted earlier just need to update their existing sc_day_text_color and sc_night_text_color scripts.


<script sc_day_text_color>
dayCompass.show
nightCompass.hide
</script>

<script sc_night_text_color>
dayCompass.hide
nightCompass.show
</script>


Step 4:
Open your ui_hp_sagan\common\ui\navigatemap.ui

Copy the following lines in your <script sc_Original_MapSize> and <script sc_Full_MapSize> scripts

runif vNightMode 1 'run sc_night_text_color'
else_run 'run sc_day_text_color'


Close and save this file.

Move all these files onto your iPaq and enjoy. If it doesn't work the first time, try again:)

To display route details by clicking on the "Clock and chequered flag" icon:

Open ui_hp_sagan\800_480\ui\navigatemap_800_480.ui

Find hp_btn_timeto_dest.bmp

replace the line with the following line:

<BUTTON xxx x=346 y=404 z=51 bmp="hp_btn_timeto_dest.bmp#2" onRelease='NEXTSTATE st_RouteItinerary' enabledmodel="!route.itiner.list.isempty">

Save and close this file.

Move the file to your iPaq and enjoy.

Changing the colors of the map by JohnCougar : download (for 04/2008 update)
Click here for a preview.

data.zip:project_config\hp_sagan.ini: increasing volume from 64 to 128.

[Before]
sound_volume=64
voice_volume=64

[After]
sound_volume=128
voice_volume=128


data.zip:ui_hp_sagan\800_480\ui\setting_800_480.ui: add Pedestrian mode.

[Before]
z=1 value="Car|0|Taxi|1|Bus|2|Truck|3|Bicycle|6"

[After]
z=1 value="Car|0|Taxi|1|Bus|2|Truck|3|Pedestrian|5|Bicycle|6"


data.zip:ui_hp_sagan800_480\ui\setting_800_480.ui: add car pool lanes mode.

[Before]
boolmodel="route.allow_carpool" hide>

[After]
boolmodel="route.allow_carpool">


data.zip:project_config\hp_sagan.ini: remove nav warning message.

[Before]
drive_carefully=1

[After]
drive_carefully=0

Note: When resuming from standby while on battery the message is not displayed. When resuming from standby
while charging the warning message is displayed.I have had only inconsistent results.

Below two further customizations which may be added to the first post.


Disable "Drive Carefully" warning

To completly disable the #8222;Drive Carefully#8220; warning follow these steps:

File:
data.zip \ui_hp_sagan\common\ui\drive_carefully.ui

Replace:
<script sc_drive_carefully_init>
run sc_drive_carefully_show
btn_dc_agree.hide
;ui_drive_carefully_xhtml.z 100005
KEY "RETURN"
KEY "REC"
KEY "UP"
KEY "DOWN"

</script>

With:
<script sc_drive_carefully_init>
; run sc_drive_carefully_show
; btn_dc_agree.hide
; ;ui_drive_carefully_xhtml.z 100005
; KEY "RETURN"
; KEY "REC"
; KEY "UP"
; KEY "DOWN"
;
</script>


Display status messages on boot

File:
data.zip \project_config\hp_sagan.ini

Replace:
[loading]
show_statustext=0
show_progressbar=1

progressbar_x=234
progressbar_y=377
progressbar_bmp="loading_progressbar.bmp"
loading_bmp="loading.jpg"

;text_fontcolor=xFFFFFF
;text_fontsize=30
;text_x=100
;text_y=400
;text_w=600
;text_align: LEFT = 0,CENTER = 1,RIGHT = 2 JUSTIFY = 3
;text_align=1

With:
[loading]
show_statustext=1
show_progressbar=1

progressbar_x=234
progressbar_y=377
progressbar_bmp="loading_progressbar.bmp"
loading_bmp="loading.jpg"

text_fontcolor=xFFFFFF
text_fontsize=24
text_x=100
text_y=410
text_w=600
;text_align: LEFT = 0,CENTER = 1,RIGHT = 2 JUSTIFY = 3
text_align=1

The simulation mode closes if you press somewhere on the map. The following tweak disables this behaviour. Then, the simulation is stopped using the #8220;Play#8221; button.
This is useful for testing some click behaviour. (e.g. show / hide cockpit / full screen)

File:
data.zip \ui_hp_sagan\common\ui\navigatemap.ui

Replace:
<layer ui_FlyOver type="flyover" x=0 y=0 w=800 h=480 z=13004>

With:
<layer ui_FlyOver type="flyover" x=0 y=0 w=0 h=0 z=13004>

It may also be useful for testing some modifications using iGo on PC.

UPDATED 20080225 : The 310 is now Wi-Fi capable, see details on page 33.

UPDATED 20080114 : tip to add back the pedestrian mode : details on page 16.

Posted by lbendlin in the iPaq 310 - User Reviews thread.

"The device is extremely easy to hack. All you need to do is replace the nav.exe with, let's say, TotalCommander for Windows CE (cecmd.exe). AFTER you did a complete backup!

And if you don't like that, add a folder to the Games folder and place your programs there. you can then see another game icon and run your app from there."

"Once you opened the control panel you can set the USB client mode from "Mass Storage Device" to "Serial Class" and then you can use ActiveSync."

You can also boot into the WinCE shell by placing a dummy celoader.exe file in a SD card (max size 2GB) and reset your iPaq
15   L A T E S T    R E P L I E S    (Newest First)
kalos1965 Posted - 17 mars 2014 : 11:57:04
On my Anygo C7012 with WinCE 6.0 have bluetooth hardware error 10050 ( controllor not present ) . I need a driver ? Where i can find it and how install it. Thanks.
hangover Posted - 14 juin 2013 : 12:09:57
Does anyone have a link for BBO RC3 ?
hangover Posted - 18 mai 2013 : 11:30:31
quote:
Originally posted by johnhayter

Here is a link to bbO-RC1 and bbO-RC1fix:
https://www.box.com/s/p6l3xi6kou7lpkht85zu



Thankyou much appreciated.
johnhayter Posted - 18 mai 2013 : 10:29:36
Here is a link to bbO-RC1 and bbO-RC1fix:
https://www.box.com/s/p6l3xi6kou7lpkht85zu
hangover Posted - 18 mai 2013 : 01:51:32
John, do you have a working link for BBO, i keep going around in circles trying to find a current link.
hangover Posted - 17 mai 2013 : 13:14:29
quote:
Originally posted by johnhayter

hi hangover,
you don't need engineering menu to update or change maps, it is beter if you don't know
how to access it, it can brick your IPAQ 312.
The easiest way to access windows CE on these units, was to copy CE_command to games folder
of your unit, than modify registry and than installing maybe BBO.
The best way to search this forum is to use printer friendly option, top or bottom and than Edit/Search.
You don't wipe windows CE, you can wipe the internal storage, 2GB is plenty to install any navigation software.
If you find iGO8.3 version or iGO Primo, you could rename the new software to the existing name and you good to go.



I was only thinking if i wanted to hack it, but it works great as it is albeit with outdated map. I do have IGO 8.3.4 or something running on both an Acer N35 and a Ipaq 4150, so all i have to do is replace the existing IGO renaming the .exe and it should work ?
johnhayter Posted - 15 mai 2013 : 07:16:20
hi hangover,
you don't need engineering menu to update or change maps, it is beter if you don't know
how to access it, it can brick your IPAQ 312.
The easiest way to access windows CE on these units, was to copy CE_command to games folder
of your unit, than modify registry and than installing maybe BBO.
The best way to search this forum is to use printer friendly option, top or bottom and than Edit/Search.
You don't wipe windows CE, you can wipe the internal storage, 2GB is plenty to install any navigation software.
If you find iGO8.3 version or iGO Primo, you could rename the new software to the existing name and you good to go.
hangover Posted - 12 mai 2013 : 00:45:27
Hi all, been searching for any info regarding updating the ipaq312 which led me here.
My recently acquired 312 is working perfectly but in my search to find current maps for the original nav program is coming up against brick walls. I'd be happy with just a current map but wiping the system and starting with a fresh win CE5.0 is appealing so i can then use a current version igo and ozi explorer.
I've read a few mentions of engineering mode but have no idea how you enter it or how it works.
johnhayter Posted - 12 mars 2013 : 12:15:23
Nice to "see" you too, ablbd.
When I put the SD with all the files in and pressed option 5,
nothing happened, exactly like in jfranjic case, only after pressing
second time, the message popped up "Something SD card missing or some files on the card are missing"
After that message, you couldn't update OS, when I restarted the unit, I could load OS or update eboot only opt.3, I think.
Maybe my motherboard was cursed. :-)
ablbd Posted - 11 mars 2013 : 21:27:53
Hey, nice to "see" you again.

The card issue is quite odd, never happened to me. When I experimented/debuged the tool for rewriting branding data, I had to erase/format several times the nand because, once written, it was impossible to change data without erasing. So, at the beggining, I was forced to use the format feature as consequence of eboot upgrade. As far as I remember, all went directly from card without previously using option 11.
johnhayter Posted - 10 mars 2013 : 23:44:25
quote:
Originally posted by jfranjic

I bought a new Transcend SD 2GB, formatted to FAT16 in XP copy data to root, but unfortunately device didnt recognize card. The only difference now than before when clicking options 5 it seem like it didnt accept and its always the main screen, but on other options it show the message the card didnt recognized etc. :(

edit:
second different thing :) after i click option "3.) Update Eboot" HP logo apear, but any other "...cant get my device to initialize SD card"


The same here, the only difference, when I did run opt.4 Update OS it loaded OS and then it was sitting on 100% complete.
I was trying different SD cards, from 256MB to 2GB, battery charged to 100%, on friends IPAQ, result always the same, no SD or files.
At the end I have connected the unit via USB to AtlasManager, updated the EBOOT, from there, no difference, opt.5 didnt work no SD or files missing, opt 4 worked
At the very end, maybe from desperation I have re-run option 11 and then run option 5, and now as we speek it is formatting NAND.
Thanks to ablbd I am happy again.
I had spare bricked,IPAQ 312 motherboard of my friend, my original IPAQ 312 was sent to someone in Europe. Now we have a spare working IPAQ312 motherboard, with virgin win ce 5.0, the plastic steecker is a bit dammaged but it works.
Edit
Hey ablbd the unit is so fast now, unbelievable and when you reset it it loads very quickly.
Thanks again
ablbd Posted - 31 janv. 2013 : 22:17:55
One more ideea, learned from old ipaq owners: this device doesn't work properly if the battery is weak. Additionally, it will not charge battery if OS is defective or missing. This behaviour would explain why it doesn't "see" SD, as the card have to be powered with a certain voltage in order to work. I would suggest to find a way to fully charge it's battery from a 4,1-4,2V external source. I remember that after receiving the dump, my first action was to connect (in an improvised way) the battery to the Li-Ion charger of my phone's second battery...
jfranjic Posted - 31 janv. 2013 : 10:38:02
I bought a new Transcend SD 2GB, formatted to FAT16 in XP copy data to root, but unfortunately device didnt recognize card. The only difference now than before when clicking options 5 it seem like it didnt accept and its always the main screen, but on other options it show the message the card didnt recognized etc. :(

edit:
second different thing :) after i click option "3.) Update Eboot" HP logo apear, but any other "...cant get my device to initialize SD card"
ablbd Posted - 26 janv. 2013 : 23:03:23
Some devices don't like micro-card + adapter combination. Use instead a standard <2GB SD. Useless to try with SDHC!
jfranjic Posted - 26 janv. 2013 : 09:06:32
Hi all.
I also play with devil number 11 :) 2 years ago. I always thought i will find a way or someone will find a way to fix it. Damn i was happy to see post from ablbd.
And damn i was sad i cant get my device to initialize SD card. So i stuck at first step.
Device: HP Ipaq Travel Companion 316
I use 2gb SanDisk micro card + microSD adapter = formated like u said in windows xp (FAT) = no luck
then i try with SanDisk SDHC 4gb repartition to 2/2 formated on FAT = no luck
i also try with sdfmt3_1 in windows 7 and xp but = no luck

so any ideas suggestions ????
cheers


GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 0,52 seconds. Powered By: Snitz Forums 2000 Version 3.4.05