Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2264




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 MioPocket 4.0 (Unlock for GPS devices)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 190

Chief Cheese

Australia
6 Posts

Posted - 07 nov. 2010 :  11:04:22  Show Profile  Reply with Quote
Hello again all...

Just an update on my various attempts to solve my problem!

Please see above two posts for my issue (stuck on "Welcome To Navigation System" screen when I choose Navi(GPS).

Ok - so what I now understand is that the radio, dvd, dvb-t etc are quite seperate from the Navigation system which is the hardware that MioPocket runs from (correct me if I have this wrong).

I have tried a number of fixes all based on installing some sort of update software on the base directory of an SD card and then trying to run them from the GPS SD card slot on the unit.

I have tried both the reset on the front of the unit (pen tip push button) and also disconnecting from the power all together.

In another thread on the forums a member (Zygo10) managed to ressurect his unit (which is almost identical) http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=123171&whichpage=6 but this didn't work for me either.

I have spoken further with the distributor from China about my issue but they prefer me to go through the Ebay seller at this point (who hasn't replied......) Hoping to get some sort of manufacturer restore? Maybe I'm being too hopeful...

End result for me so far is the same "Welcome To Navigation System" screen that has no exit option.

My unit is - http://www.alibaba.com/product-gs/305962533/2_DIN_Car_DVD_GPS_DVD_DVB_T_7_TFT_LCD_16_9_panel.html

Looking forward to any suggestions as at this point!!!

Cheers From Australia...
Go to Top of Page

van

Australia
22 Posts

Posted - 07 nov. 2010 :  12:03:33  Show Profile  Reply with Quote
@Chief Cheese!
Chinese double din has 2 halves,main dvd,tv, ect...,you can not unclock copy or replace anything on this side, but on the GPS side you can do anything to unclock it (change logo boot-up main menu display on GPS and install Miopocket mini or full version).I bricked my unit 4 or 5 times, anytimes bricked, i use right firmware ressurected,the firmware i got from Chinaversion, because i bought unit dirrect from them (but my device difference from yours), so I think better ways,you ask distributor from China give you GPS upgrade software, if you get right firmware your problem will be solve easy.


Go to Top of Page

bumbum

519 Posts

Posted - 07 nov. 2010 :  16:04:51  Show Profile  Reply with Quote
Osprey,

I have problems with the new release. First I copied over the existing release. After startup Menu nothing happens anymore. Then I decided for a complete new installation. Now "Fatal Application Error" ==> TaskMgr.exe and I recocnized that Mortscript isn't started, when I start Mortscript manually, everything seems to work OK, clicking mscr files is working, but I still can not see Mortscript.exe in Taskmanager.

Edit:

Also dot NET isn't working

Falk F8, only used for real car Navigation, Miopocket Rel. 5? installed / Becker 7928 test device for car and writing desk, always newest Miopocket version / Medion 4435 only test device on writing desk, always newest Miopocket version / Often others

Edited by - bumbum on 07 nov. 2010 22:30:57
Go to Top of Page

aiolos

26 Posts

Posted - 07 nov. 2010 :  20:45:57  Show Profile  Reply with Quote
Hello Osprey and thanks for the new version.
I'm having a problem with the task manager. None of the black buttons show when I choose an option so I can't close it and I have to hard reset. I was having the same problem in August and I talked with you and task manager's creator and after a few emails we found a solution. He said he'd implement it in v.3.4 but that hasn't come out yet.
For some reason the problem went away with the previous (2 I think) versions of miopocket, but now it's back. I checked and I can't see any differences with task manager between v66 and v67 so I can't figure out what made the problem go away in the first place, and come back with this version. Any ideas ?

Navigon 8110, 480x272
WinCE 5.0, SIRF Star III
CPU 533MHz, RAM 128 MB
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 08 nov. 2010 :  03:29:50  Show Profile  Visit Osprey's Homepage  Reply with Quote
Chief Cheese,
The "welcome" screen has no buttons of any kind? Have you tried disconnecting the unit from the car's power or disconnecting the car battery from the car? EDIT: Oh, I see that you now say that you have done that. Yes, you're right about these devices having two halves: one that runs WinCE and is for navigation software and the other that runs everything else (radio, music, DVD, etc.). Have you tried updating the firmware via Zygo10's link?

infoservi,
Have you tried hard reseting the device? Hold the power button in the down/off position for up to 10 seconds, then repeat to turn it back on.

mrcorn,
It sounds like you want to see section 5.17 of the Readme.

melcug,
I'm not sure. If you're already using R67, try copying MortScript.exe to MioAutoRun\Programs\MortScript.

legion89,
I don't know. Not all apps work on all devices. JB Piano seems to be one.

vmax377,
Have you tried deleting avc.plg from MioAutoRun\Programs\Media Player?

bumbum,
Try re-downloading R67 to make sure that you have the current version that I uploaded on the 4th, then try putting it on your device/card fresh again. If you do SD installation, re-formatting with Extras\Win32\SD Formatter wouldn't be a bad idea. If, after installation, .mscr files don't work (which I'm guessing is what you're saying), what is HKEY_CLASSES_ROOT\MortScript\Shell\Open\Command in the registry set to?

aiolos,
Really? I wasn't aware that it ever went away. I haven't knowingly done anything to address the problem and I've been waiting for the author's new version, same as you. This doesn't really make sense to me, but MioAutoRun\Programs\MortScript\MortScript.exe is the only thing that was different in the last two releases (uncompressed, 401KB) than it is in R67 and was in R64 and earlier (compressed, 93KB). You can try copying that file from R65 or R66 (kill all MortScript.exe processes with iTaskMgr beforehand).

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe
Go to Top of Page

Chief Cheese

Australia
6 Posts

Posted - 08 nov. 2010 :  04:33:08  Show Profile  Reply with Quote
Van - I'm waiting for the ebay seller to get back to me about getting the right firmware update/restore for my unit. The distributor in China prefers me to get it via the seller - which suits me as the seller seems to know more about MioPocket anyway!!

Osprey - no buttons on the welcome screen. I have tried zygo10s update with no success The seller said he didn't think my unit had enough flash space for Miopocket and suggested the SD Free option - i replied that i dont have access to do that anymore and am waiting for a reply - do you think there would not be enough free memory after the install?

Thanks again for suggestions!!!
Go to Top of Page

infoservi

Argentina
4 Posts

Posted - 08 nov. 2010 :  05:07:04  Show Profile  Reply with Quote
Osprey,
commented my problem, and it could not make it work the sound in my GPS try to install version 2.0 of MioPocket.
As he saw that the problem was when loading certain application registry enter registration (via miopocket) and delete entry...
From HKLM\init\ the file HookShim.exe

After this try uninstalling MioPocket 2.0 to leave menu by default that brings my GPS, after uninstalling the device restarts, then no load menu, neither displays the desktop of win ce, I cannot access the SD device, can I copy files, but does not start. Apparently this running windows ce, but missing him some input to record fails to load the menu.
the what I think by what I see, I try to connect with activesync actually in Windows Mobile Device Center, have windows 7, but does not connect with the device. I can't access the registry to restore the backup that I have it (I did a backup before delete the entry) if someone can give me a solution, I would be very grateful. Not sure if i can reinstall windows ce.... my GPS is MOX, model GM-G432, Chinese middle is generic i think.., has installed windows ce 5.0

Thanks again...
Go to Top of Page

bumbum

519 Posts

Posted - 08 nov. 2010 :  11:09:26  Show Profile  Reply with Quote
quote:
If, after installation, .mscr files don't work (which I'm guessing is what you're saying), what is HKEY_CLASSES_ROOT\MortScript\Shell\Open\Command in the registry set to?

Osprey

MioAutoRun\Programs\Mortscript\Mortscript.exe" "%1"
this should be correct, because it's the same in my other device, which works with Rel. 67

Inbetween I changed Mortscript.exe with the uncompressed version. Problem still exists.

Question:
Why is TaskMgr.exe crashing at startup? For what reason you start TaskMgr.exe?

Edit:

I changed to Rel. 66 TaskMgr. crashing at startup exists further, but Mortscript is working, so this might be two independent problems.
But why is Mortscript not working in Rel. 67, even when I changed to uncompressed version?


Falk F8, only used for real car Navigation, Miopocket Rel. 5? installed / Becker 7928 test device for car and writing desk, always newest Miopocket version / Medion 4435 only test device on writing desk, always newest Miopocket version / Often others

Edited by - bumbum on 08 nov. 2010 12:17:04
Go to Top of Page

jwoegerbauer

1865 Posts

Posted - 08 nov. 2010 :  12:37:29  Show Profile  Visit jwoegerbauer's Homepage  Reply with Quote
quote:
Originally posted by bumbum


Question:
Why is TaskMgr.exe crashing at startup? For what reason you start TaskMgr.exe?


TaskMgr is used to backup the registry:

Unlock.mscr

CallScript("RegistryBackup.mscr", "all", InstallBackupFile, TRUE)

RegistryBackup.mscr
runs modified version of Dotfred's Taskmanager 3.3.0.1, original name is TaskMgr, which is also existing

ElseIf(key eq "all")
	#Backup the entire registry
	RunWait(ProgramsFolder\"TaskMgrReg.exe", "/regxpall " & exportFile)
Go to Top of Page

aiolos

26 Posts

Posted - 08 nov. 2010 :  13:21:51  Show Profile  Reply with Quote
I thought about mortscript also by looking at the changelog, but I figured task manager is a standalone executable and wouldn't rely on mortscript. But I changed to the uncompressed version and now it works again. Strange...
Thanks

Navigon 8110, 480x272
WinCE 5.0, SIRF Star III
CPU 533MHz, RAM 128 MB
Go to Top of Page

Lieuallen

USA
83 Posts

Posted - 08 nov. 2010 :  15:48:26  Show Profile  Visit Lieuallen's Homepage  Reply with Quote
In my random wanderings I found "Batata", which is a freeware game identical to Koule. It needs only the single .EXE file (plus a script to rotate the screen), so takes less storage space. Just an alternative, if anyone is interested.

You can find it at http://www.download32.com/batata-for-pocket-pc-i68534.html

US Mio C320 (R40) with SanDisc 8GB microSDHC card; MioMap 3.3 (Jan 10 2008)
2007.07 (12M POI) maps, TTS, Jerry's Skin 20090315 with custom override and Haplo's icons
Customized MioPocket 3.0 r59
Go to Top of Page

pa3ggl

Netherlands
12 Posts

Posted - 08 nov. 2010 :  21:08:21  Show Profile  Reply with Quote
Osprey

Before following your suggestions I want to examine the problems I have. I experimented around. Now I see a installLog.txt that is not empty and is dated sep 7, 2008 (I thought I bought a new item):

MioAutoRun.mscr: Displaying the startup menu...
MioAutoRun.mscr: Running the unlock script...
Unlock.mscr: Install started at 04:31:09 07/09/2008...
Unlock.mscr: Calculating disk space...
Unlock.mscr: Adjusting the system memory division...
Unlock.mscr: Writing "Before" settings to \My Flash Disk\MioAutoRun\Backup\StartupApps.reg and \My Flash Disk\MioAutoRun\Backup\StartupApps.txt...
Unlock.mscr: Removing apps from startup...
Unlock.mscr: Writing "After" settings to \My Flash Disk\MioAutoRun\Backup\StartupApps.txt...
Unlock.mscr: Adding notification events...
Unlock.mscr: Extending the system path...
Unlock.mscr: Configuring system folders...
Unlock.mscr: Importing registry files...
Unlock.mscr: Copying files to \Windows...
Unlock.mscr: Installing drivers...
Unlock.mscr: Configuring wallpaper...
Unlock.mscr: Configuring skin...
Unlock.mscr: Configuring EuroKeyboard layout...
Unlock.mscr: Restoring CE databases...
Install Complete.
Unlock.mscr: Install completed at 04:31:41 07/09/2008 ...
Unlock.mscr: Adjusting system memory division (again)...
Unlock.mscr: Attempting to reset the device (if successful, this will be the last log message)...


Because of your question above to bubmum for the association I found in the M405: HKEY_CLASSES_ROOT\MortScript\Shell\Open\Command\Default
String value Contents for <Default>: "\Storage Card\MioAutoRun\Programs\MortScript\MortScript.exe" "%1"

\Storage Card ???

The Tree looks as:
\\Plugins________________\\\FTP
_________________________LAN
_________________________REGISTRY___HKCR
____________________________________HKCU
____________________________________HKLM
My Flash Drive
profiles
Program Files
Recycled
Temp
Windows

In HKLM\Information I found:
Default Root: \My Flash Disk
External1: \Storage card
Internal: \My Flash Disk

Perhaps here is the problem why I have to start MortScript.exe manually to make the associations?
Many thanks for every comment and help.
Huub.

Edited by - pa3ggl on 08 nov. 2010 21:28:01
Go to Top of Page

mrcorn

USA
6 Posts

Posted - 08 nov. 2010 :  23:07:14  Show Profile  Reply with Quote
Osprey

quote
mrcorn,
It sounds like you want to see section 5.17 of the Readme.

I tried all the suggestions in 5.17 and some I found in other threads and forums.
It bugs me to see the Magellan Menu since I have no use for it anymore and to have to click the lower left arrow to proceed.

Also, whats with the "OK" button? Why is MioPocket asking my permission to proced with the load?

Thank You



Go to Top of Page

Daweed

8 Posts

Posted - 08 nov. 2010 :  23:20:46  Show Profile  Reply with Quote
Hello!

I have Mio moov M400 adriatic and it is locked. If I instal Miopocket 4.0, will I can update more maps?
Please help and sorry for my english.
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 09 nov. 2010 :  07:46:59  Show Profile  Visit Osprey's Homepage  Reply with Quote
Chief Cheese,
SD-free installation means having MioPocket on the flash drive (just as SD installation means having it on the SD card), so that's a small correction to what you said. Since the MioAutoRun folder is ~113MB, that's how much free space you need on the flash drive for SD-free installation. MioPocket Mini's MioAutoRun folder, by contrast, is ~30MB, so that's an option for anyone who needs to do SD-free installation but doesn't have 113MB of free flash drive space.

infoservi,
I am having trouble understanding the translation engine that you are using, so forgive me if I misunderstand. Things to try:
1. If you did SD installation, copy MioAutoRun\Programs\Regedit.exe to MioAutoRun\Scripts\Initialize.exe and MioAutoRun\Scripts\ShellStart.exe on the SD card. Reset the device with the SD card in.
2. Create a "2577" folder on the SD card, copy Regedit.exe to the folder and rename it autorun.exe. Insert the card into the device while it is on.
3. If you have access to the flash drive of your device, copy Regedit.exe to MioAutoRun\launch.exe on the flash drive, then reset the device.
4. If you can find a Spanish-language forum where people are discussing MioPocket, you might try presenting your problem there, since they might be able to understand it much better than I am.

bumbum,
I'm not sure what's going on. aiolos mentions a similar problem that links TaskMgr.exe with MortScript.exe. It's like they have an issue co-existing. BTW, TaskMgr.exe hasn't changed in many releases, probably since R60, so replacing R67's with R66's shouldn't change anything.

aiolos,
TaskMgr.exe is a standalone app, yes, but the MiniBar covers up the important "check" ("OK") button in TaskMgr, so TaskMgr is launched via a MortScript script that kills the MiniBar before running TaskMgr.exe. That's why I suspected that maybe the issue was related to the MortScript.exe change, and it looks like it was, though I still don't understand why. Maybe it has to do with the fact that TaskMgr.exe is compressed, too. I don't know. EDIT: I have an idea. Does this TaskMgr.exe work for you with the compressed MortScript.exe?

pa3ggl,
Ah! Interesting. That's what I was looking for, whether the drive name in the MortScript path was incorrect. Yeah, it should definitely be \My Flash Disk for you, not \Storage Card. Ok, I think that I have an idea of where the problem is. Would you open up the MioAutoRun\Registry\FileAssociations.reg on your device (not the one on your computer) and confirm for me that the MortScript path still contains "Storage Card" and whether every application's app contains "Storage Card". If so to both, then the problem is with the small change that I made to FixPaths.mscr (though it checked out for me in my tests). EDIT: Ok, I think I know what the problem was. Please see my next post.

mrcorn,
I don't know what you mean by "OK button." I doubt that it's MioPocket. If you were to give more information, I could tell you for sure.

Daweed,
If you have updated maps for your built-in navigation software, you don't need MioPocket to use them. If you have some other navigation software, yes, MioPocket will allow you to run it.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe

Edited by - Osprey on 09 nov. 2010 09:19:11
Go to Top of Page
Page: of 190 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,61 seconds. Powered By: Snitz Forums 2000 Version 3.4.05