Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 1942




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 MioPocket 4.0 (Unlock for GPS devices)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author  Topic Next Topic
Page: of 190

TroNik

362 Posts

Posted - 18 août 2010 :  07:10:05  Show Profile  Reply with Quote
quote:
Originally posted by bumbum

Osprey, Tronik
However I was not able to link ctlpnl.exe to the Miopocket cpl folder. Would you please help me?

quote:
Originally posted by Osprey
bumbum
I don't think that TroNik would've programmed his ControlPanel.exe if he knew of a way to use ctlpnl.exe with different paths.


The problem with windows's ctlpnl.exe is that it doesn't support spaces in the path. Try my RunControlPanelApplet.exe instead.

http://iphonetoday.googlecode.com/
Go to Top of Page

peter-gm

10 Posts

Posted - 18 août 2010 :  07:37:50  Show Profile  Reply with Quote
Osprey said: "I've really never heard of a manufacturer including a button to go to the CE shell, so I don't know anything about this (and certainly couldn't have knowingly made MioPocket mess with it)."
fyi, my Travelpilot 300 has a "Shell" button, see post #1 here
Go to Top of Page

dexex

United Kingdom
13 Posts

Posted - 18 août 2010 :  08:47:11  Show Profile  Reply with Quote
quote:
Originally posted by Osprey


dexex,
1. ...so you'll see the installation screen after every hard reset (or shutdown).


Now you see, that doesn't happen on my device. After every "hard reset" or "shutdown", it just goes into the iphone shell. Something strange is going on here!

Navigon 4350/6310 | CE 6.0 | Navigon 7.4.6 | iGO Primo | MioPocket 4.0 R61
Go to Top of Page

Maximus9

Romania
53 Posts

Posted - 18 août 2010 :  09:24:02  Show Profile  Reply with Quote
quote:
Originally posted by Osprey
Maximus9,
3. Since you said nothing about half of the games not working, it must be because MioAutoRun\Programs\PRuler.mscr has slightly different code. I've just changed it to the same as the games. You can test by replacing the lines in that script with:
ScriptsFolder = "\" & Part(SystemPath("ScriptPath"),"\",2) \ Part(SystemPath("ScriptPath"),"\",3) \ "Scripts"
CallScript(ScriptsFolder\"OrientationToggle.mscr", SystemPath("ScriptPath")\SystemPath("ScriptName")&".exe")
5. RunOnPowerOn tells CE to run the given application when the device is powered on. You said that you need to turn the backlight on each time the device is powered on, so that's what that line is doing. The While loop should be executing, but you might not know it if that path to iGO is incorrect. Also, I'm not sure that PowerOff works on these devices. You might be better off running the off.exe in MioAutoRun\Programs. For that matter, I don't think that RunOnPowerOn does, either. Maybe your device supports these commands when mine and others don't, though. Finally, if you happen to have "ErrorLevel("off")" at the top of the script, putting a # sign in front of it will un-suppress errors, maybe pointing out a syntax error or something.


3.Halh of the games are not working, yes, including freecell, that worked if I tried it before installing miopocked, could it be coredll or aygshell? At lot of games, the screen gets black then returns to the interface with no error message. Replaced all content of OrientationToggle.mscr but same.
5.PowerOff comand works on Sony, and ErrorLevel is not set to off, I tested and errors are displayed, but there are no errors. Igo.exe is executed and then device powers off, then restarts ok (the screen gets lighted up). But if I change igo.exe to something else, it is not getting lighted up. This device is a major pain.
Also, if I run navigation from miopocket I get errors (cannot find "igo.exe" or one of it's components), if I run them without miopocket, they run fine. That error comes from a DLL missing usually. Even TotalComander gives errors when performing a task like renaming a file or trying to edit a file, though tested and they work without miopocket.
In the example above, igo is executed, then poweroff, when device powers up the first line is while(true), then igo.exe, right? How can a line outside the while-end be executed, even if that line is the RunOnPowerOn command? I tried to find info on mortscript, but not a lot of info about commands in english.
6.Off.exe also works well, and it returns from standby ok, with those line of code added.

Edited by - Maximus9 on 18 août 2010 09:32:29
Go to Top of Page

malamenchi

Spain
12 Posts

Posted - 18 août 2010 :  10:10:35  Show Profile  Reply with Quote
wow!
To Osprey: It has been long since I did not check for updates (I was happy with release 51 and the modified variables.mscr files provided, but my SD card got corrupted, so I came back and saw last release. It is really impressing, I loved the new interface, and also even if I do not find it useful, built in MioMap launches perfectly, which gives an idea on the robustness of this release. Congratulations.
The only issue that I have with it is that again, the bluetooth does not work. The trick was done in release 51 with a modified variables.mscr file, i tried last release with the old variables.mscr file with no success. The problem is that Miomap launches 2 BT processes and when MioMap is closed, those get closed too:

Bluetooth processes are
\Program Files\MioBT\MioBT.exe
\Program Files\MioBT\MioBTCore.exe

MioMap process seems to be:
\Program Files\Navman\SmartST_CE\SmartST_CE.exe

Do you think that there is a way in which when miopocket launches it kills the miomap process, but not the BT processes? (That is what I obtained somehow via the modified variables.mscr files in release 51).

Thanks and keep it up!

Mio Moov 560 EU + MioPocket 3.0 (Release 51 on SD)

Edited by - malamenchi on 18 août 2010 15:43:55
Go to Top of Page

Janne

Sweden
92 Posts

Posted - 18 août 2010 :  10:41:15  Show Profile  Reply with Quote
Osprey
I did a fresh install of MP61 with
- Tronik's Mortscript 4.3b15
- Explorer from MP61
- Powerbutton.ini from R59
As long as power is on most things work, one question
that may have been answered before is when selecting
keyboard from minibar all I get is a box saying Show input panel?
Then, disconnect power or just plain power off, when powering on
the SD-card is no longer accessible.
I also tried doing the same thing on MP59 and it works OK.
Update:
removed

C710, Wince .Net 4.2 Core
ROM Version R37F.3.112.1201
Sandisk Ultra II 2GB

Edited by - Janne on 18 août 2010 21:38:12
Go to Top of Page

KhaKev

385 Posts

Posted - 18 août 2010 :  11:04:59  Show Profile  Visit KhaKev's Homepage  Reply with Quote
Osprey,
For SD-Free install, I'd like to request an option to switch path of Media folder from Internal Flash to SD. It's like to have an user's preferred Media folder path in MioPocket.ini. A prompt to ask the user where Media folder to reside during the install phase of SD-Free would be nice. The reason is with SD-Free most of our data (maps, music, video, etc) will be on SD card. Thanks in advance.
Go to Top of Page

bumbum

519 Posts

Posted - 18 août 2010 :  11:36:49  Show Profile  Reply with Quote
quote:
Originally posted by Maximus9

quote:
Originally posted by Osprey
Maximus9,
3. Since you said nothing about half of the games not working, it must be because MioAutoRun\Programs\PRuler.mscr has slightly different code. I've just changed it to the same as the games. You can test by replacing the lines in that script with:
ScriptsFolder = "\" & Part(SystemPath("ScriptPath"),"\",2) \ Part(SystemPath("ScriptPath"),"\",3) \ "Scripts"
CallScript(ScriptsFolder\"OrientationToggle.mscr", SystemPath("ScriptPath")\SystemPath("ScriptName")&".exe")
5. RunOnPowerOn tells CE to run the given application when the device is powered on. You said that you need to turn the backlight on each time the device is powered on, so that's what that line is doing. The While loop should be executing, but you might not know it if that path to iGO is incorrect. Also, I'm not sure that PowerOff works on these devices. You might be better off running the off.exe in MioAutoRun\Programs. For that matter, I don't think that RunOnPowerOn does, either. Maybe your device supports these commands when mine and others don't, though. Finally, if you happen to have "ErrorLevel("off")" at the top of the script, putting a # sign in front of it will un-suppress errors, maybe pointing out a syntax error or something.


3.Halh of the games are not working, yes, including freecell, that worked if I tried it before installing miopocked, could it be coredll or aygshell? At lot of games, the screen gets black then returns to the interface with no error message. Replaced all content of OrientationToggle.mscr but same.
5.PowerOff comand works on Sony, and ErrorLevel is not set to off, I tested and errors are displayed, but there are no errors. Igo.exe is executed and then device powers off, then restarts ok (the screen gets lighted up). But if I change igo.exe to something else, it is not getting lighted up. This device is a major pain.
Also, if I run navigation from miopocket I get errors (cannot find "igo.exe" or one of it's components), if I run them without miopocket, they run fine. That error comes from a DLL missing usually. Even TotalComander gives errors when performing a task like renaming a file or trying to edit a file, though tested and they work without miopocket.
In the example above, igo is executed, then poweroff, when device powers up the first line is while(true), then igo.exe, right? How can a line outside the while-end be executed, even if that line is the RunOnPowerOn command? I tried to find info on mortscript, but not a lot of info about commands in english.
6.Off.exe also works well, and it returns from standby ok, with those line of code added.




Maximus9,

Try this download http://www.mediafire.com/?sqtbpfc1nnptvqm.
Please bring back your device into complete original condition, so that original Navigation Software works. Than change nav-u.exe in nav-u_orig.exe and copy my files to Mounted Volume and Memory Stick. The trick of this download is, if Memory stick including Miopocket is plugged in, it will run Miopocket, if not Original Navigation will run. Reason why I had programmed that way: Original Navigation is very old, very old maps and no more support from Sony, but it's the only Software, where TMC is working on this device. GPS Signal for other Software like iGO is working on this device with some tricks included in my scripts, but then original Navigation SW will not find GPS under Miopocket. So the best was to run both independently. The Miopocket Version included into this download is old, something like R4X, but as I remember, most of the stuff like games worked, cause I have modified with some aditional dll's, patched with execheck etc. So I propose to you, try this old version, then update to new R61 and change step by step content of the (programs, games) folders.

Osprey,
this patch should be good for following Sony devices
Sony NV-U82/52/53/73/83/93 for other Sony devices some minor changes are neccessary in the scripts. For example

On Sony U-71T.

change in .mscr
RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 18")
RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 15")

with

RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 19")
RunWait("\Mounted Volume\Sony\nav-u\ToolDevice.exe","off 17")

Edit:

quote:
bumbum
The same idea crossed my mind the other night, coincidentally, but I quickly decided that it'd be a lot of work and hurdle clearing for relatively little improvement. If you don't mind, go for it.


I do not understand "relatively little improvement"? With a proper solution, IPT based like I described, everybody will have the same ControlPanel, with a nicer look and it's very easy to add other applets. However I have done it in the meantime, but it is not a "for everybody 1 click integrating solution" because of the described problems.
Better I present that in the Tips&Tricks Thread

http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=132727&whichpage=35

quote:
Try my RunControlPanelApplet.exe instead.


Tronik

I tried but I do not know if I did right

Run(ProgramsFolder\"TroNik\RunControlPanelApplet.exe", """\My Flash Disk\MioAutoRun\Windows\Control Panel\cplmain_coredl2.cpl,3""")

is not working

Falk F8, only used for real car Navigation, Miopocket Rel. 5? installed / Becker 7928 test device for car and writing desk, always newest Miopocket version / Medion 4435 only test device on writing desk, always newest Miopocket version / Often others

Edited by - bumbum on 18 août 2010 16:00:56
Go to Top of Page

Maximus9

Romania
53 Posts

Posted - 18 août 2010 :  18:13:30  Show Profile  Reply with Quote
Bumbum
Thanks a lot. Do you know ANY method to make BlueTooth work ? How about TMC ?
I must say MP3.0 R59 works well, just added this 3 lines in PowerOff.mscr and all is ok after standby:
Run ("\Windows\TestMode.exe")
Sleep (50)
Kill ("TestMode.exe")

Go to Top of Page

bumbum

519 Posts

Posted - 18 août 2010 :  19:13:08  Show Profile  Reply with Quote
Maximus9,

I don't believe you solved "all" your reported problems, by adding these lines to PowerOff.mscr.
Testmode.exe was extra programmed from a spanish guy to let Backlight working on 100%. Read this from another board

quote:
# If I'm going to throw the script "PowerOn.mscr." This script is to run "TestMode.exe" and then
# close to shine again at the maximum, if not done every time you start the GPS after
# a standby screen of both the U52 and U82 are not the iluminarian, would remain in black.


A better way would be to insert this to unlock.mscr, but I'd tried that all, this Sony is a nice Hardware with a totally crippled WinCE 4.2 Software.
Why don't you follow my suggestions and install my upload?

To answer your questions: No way for Bluetooth or TMC. The only chance I see (Not tested), to install an old and slow Navigon 6.5 Software, for this you get at least actual maps.

Falk F8, only used for real car Navigation, Miopocket Rel. 5? installed / Becker 7928 test device for car and writing desk, always newest Miopocket version / Medion 4435 only test device on writing desk, always newest Miopocket version / Often others

Edited by - bumbum on 18 août 2010 19:14:03
Go to Top of Page

Maximus9

Romania
53 Posts

Posted - 18 août 2010 :  20:13:55  Show Profile  Reply with Quote
Bumbum,
Thanks, but PowerOn.mscr consists exactly of those 3 lines, so no need for an extra script. All that is needed is those 3 lines in MP's PowerOff.mscr script. You could add them to Unlock.mscr (I did that) but it is not required. Did that solved all problems? Yes, TimeSync=0 and those lines, AND the fact that I switched to MP 3.0 R59. I can run a lot more applications, including navigations that didn't work under MP4. Freecell is not working, but this is the strangest .exe file ever, I tested it on about 20 deviced until now and it works in 50%, still cant find why.
If analized with CFF Explorer VII it reveals under "Data Directories" an entry with INVALID written on it on RED background.
Unfortunetly, I dont know what that means and how it can be fixed, maybe Osprey or Tronic could explain more.

The entire nav-u.mscr script was redundant, and copied some old versions of Miopocket and toolhelp.dll to windows folder. And TestMode.exe is simply copied from another device, not some original coding, just a file used for screen calibration in some other device/model.

About BT and TMC: There is a BTVOLUME.DLL and a TMC.DLL in windows folder, but again, my knowledge is limited, although I am willing to learn how to use them.

Another question for Tronik or Osprey is this:
-so we have a device with the classic Windows folder in it, we find out using a reg editor appname.exe is launched at startup, and we want to expect that application. How can we copy that appname.exe from windows folder ? It says it is in use and cannot be copied (it cannot be stoped/killed either). Is there a way to do that?

Edited by - Maximus9 on 18 août 2010 20:15:57
Go to Top of Page

moshekatzir

Israel
1 Posts

Posted - 18 août 2010 :  23:02:57  Show Profile  Reply with Quote
I tried the miopocket 4.0 on my mio c320 Israel version according to the readme instruction with no success.

I found the following work around :
1. I copied the original miomaps SD to a new one.
2. I copied the miopocket 4.0 files to the same SD twice :
a. as instructed in the read me.
b. to the original /SD Root Directory/miomap/ directory
3. in the miomap directory I rename the miomap.exe file to miomapold.exe
4. I copy the MioAutoRun.exe and MioAutoRun.mscr to miomap.exe and miomap.mscr

5. After hard reset the mio c320 load my miopocket 4.0 properlly.

I did all the work as my mio use /SD Root Directory/miomap/miomap.exe as it's user hook/root program.
I'm sure that there is better way to do the same and copy less files.

Any advice ?

Thanks,

Moshe Katzir

moshe katzir

Edited by - moshekatzir on 18 août 2010 23:06:09
Go to Top of Page

blondemale35

10 Posts

Posted - 19 août 2010 :  01:13:05  Show Profile  Reply with Quote
Hi Osprey.
You are a legend.
Thank you very much for all of your help. I got it installed and all working fine.
I have a Chinese 7"GPS and Miopocket runs great so far. Do you know anything about these GPS units. Mine is not a YF system
and I would love to change the original boot screen to something better looking.
I really do appreciate all of your help.
Keep up the great work as we all appreciate your knowledge.
Regards Greg
Go to Top of Page

Osprey

USA
2764 Posts

Posted - 19 août 2010 :  06:03:47  Show Profile  Visit Osprey's Homepage  Reply with Quote
bsweeny,
I don't know what you're referring to. No one is reporting the wide range of problems that you are. As I said, I think that either you're not running MioPocket correctly (follow the Readme) or it's because your device is severely crippled. Either way, there's not much that I can do.

fsolanes,
The only thing that I can think of is that the "shell" menu button might've been set to run explorer.exe (Windows Explorer), but MioPocket doesn't replace that. Oh, wait a sec, there's a bug that I fixed last week that affected Explorer in CE6 and caused it to crash. Copy the following to MioAutoRun\Registry and either run it (ex. from a file manager or "Run" on the start menu) or re-install MioPocket: FileAssociations.reg
(BTW, thanks for the info and link, peter-gm)

dexex,
In that case, either it's not really doing a hard reset (but a soft reset, instead) or your device has a persistent, hive-based registry. I forget what device you have, but, if it's CE6, then the latter is a strong possibility. With such devices, the registry is actually written to disk, so changes to the startup sequence (which includes the call to the MioPocket shell) are preserved, even across hard resets. If that's the case and you need to re-install MioPocket, you can delete the HKEY_LOCAL_MACHINE\SOFTWARE\MioPocket key in the registry, the existence of which determines whether MioPocket is installed or not.

Janne,
1. Your device must be missing something required for the software input panel (SIP). I wouldn't know what. You seemed content with the workaround that I gave you before, though.
2. Are you waiting at least 10 seconds before pressing an icon. With SD installation, you need to give the card some time to become available again.

KhaKev,
Ok. Note that, really, you can do that already. It's just that the 3 or 4 apps that default to the Media folder will require you to manually select the new location, instead. I understand that you'd like that automated, though, which sounds doable.

bumbum,
That's not a "patch"; it's 86MB large, as large as MioPocket, itself :). Maybe you meant a different link...?

Maximus9,
You or bumbum can correct me if I misunderstand, but I think that bumbum's point is that TestMode.exe does not come with the Sony or with MioPocket (i.e. you added it yourself, either individually or in a different 3rd-party unlock/utility), so those three script lines of yours are not enough for most people.

moshekatzir,
If you happen to mean that you copied the MioAutoRun folder to the MioMap folder and/or copied the three files to root fo the card, delete them, since they're not being used and are just wasting space. For your situation, all that you need is the MioAutoRun folder in the root of the card and the three files (MortScript.exe and MioAutoRun.exe and MioAutoRun.mscr renamed) in the MioMap folder. I've added this information to the Readme. Thanks.

blondemale35,
Sorry, I don't know enough about that system to know how to do that.

Mio C320 (US), R40 firmware, WinCE 5.0 Core, MioPocket 4.0 Release 68
Latest MioPocket: MioPocket 4.0 (Release 68) - Dec 6, 2010 & ReadMe
Go to Top of Page

Maximus9

Romania
53 Posts

Posted - 19 août 2010 :  07:18:16  Show Profile  Reply with Quote
quote:
Originally posted by Osprey
Maximus9,
You or bumbum can correct me if I misunderstand, but I think that bumbum's point is that TestMode.exe does not come with the Sony or with MioPocket (i.e. you added it yourself, either individually or in a different 3rd-party unlock/utility), so those three script lines of yours are not enough for most people.


Yes, you are correct, I already said that TestMode.exe is from another device/model. As there is only one way to unlock Sony NV (using that script), I was reffering that those 3 lines are all that is needed for installing MioPocket and getting back from standby succesfully. So the long script that BumBum posted is always needed (but improved a little), but for MioPocket part, just those 3 lines are ok, I tested it and all reported problems disappeared (BUT using MP3.0 R59). I am not going to try R61 again on this device, as it appears the CE4.2 is very crippled.
Can you please tell me if you can give me a helping hand with these (out-of-topic) issues:
There are some BTVOLUME.DLL and a TMC.DLL in windows folder, but again, my knowledge is limited, although I am willing to learn. Any ideea how to use them?
Another question for Tronik or Osprey is this:
-so we have a device with the classic Windows folder in it, and we find using a reg editor that appname.exe (or BTvolume.dll or tmc.dll from above example) is launched at startup, and we want to inspect that application using a flex editor or a resource hacking tool and so on. How can we copy that appname.exe from windows folder ? It says it is in use and cannot be copied (it cannot be stoped/killed either). Is there a way to do that (to get that file on our HDD and be able to open/edit or whatever)?

Edited by - Maximus9 on 19 août 2010 07:21:14
Go to Top of Page
Page: of 190  Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 1,28 seconds. Powered By: Snitz Forums 2000 Version 3.4.05