Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2264




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Handheld Portable GPS Receivers
 Garmin Geko 201 date/time issue
 New Topic  Reply/Répondre
 Printer Friendly
Author Previous Topic Topic Next Topic  

andylsun

USA
2 Posts

Posted - 17 janv. 2010 :  15:28:52  Show Profile  Reply with Quote
I used my Garmin Geko 201 for the first time for a couple of weeks yesterday, and noticed that all my track data after importing to my mac reported 1990 rather than yesterday's date.

It appears now that the GPS has hit some kind of date (or 2010) related software bug. Every time it's powered on it goes through a cold start, and then either reports the date as 1990 or 2029. This is after performing a factory reset, and leaving it in normal (not WAAS mode).

Googling around, this could indicate that it's lost the almanac, and is having to start from scratch every time it's powered on (the fact that the year is wrong by 19 years may a clue). I'm going to call Garmin on tuesday and find out if they know about this and have a potential fix. Surprisingly, the unit is still for sale at garmin.com.

I carry it skiing, so the fact that it's small, light and pretty much bombproof are great plusses.

There's only one other thread on another forum that reports the same issue, but was wondering who else is seeing this.

My unit is running the latest software (2.70).

Ads


pavel

2 Posts

Posted - 19 janv. 2010 :  13:22:41  Show Profile  Reply with Quote
I'm having exactly the same problem you're reporting.
It happened first on Jan 16; but it was ok on Jan 10.

I thought my firmware was damaged, so I reinstalled it (2.70); but the problem is still there :(

continued : I was wrong; all my tracks in 2010 have wrong time.
Last correct track dates back to 29th Dec 2009.
Go to Top of Page
Go to Top of Page

pausch

Sweden
3 Posts

Posted - 20 janv. 2010 :  22:09:13  Show Profile  Reply with Quote
I too experienced the same problem with my Geko 201: the date is now *sometimes* correct but usually it's wildly wrong. Today I turned it on 3 times: the first time it said the date was 2010-01-20 (the correct date). The second time it said the date was 1988-07-21 (exactly 1122 weeks into the past) and the third time it said 2008-03-06 (exactly 98 weeks into the past). Note that 1122-98 = 1024, the GPS week counter rollover period.

I first noticed this in last Sunday, 17 jan 2010. My last track with all correct dates was from 5 jan 2010.

I too upgraded my firmware, from ver 2.50 to ver 2.70, but that didn't help.
Go to Top of Page

andylsun

USA
2 Posts

Posted - 21 janv. 2010 :  03:39:17  Show Profile  Reply with Quote
I contacted Garmin (by phone they were not very helpful, but much better via email) and they've sent me a time/date fix to try. It's a windows binary, so wonder what it changes on the unit (and they've said it's not new firmware). I'll try it on my unit and let you know how I get on.

Update: The software was called Garmin Time Set and is supposed to send the current date and time to the unit. When I tried it, it still returns an incorrect date/time.

Garmin Time Set thinks the GPS thinks it's 1992, but the LCD display now reports 5th December 68 (but not sure if that's 1968 or 2068)


Edited by - andylsun on 21 janv. 2010 04:08:42
Go to Top of Page

pausch

Sweden
3 Posts

Posted - 21 janv. 2010 :  15:44:18  Show Profile  Reply with Quote
I believe new firmware is necessary in the Geko 201 to fix this bug. Whenever I turn on my Geko 201 now, it usually "thinks" the date is different from the actual date, often jumping back and forth between off/on cycles in steps of exactly 1024 weeks. The discrepancy from the actual date can be different from 1024 weeks though, but seems to always be an integral number of weeks. Occasionally my Geko 201 still "guesses" today's date correctly, but usually it doesn't any more.

Today (21 Jan 2010) is a Thursday. 5 Dec 1968 was also a Thursday, while 5 Dec 2068 will be a Wednesday. Therefore I'm quite certain your GPS meant 1968 when it reported the date as "5 Dec 68".

Even though my Geko 201 shows wildly incorrect days now, it still shows the time-of-day correctly. The longitude and latitude reported by my Geko 201 also seem to be correct.

Edited by - pausch on 21 janv. 2010 15:47:59
Go to Top of Page

fir99

2 Posts

Posted - 27 janv. 2010 :  22:19:46  Show Profile  Reply with Quote
I think it would be an good idea if as much concerned users as possible report the problem to Garmin. On the one hand Garmin then will more probably conclude that this isn't a very rare problem but it is worth to develop an firmware update to tie the customers and on the other hand more serial numbers (see battery case) will help the engineers to narrow the root cause of the problem. Filling out the contact form for the customer support does only cost a few minutes:

http://www.garmin.com/garmin/cms/home/support/supportcontact

Regards,
Bernhard
Go to Top of Page

pausch

Sweden
3 Posts

Posted - 28 janv. 2010 :  22:24:20  Show Profile  Reply with Quote
A very good idea to have as many as possible with this problem report it - I did so earlier this evening.

The shareware program GarTrip ( http://www.gartrip.de ) fails to read tracks acquired by GarTrip if the erroneous date is before the year 1990 - then the Garmin time counter reaches a negative value which GarTrip cannot handle. I've been corresponding with the author of GarTrip about this, and now he's made a fix to this problem which will enable GarTrip to load tracks from buggy Geko 201 units. The fix will be present in the soon-to-be-released version 2.10c of GarTrip: an extra popup menu appears when obviously buggy time data is read from a track (either a negative time count, or a date more than 1 year into the future), and the user will be asked for the correct date if known - then the time data is corrected by adding or subtracting an even multiple of 86400 seconds (one day) to the time data. This should fix the broken time data in a track from a buggy Geko 201.
Go to Top of Page

fir99

2 Posts

Posted - 13 févr. 2010 :  17:39:37  Show Profile  Reply with Quote
Meanwhile Garmin informed me that they reported the problem to the development department. They intend to provide a new firmware update but can't tell when it will be available. The update will be announced via the service newsticker (http://news.garminservice.de/).

Regards,
Bernhard
Go to Top of Page

KCCjr

USA
1 Posts

Posted - 21 févr. 2010 :  21:28:01  Show Profile  Reply with Quote
I too, have had the same time/date problems. I contacted Garmin Support, they sent back a Windows binary called Garmin Time set. It correctly displayed the firmware version. However, it did not correctly apply the time (as andylsum described above). In fact, the time reported back to the program was not the same as the weird one on the Geko 201 display. Garmin mentioned creating an RMA for me, but I have yet to see if they "fix" the problem for free or not. They did not mention any new firmware update. I found other discussions as well (of which some of you are participants):
http://forums.groundspeak.com/GC/index.php?showtopic=239205
http://groups.google.com/group/alt.satellite.gps.garmin/browse_thread...

Cheers,
Chuck

Edited by - KCCjr on 21 févr. 2010 21:59:43
Go to Top of Page

john8412

United Kingdom
2 Posts

Posted - 28 févr. 2010 :  21:37:04  Show Profile  Reply with Quote
The same thing has happended to me - just in 2010

Thanks for the useful info - hoping Garmin come up with a fix.

John
Go to Top of Page

john8412

United Kingdom
2 Posts

Posted - 04 mars 2010 :  00:11:39  Show Profile  Reply with Quote
Here's teh response from Garmin:

Thank you for your response.

I have investigated your query further and found this is a known issue.
A software update is due to be released shortly and the update will be
downloadable from the link below to resolve the issue: -

https://buy.garmin.com/shop/store/downloadsUpdates.jsp?product=010-00318-00&cID=144&pID=220


John
Go to Top of Page

cambsrambler

United Kingdom
1 Posts

Posted - 03 avr. 2010 :  16:29:03  Show Profile  Reply with Quote
I have had this problem with my Geko 201 (wildly inaccurate date and very slow satellite acquisition). However all is now resolved as Garmin have just issued a new software update (v 2.90). I have installed it and both these issues now seem to be resolved..

Just go to the Garmin website and use the webupdater.

Cambsrambler
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 0,62 seconds. Powered By: Snitz Forums 2000 Version 3.4.05