Google
  Web www.gpspassion.com


GpsPasSion LIVE!
www.flickr.com
This is a Flickr badge showing public photos from GpsPasSion Live !. Make your own badge here.

www.NaviBlog.com



Versions

Links/Liens




Portal/Portail
Rechercher

- -

Polls/Sondages
Sondage
Pour vous guider sur la Route :
GPS Mobile (SEM)
GPS Intégré
Smartphone
Autre
Voter  -  Résultat des votes
Votes : 2248




Club GpsPasSion
Soutenez le site!

USA: (US$)
EUROPE: (€)
Guide Paypal


GpsPasSion Forums
Home | Profile | Register/Enregist. | Active Topics | Search/Recherche | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 English Forums - Hardware
 Mio AIO Forums - www.mionav.com
 How to upgrade/downgrade the firm. on Mio (Moov+C)
 New Topic  Reply/Répondre
 Printer Friendly
Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 167

jvdp

Australia
10 Posts

Posted - 10 nov. 2010 :  06:16:17  Show Profile  Reply with Quote
You are a champion, started up fine no error!
Go to Top of Page

g_alin

USA
817 Posts

Posted - 10 nov. 2010 :  18:26:10  Show Profile  Reply with Quote
jvdp,
Thank you for your feedback ... I update the link on the first page too ...
Go to Top of Page

zdarova

Italy
4 Posts

Posted - 12 nov. 2010 :  03:46:21  Show Profile  Visit zdarova's Homepage  Reply with Quote
Hi, I lost my self in firmwares, boot and hard reset.
My aim is to make work my Italian c250 plus with some updated maps.
I just recovered my Mio with the DVD so I would like to ask you guys that is best to do :D


1. someboby who has the 2008 maps, does it have the track option (long vehicle) compare as on 2006 does?
2. what are the newest maps for Mio c250? on the Mio webside I didn't found that info
3. Alin_g, please can you explain (or link me some guide) of the benefit of updating the rom?
4. I saw that somebody is using Garmin on Mio with Mio Pocket, ho is it works, what version of Garmin XT is better (supposing I will buy it)
5. What versione of Mio Pocket is better for c250 plus? I tried the last, trying all day long but after it restart, the main screen is freezed :| (made all the adviced from the guide and nothing)




thank you !!! :)

PS: I see alin is one of the "guru" for the Mio :D

Edited by - zdarova on 12 nov. 2010 03:51:12
Go to Top of Page

GROMM

France
56 Posts

Posted - 15 nov. 2010 :  15:10:01  Show Profile  Reply with Quote
@ g alin

GROMM,
"1 - It is necessary to before Uboot up grade ? "
don't play with UBOOT ... you'll brick your device ...
If you have CRC error with so many firmwares I would say that you use a defective SDCard (or you GPS is not reading right the SDCard) ... Or you have an internet connection with many errors ...
"Can we get good files for MIO C710 or Mio C510 ?"
(My opinion is: ) All of those files are OK; You are the first user reporting CRC error to several firmwares. I don't think there is problem with the firmware (some of theme where downloaded more than 100 times...)
"I have also teted a file ENG EU NL R34F 311 2928 you had get to redyak 27/08/2010 on this paper with same result : "checkSum error"."
He used those file ... don;t you think is strange that only you have that problem? ... change the SDCard ....

Thanks for your response.

My SD card was in default
I formatted SD card and the first test was correct with ROM file.
and I installed IGO8 and Mio is OK.
THANKS
GROOM

GROMM (Lyon France)
GPS Passion Depuis 2006
MIO C710 non débridé
IGO 8 3 ...... de 2009
R33F.X.XXX.XXX
Skin CHOUP 6.3
Go to Top of Page

g_alin

USA
817 Posts

Posted - 15 nov. 2010 :  18:14:39  Show Profile  Reply with Quote
zdarova,
"3. Alin_g, please can you explain (or link me some guide) of the benefit of updating the rom? "
The only version we have are:
C250_Plus_EU (R11.3.0160.1107) http://www.4shared.com/file/134361154/73ee2da3/C250_EU_ROM_R11301601107.html
C250_Plus_EU (R17.4.0160.0917) http://www.4shared.com/file/143885453/7eb69489/C250_EU_ROM_R17401600917.html (better option than R11.3)
"better option" = Have more wince components (more unlocks will work - if you have more components).
If you want to have 'only a GPS' -> both are working very well with navigation software.

GROOM,
welcome.
Go to Top of Page

zdarova

Italy
4 Posts

Posted - 15 nov. 2010 :  20:47:18  Show Profile  Visit zdarova's Homepage  Reply with Quote
@ G_alin, multumesc (thanks)

where in US?
Go to Top of Page

EnemyNr1

4 Posts

Posted - 15 nov. 2010 :  22:28:46  Show Profile  Reply with Quote
G_alin hallo,

I have Flash my Mio Moov 370 with a second (more complicated option) that will help you to recover is JTAG recovery.
i have a problem with GWES error.
I using SJF2443_Mio.exe with boot_patch.bin, but i can not see orage screen and uboot screen. I see nothing!

If i see NoICEARM, i see just ????????????? ADR 000, ?????????? ADR 0004 ,.....

i think, i need (With srelioskoz help we have a recovery method also for MOOV series.)!!!!!!!

I need your help.!

Edited by - EnemyNr1 on 15 nov. 2010 22:30:42
Go to Top of Page

ablbd

358 Posts

Posted - 15 nov. 2010 :  23:44:43  Show Profile  Reply with Quote
EnemyNr1, I don't know what was wrong with your moov but now I'm pretty sure that you killed the bootloaders. That particular boot_patch is for certain C series devices and definitively not for moovs...
For the time being the only solution is to dump via jtag from a working one the first 6 blocks (ca 1,5MB) and flash that dump in yours; question is who will do this?
Go to Top of Page

sonycam

Croatia
21 Posts

Posted - 17 nov. 2010 :  18:11:17  Show Profile  Reply with Quote
hello g_alin
it is me again whit my c620
dont know how but I can only start miopocket when I put USB cable in and klick run mio pocket.
maybe when You remove luncher.exe from image will work fine.
when I delete luncher.exe and make softreset it works evrything
Go to Top of Page

g_alin

USA
817 Posts

Posted - 18 nov. 2010 :  21:41:14  Show Profile  Reply with Quote
sonycam,
When you insert the SDCard the GPS initiate a restart procedure ... that's perfectly normal ....
Launcher.exe does many hardware initialization ... strange behavior can be explained by that.
Go to Top of Page

sonycam

Croatia
21 Posts

Posted - 19 nov. 2010 :  20:26:38  Show Profile  Reply with Quote
well in that way I wont change a thing,but problem is when I am somewhere on trip and run off battery power and dont have USB conection.....but wont let that happen :))

thanks g_alin
Go to Top of Page

ablbd

358 Posts

Posted - 29 nov. 2010 :  22:53:39  Show Profile  Reply with Quote
A Moov330/N179 is still laying on my desk as I couldn't find nboot/uboot for it. After some digging and testing I found a program (s3c2443_nr.exe, http://www.megaupload.com/?d=S5B4KQLP ) which is able to copy physical nand blocks. Should be executed from SD card and because bootloaders are not longer than 1,5MB, it can be stopped at 1/5 of the total size by simply reseting the device. If everything is OK, before pressing the "save" button you'll see the full nand ID of K9LAG08(EC D5 55 25 68). On SD you'll find 2 .hex files: pages.hex and spare.hex; it would be great to have both but actually I need pages.hex.

Go to Top of Page

notmee

Slovenia
3 Posts

Posted - 30 nov. 2010 :  14:06:20  Show Profile  Reply with Quote
hello to all

so I also bricked my Mio Moov M300 "Adriatic" (Balcan) by pointing paths.xml to iGO primo, and than the deveice woudn't show up as a flash drive on usb.

i already managed to ubrick it thanks to Osprey and his MioPocket project. I read in his instructions for installing MioPocket that in my case (edit of paths.xml file or AppStartupSec.exe file) the device sometimes shows up as as flash drive if you repeatedly turn it on and off while connected on the computer.

But since I already have the device open and connected to DNW (that took quite an effort), I could donate results of my efforts so far.

http://www.4shared.com/file/6MFCeqJ6/Mio_m300_pictures__flash.html

In the file you'll find some pictures of my device and a part of flash as per abdld's instructions on page 54 (0x30000000 to 0x38000000). I also plan to make a complete clone of the memory.

Bootup version of my device is R00.00.1029.64M and bluescreen version is TATA300_R02_1117 RAM64 MLC 2G. The sticker on the samsung chip has the following text: TATA 300A/E WWE R01 2G C567 and the chip itself has: SAMSUNG 943 K9GAG08U0M PCB0 YCJ118XS. (all of this can be seen on the pictures, i'm posting it here just so google can find it easier )

Also things I found out while searching for a solution:
  • Apparently there are two versions of Mio M300 (http://service.mio.com/M0100/MainFrame.aspx)
    I haven't managed to find out what the differences are and which version I have.
  • I had to edit the secusb2.inf file for windows to accepet it. When my device connected from the blue screen win found WINCE usb sync and absolutely refused to take the Secusb2 driver. So I checked in device manager under DEVICE PROPERTIES - DETAILS tab and found my device GUID. I edited the inf file and replaced all instances of "USB\VID_04E8&PID_1234" with my own device GUID. Than Win accepted the driver and DNW worked OK.
  • I belive that the flash part that I got from the device isn't full smflash image but just a part of uboot (iboot, nboot?) Maybe the he addresses are different because it isn't a regular Cobia device?


That's all I can remember now. I plan to install MioPocket on the device in the near future so I'll be able to get a real smflash image but for now I'm just happy that I got it to the original condition. Also I'll probably be busy for the next few day because I've been neglecting my studying.

Any questions or suggestions about memory range (abdld ) are welcome.

notmee

-------------------------------------------
EDIT:
This is the link to the memory range 0x00000000 / 0x40000000
http://www.4shared.com/file/tYYMoNfT/0x00-0x40.html

Edited by - notmee on 30 nov. 2010 15:31:14
Go to Top of Page

ablbd

358 Posts

Posted - 30 nov. 2010 :  18:49:00  Show Profile  Reply with Quote
@notmee
Thanks alot, it was quite interesting looking into a RAM dump. As you can easyly notice, memory 0x0 - 0x40000 is endlessly repeating, probably due to multiple memory mapping. Uboot is at 0x30000000 as it should be. Another interesting fact is that the Moov300 I dumped (on jtag) has a totaly different nboot/uboot than yours (it's Cobia_400_64). Another issue is that not all data from nand is copied into RAM, so if you like to play with your device, follow instructions from my previous post and run s3c2443_nr; this will make an exact nand copy, identical with the ones dumped on jtag.

Edited by - ablbd on 30 nov. 2010 20:25:56
Go to Top of Page

GelullaBarr

25 Posts

Posted - 30 nov. 2010 :  20:16:20  Show Profile  Reply with Quote
any ROM for Mio S600?
Go to Top of Page
Page: of 167 Previous Topic Topic Next Topic  
Previous Page | Next Page
 New Topic  Reply/Répondre
 Printer Friendly
Jump To:
GpsPasSion Forums © 2002-2014_GpsPasSion/Manzanite Go To Top Of Page
This page was generated in 0,91 seconds. Powered By: Snitz Forums 2000 Version 3.4.05